<!DOCTYPE html>
<html lang="en-US">
<head><style id="litespeed-optm-css-rules">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://urbanislandz.com/wp-content/litespeed/cssjs/9a7ca.css?ad11c" /><script id="litespeed-css-async-lib">!function(a){"use strict";var b=function(b,c,d){function e(a){return h.body?a():void setTimeout(function(){e(a)})}function f(){i.addEventListener&&i.removeEventListener("load",f),i.media=d||"all"}var g,h=a.document,i=h.createElement("link");if(c)g=c;else{var j=(h.body||h.getElementsByTagName("head")[0]).childNodes;g=j[j.length-1]}var k=h.styleSheets;i.rel="stylesheet",i.href=b,i.media="only x",e(function(){g.parentNode.insertBefore(i,c?g:g.nextSibling)});var l=function(a){for(var b=i.href,c=k.length;c--;)if(k[c].href===b)return a();setTimeout(function(){l(a)})};return i.addEventListener&&i.addEventListener("load",f),i.onloadcssdefined=l,l(f),i};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this);!function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(b){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<link rel="preload" href="https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf" as="font" crossorigin="anonymous">
<link rel="preload" href="https://urbanislandz.com/wp-content/themes/wpzoom-prime-news-child/fonts/primenews.woff" as="font" crossorigin="anonymous">
<link rel="preload" href="https://urbanislandz.com/wp-content/themes/wpzoom-prime-news-child/fonts/primenews.ttf" as="font" crossorigin="anonymous">
<link rel="preload" href="https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/fonts/primenews.ttf" as="font" crossorigin="anonymous">

<title>Tekashi 6ix9ine&#039;s Kidnapper Harv Gets Lengthy Sentence In Prison - Urban Islandz</title>
<meta name="description" content="Tekashi 6ix9ine&#039;s former gangmate and kidnapper has now received a prison sentence. After being convicted last year, Anthony &#039;Harv&#039; Ellison has finally" />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Tekashi 6ix9ine&#039;s Kidnapper Harv Gets Lengthy Sentence In Prison" />
<meta property="og:description" content="Tekashi 6ix9ine&#039;s former gangmate and kidnapper has now received a prison sentence. After being convicted last year, Anthony &#039;Harv&#039; Ellison has finally" />
<meta property="og:url" content="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2020-11-05T22:02:41+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="801" />
<meta property="fb:app_id" content="137673839610560" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://urbanislandz.com/#organization","name":"Urban Islandz","url":"https://urbanislandz.com/","sameAs":["https://www.facebook.com/urbanislandz","https://instagram.com/urbanislandz","https://www.youtube.com/user/CaribbeanUrbanMedia/","https://twitter.com/urbanislandz"],"logo":{"@type":"ImageObject","@id":"https://urbanislandz.com/#logo","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2018/01/Urbanislandz-logo-amp-1.png","width":300,"height":26,"caption":"Urban Islandz"},"image":{"@id":"https://urbanislandz.com/#logo"}},{"@type":"WebSite","@id":"https://urbanislandz.com/#website","url":"https://urbanislandz.com/","name":"Urban Islandz","description":"Dancehall &amp; Hip Hop","publisher":{"@id":"https://urbanislandz.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://urbanislandz.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#primaryimage","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots.jpg","width":1400,"height":801},{"@type":"WebPage","@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#webpage","url":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/","name":"Tekashi 6ix9ine's Kidnapper Harv Gets Lengthy Sentence In Prison - Urban Islandz","isPartOf":{"@id":"https://urbanislandz.com/#website"},"primaryImageOfPage":{"@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#primaryimage"},"datePublished":"2020-11-05T22:02:41+00:00","dateModified":"2020-11-05T22:02:41+00:00","description":"Tekashi 6ix9ine's former gangmate and kidnapper has now received a prison sentence. After being convicted last year, Anthony 'Harv' Ellison has finally","breadcrumb":{"@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/"]}]},{"@type":"BreadcrumbList","@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/","url":"https://urbanislandz.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/","url":"https://urbanislandz.com/category/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/hip-hop/","url":"https://urbanislandz.com/category/news/hip-hop/","name":"Hip Hop"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/","url":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/","name":"Tekashi 6ix9ine&#8217;s Kidnapper Harv Gets Lengthy Sentence In Prison"}}]},{"@type":["Article","NewsArticle"],"@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#article","isPartOf":{"@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#webpage"},"author":{"@id":"https://urbanislandz.com/#/schema/person/cf3a3c67f8ef6b9510239d925050c43e"},"headline":"Tekashi 6ix9ine&#8217;s Kidnapper Harv Gets Lengthy Sentence In Prison","datePublished":"2020-11-05T22:02:41+00:00","dateModified":"2020-11-05T22:02:41+00:00","mainEntityOfPage":{"@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#webpage"},"publisher":{"@id":"https://urbanislandz.com/#organization"},"image":{"@id":"https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/#primaryimage"},"keywords":"Tekashi 6ix9ine","articleSection":"Hip Hop","inLanguage":"en-US","copyrightYear":"2020","copyrightHolder":{"@id":"https://urbanislandz.com/#organization"}},{"@type":"Person","@id":"https://urbanislandz.com/#/schema/person/cf3a3c67f8ef6b9510239d925050c43e","name":"K.D. Anglin"}]}</script>

<link rel="amphtml" href="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/amp/" /><meta name="generator" content="AMP for WP 1.0.66.3" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<script type='text/javascript' src='https://urbanislandz.com/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/249670" />


<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-249670 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-10" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">facebook</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">rss</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-rss" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="inner-wrap">
<div class="musicad11">
<div class="musicad112">
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-249670" class="post-249670 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-tekashi">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/news/hip-hop/" rel="category tag">Hip Hop</a></span>
<h1 class="entry-title fn">Tekashi 6ix9ine&#8217;s Kidnapper Harv Gets Lengthy Sentence In Prison</h1> <div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/ksmith/" title="Posts by K.D. Anglin" rel="author">K.D. Anglin</a></span> <span class="entry-date"> <time class="entry-date" datetime="2020-11-05T17:02:41-05:00">November 5, 2020</time> </span> </div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1400" height="801" src="https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-300x172.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-700x401.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-600x343.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-200x114.jpg 200w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-400x230.jpg 400w" sizes="(max-width: 1400px) 100vw, 1400px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/ksmith/" title="Posts by K.D. Anglin" rel="author">K.D. Anglin</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Tekashi 6ix9ine&#8217;s former gangmate and kidnapper has now received a prison sentence.</p>
<p>After being convicted last year, <a href="https://urbanislandz.com/2020/09/03/tekashi-6ix9ines-kidnapper-anthony-harv-ellison-life-sentence/">Anthony &#8216;Harv&#8217; Ellison</a> has finally been sentenced for his crimes. Ellison who is a former gang mate and one-time manager of previously incarcerated New York rapper <a href="https://urbanislandz.com/artist/tekashi/">Tekashi 6ix9ine</a> was said by prosecutors to be the &#8220;the most culpable defendant convicted&#8221; in the Nine Trey Blood gang case when the group was prosecuted in 2019. </p>
<p>The same judge who presided over 6ix9ine&#8217;s trial, Judge Engelmayer has continued to handle the majority of the Nine Trey Blood gang members&#8217; fate. While prosecutors recommended 30 years to life for Harv, citing that he is a high-ranking member of the gang in court documents, the judge decided to go with another decision. Ellison was sentenced to two dozen years in the slammer plus five years of supervised release. In court on Wednesday (Nov. 4), the convict pleaded his case, telling Engelmayer, &#8220;I&#8217;m not an angel. But I&#8217;m not a monster either,&#8221; according to InnerCityPress on Twitter.</p>
<p>After detailing Anthony Ellison&#8217;s &#8220;horrific&#8221; crimes and the products of him existing wholly on the other side of the law for the past number of years, Judge Engelmayer handed down the heavy sentence. &#8220;I think 360 months is not necessary. I find that a sentence below this can accomplish what it must,&#8221; he said. &#8220;Mr Ellison, I sentence you to 24 years, followed by five years of supervised release. I hope when you get out you are not tempted to return to crime. The Department of Probation will have its eyes on you.&#8221;</p>
<p>Some of the crimes the judge made reference to during the sentencing were Snow Billy getting shot in the head, Mark Hovde&#8217;s face being slashed, and a gang fight at LAX. Ellison and another gang member were also accused of kidnapping 6ix9ine in July 2018 and robbing him of $750K in jewelry and approximately $35K in cash. The other defendant was sentenced to 17 years behind bars earlier this year. </p>
<p>Based on Harv&#8217;s crimes, do you think his sentence was harsh or lenient?</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-249670" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-249670" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/tekashi/" rel="tag">Tekashi 6ix9ine</a></div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-249684" class="post-249684 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-non tag-popcaan tag-stylo-g">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/11/05/popcaan-calls-out-stylo-g-video-hairstyle-beef/" title="Popcaan Calls Out Stylo G For Sharing Underwear Video, &#8220;bunup&#8221;">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/11/Popcaan-Stylo-G-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/11/05/popcaan-calls-out-stylo-g-video-hairstyle-beef/" title="Popcaan Calls Out Stylo G For Sharing Underwear Video, &#8220;bunup&#8221;">Popcaan Calls Out Stylo G For Sharing Underwear Video, &#8220;bunup&#8221;</a></h3>
<p>Dancehall artiste Stylo G is giving fans a peek at his new look as he teases upcoming music. Stylo G<a class="read-more" href="https://urbanislandz.com/2020/11/05/popcaan-calls-out-stylo-g-video-hairstyle-beef/">[Read More&#8230;]</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-249684" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/11/05/popcaan-calls-out-stylo-g-video-hairstyle-beef/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-249684" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/11/05/popcaan-calls-out-stylo-g-video-hairstyle-beef/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="entry-meta">
<span class="entry-date">9 mins ago</span> </div>
</div>
</div>
</div>
 <ul class="right_col_posts">
<li class="post-249680 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-trending tag-buju-banton">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/11/05/buju-banton-re-release-album-til-shiloh-december-new-songs/" title="Buju Banton Re-releasing Classic Album &#8220;Til Shiloh&#8221; In December With New Songs">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/02/Buju-Banton-new-photo-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Buju Banton new photo" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/11/05/buju-banton-re-release-album-til-shiloh-december-new-songs/" title="Buju Banton Re-releasing Classic Album &#8220;Til Shiloh&#8221; In December With New Songs">Buju Banton Re-releasing Classic Album &#8220;Til Shiloh&#8221; In December With New Songs</a></h3>
<div class="entry-meta">
<span class="entry-date">44 mins ago</span> </div>
</div>
</li>
<li class="post-249578 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-future">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/11/05/future-gifted-new-boo-dess-dior-an-ap-watch-hit-the-club-together/" title="Future Gifted New Boo Dess Dior An AP Watch, Hit The Club Together">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/11/Future-and-Dess-Dior-dating-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2020/11/Future-and-Dess-Dior-dating-400x230.jpg 400w, https://urbanislandz.com/wp-content/uploads/2020/11/Future-and-Dess-Dior-dating-300x173.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/11/Future-and-Dess-Dior-dating-700x403.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/11/Future-and-Dess-Dior-dating-768x442.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/11/Future-and-Dess-Dior-dating.jpg 1400w" sizes="(max-width: 400px) 100vw, 400px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/11/05/future-gifted-new-boo-dess-dior-an-ap-watch-hit-the-club-together/" title="Future Gifted New Boo Dess Dior An AP Watch, Hit The Club Together">Future Gifted New Boo Dess Dior An AP Watch, Hit The Club Together</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
<li class="post-249673 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-kodak-black tag-tory-lanez">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/11/05/kodak-black-taps-tory-lanez-feature-new-album-bill-israel-tracklist/" title="Kodak Black Taps Tory Lanez For Feature On New Album &#8220;Bill Israel&#8221;">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/03/Kodak-Black-2443-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Kodak Black" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/11/05/kodak-black-taps-tory-lanez-feature-new-album-bill-israel-tracklist/" title="Kodak Black Taps Tory Lanez For Feature On New Album &#8220;Bill Israel&#8221;">Kodak Black Taps Tory Lanez For Feature On New Album &#8220;Bill Israel&#8221;</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
<li class="post-249670 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-tekashi">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/" title="Tekashi 6ix9ine&#8217;s Kidnapper Harv Gets Lengthy Sentence In Prison">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-400x230.jpg 400w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-300x172.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-700x401.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-600x343.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots-200x114.jpg 200w, https://urbanislandz.com/wp-content/uploads/2019/10/Harv-and-Tekashi-mugshots.jpg 1400w" sizes="(max-width: 400px) 100vw, 400px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/11/05/tekashi-6ix9ines-kidnapper-harv-gets-lengthy-sentence-in-prison/" title="Tekashi 6ix9ine&#8217;s Kidnapper Harv Gets Lengthy Sentence In Prison">Tekashi 6ix9ine&#8217;s Kidnapper Harv Gets Lengthy Sentence In Prison</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments">Comments are closed.</p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-43"><h3 class="title">Whats Trending</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/11/05/buju-banton-re-release-album-til-shiloh-december-new-songs/"><img src="https://urbanislandz.com/wp-content/uploads/2019/02/Buju-Banton-new-photo-120x100.jpg" height="100" width="120" alt="Buju Banton Re-releasing Classic Album &#8220;Til Shiloh&#8221; In December With New Songs" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/11/05/buju-banton-re-release-album-til-shiloh-december-new-songs/">Buju Banton Re-releasing Classic Album &#8220;Til Shiloh&#8221; In December With New Songs</a></h3><br />44 mins ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/11/05/rapper-influencer-brax-dead-at-21-her-mother-confirm/"><img src="https://urbanislandz.com/wp-content/uploads/2020/11/Rapper-Brax-dead-120x100.jpg" height="100" width="120" alt="Rapper &#038; Influencer Brax Dead At 21, Her Mother Confirm" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/11/05/rapper-influencer-brax-dead-at-21-her-mother-confirm/">Rapper &#038; Influencer Brax Dead At 21, Her Mother Confirm</a></h3><br />4 hours ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/11/05/spragga-benz-tribute-slain-son-with-new-album-the-journey-chosen/"><img src="https://urbanislandz.com/wp-content/uploads/2019/10/Spragga-Benz-120x100.jpg" height="100" width="120" alt="Spragga Benz Tribute Slain Son With New Album &#8220;The Journey Chosen&#8221;" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/11/05/spragga-benz-tribute-slain-son-with-new-album-the-journey-chosen/">Spragga Benz Tribute Slain Son With New Album &#8220;The Journey Chosen&#8221;</a></h3><br />4 hours ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/11/05/popcaan-celebrates-sister-unruly-squid-birthday-with-rihanna-throwback-pic/"><img src="https://urbanislandz.com/wp-content/uploads/2020/08/Rihanna-Drake-Popcaan-squid-120x100.jpg" height="100" width="120" alt="Popcaan Celebrates Sister Unruly Squid Birthday With Rihanna Throwback Pic" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/11/05/popcaan-celebrates-sister-unruly-squid-birthday-with-rihanna-throwback-pic/">Popcaan Celebrates Sister Unruly Squid Birthday With Rihanna Throwback Pic</a></h3><br />7 hours ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/11/05/erica-mena-shares-adorable-photo-of-her-safarees-baby-girl-safire-majesty/"><img src="https://urbanislandz.com/wp-content/uploads/2020/11/Safaree-Erica-daughter-120x100.jpg" height="100" width="120" alt="Erica Mena Shares Adorable Photo Of Her &#038; Safaree&#8217;s Baby Girl Safire Majesty" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/11/05/erica-mena-shares-adorable-photo-of-her-safarees-baby-girl-safire-majesty/">Erica Mena Shares Adorable Photo Of Her &#038; Safaree&#8217;s Baby Girl Safire Majesty</a></h3><br />8 hours ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/11/05/popcaan-and-spice-remembers-j-capri-nearly-5-years-since-her-death/"><img src="https://urbanislandz.com/wp-content/uploads/2020/11/J-Capri-and-Popcaan-120x100.jpg" height="100" width="120" alt="Popcaan and Spice Remembers J Capri Nearly 5 Years Since Her Death" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/11/05/popcaan-and-spice-remembers-j-capri-nearly-5-years-since-her-death/">Popcaan and Spice Remembers J Capri Nearly 5 Years Since Her Death</a></h3><br />November 5, 2020<small></small> <br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" rel="nofollow noopener">

<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-feedburner" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3>
<ul>
<li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li>
<li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<span class="copyright">Copyright © 2020 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/cc813.js?f564b"></script></body>
</html>
