<!DOCTYPE html>
<html lang="en-US">
<head><link rel='stylesheet' id='primenews-google-fonts-css' href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2C700%2C700i%2Citalic%7CWork+Sans%3Aregular%2C600%2C700%7CLibre+Franklin%3Aregular%2C500%2C600&#038;ver=5.5.1' type='text/css' media='all' /><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/cssjs/b04a7.css?9cfc7" /><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/2f66e.js?d5bc7"></script><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">

<title>Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse - Urban Islandz</title>
<meta name="description" content="Megan Thee Stallion is hitting back at claims from one of her ex-boyfriends that she abused him. Megan Thee Stallion’s love life has always been a point" />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse - Urban Islandz" />
<meta property="og:description" content="Megan Thee Stallion is hitting back at claims from one of her ex-boyfriends that she abused him. Megan Thee Stallion’s love life has always been a point" />
<meta property="og:url" content="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2020-09-15T14:09:31+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion.jpg" />
<meta property="og:image:width" content="1250" />
<meta property="og:image:height" content="740" />
<meta property="fb:app_id" content="137673839610560" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://urbanislandz.com/#organization","name":"Urban Islandz","url":"https://urbanislandz.com/","sameAs":["https://www.facebook.com/urbanislandz","https://instagram.com/urbanislandz","https://www.youtube.com/user/CaribbeanUrbanMedia/","https://twitter.com/urbanislandz"],"logo":{"@type":"ImageObject","@id":"https://urbanislandz.com/#logo","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2018/01/Urbanislandz-logo-amp-1.png","width":300,"height":26,"caption":"Urban Islandz"},"image":{"@id":"https://urbanislandz.com/#logo"}},{"@type":"WebSite","@id":"https://urbanislandz.com/#website","url":"https://urbanislandz.com/","name":"Urban Islandz","description":"Dancehall &amp; Hip Hop","publisher":{"@id":"https://urbanislandz.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://urbanislandz.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#primaryimage","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion.jpg","width":1250,"height":740},{"@type":"WebPage","@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#webpage","url":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/","name":"Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse - Urban Islandz","isPartOf":{"@id":"https://urbanislandz.com/#website"},"primaryImageOfPage":{"@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#primaryimage"},"datePublished":"2020-09-15T14:09:31+00:00","dateModified":"2020-09-15T14:09:31+00:00","description":"Megan Thee Stallion is hitting back at claims from one of her ex-boyfriends that she abused him. Megan Thee Stallion\u2019s love life has always been a point","breadcrumb":{"@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/"]}]},{"@type":"BreadcrumbList","@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/","url":"https://urbanislandz.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/","url":"https://urbanislandz.com/category/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/hip-hop/","url":"https://urbanislandz.com/category/news/hip-hop/","name":"Hip Hop"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/","url":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/","name":"Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse"}}]},{"@type":["Article","NewsArticle"],"@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#article","isPartOf":{"@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#webpage"},"author":{"@id":"https://urbanislandz.com/#/schema/person/4205271a6efa4b282d3af005f742df95"},"headline":"Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse","datePublished":"2020-09-15T14:09:31+00:00","dateModified":"2020-09-15T14:09:31+00:00","mainEntityOfPage":{"@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#webpage"},"publisher":{"@id":"https://urbanislandz.com/#organization"},"image":{"@id":"https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/#primaryimage"},"keywords":"Megan Thee Stallion","articleSection":"Hip Hop,Trending","inLanguage":"en-US","copyrightYear":"2020","copyrightHolder":{"@id":"https://urbanislandz.com/#organization"}},{"@type":"Person","@id":"https://urbanislandz.com/#/schema/person/4205271a6efa4b282d3af005f742df95","name":"Sasha Star"}]}</script>

<link rel="amphtml" href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/amp/" /><meta name="generator" content="AMP for WP 1.0.62.2" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/246733" /><script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script>

<style type="text/css" id="wpzoom-prime-news-custom-css">
.site-footer{
	background-color:#000000;
	color:#cccccc;
}
.site-footer .widget .title{
	color:#cccccc;
}
.site-footer a{
	color:#cccccc;
}
body{
	font-family:"PT Sans";
}
.slides li h3{
	font-family:"PT Sans";
	font-weight:normal;
}
.widget h3.title{
	font-family:"PT Sans";
	font-weight:bold;
}
.single h1.entry-title{
	font-family:"PT Sans";
	font-size:36px;
}
.page h1.entry-title{
	font-size:36px;
}

</style>

<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-246733 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-10" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">facebook</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">rss</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-rss" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="inner-wrap">
<div class="musicad11">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-246733" class="post-246733 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-megan-thee-stallion">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/news/hip-hop/" rel="category tag">Hip Hop</a>, <a href="https://urbanislandz.com/category/trending/" rel="category tag">Trending</a></span>
<h1 class="entry-title fn">Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse</h1> <div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/sstar/" title="Posts by Sasha Star" rel="author">Sasha Star</a></span> <span class="entry-date"> <time class="entry-date" datetime="2020-09-15T10:09:31-04:00">September 15, 2020</time> </span> </div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1250" height="740" src="https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion.jpg 1250w, https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion-300x178.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion-700x414.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion-768x455.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion-220x130.jpg 220w" sizes="(max-width: 1250px) 100vw, 1250px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/sstar/" title="Posts by Sasha Star" rel="author">Sasha Star</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Megan Thee Stallion is hitting back at claims from one of her ex-boyfriends that she abused him. </p>
<p><a href="https://urbanislandz.com/artist/megan-thee-stallion/">Megan Thee Stallion’s</a> love life has always been a point of interest for the masses, with rumors following <a href="https://urbanislandz.com/2019/11/21/megan-thee-stallion-addresses-viral-video-with-trey-songz-i-aint-hit/">her of links to Trey Songz</a>, Tristan Thompson, <a href="https://urbanislandz.com/2020/02/11/g-eazy-confirms-he-and-megan-thee-stallion-are-just-friends/">G-Eazy</a>, and others. The only relationship which <a href="https://urbanislandz.com/2019/07/14/megan-thee-stallion-moneybagg-yo-dating-fever-movie/">Megan has publicly acknowledged was with Moneybagg Yo</a>, and the pair split up last year, with the “Said Sum” rapper having been dating Ari Fletcher for at least nine months. The latest rumor involving Megan’s name claims that the Houston hottie assaulted her ex, Karim York after the latter wrote a message about a former girlfriend who had abused him while on drugs. </p>
<p>In the letter, Karim York described the anonymous woman as having aimed a gun at him and strangled him, but that he is currently the one who is being painted as an abuser. The document contained no names, but that didn’t stop publications from pinning the accusations on the “<a href="https://urbanislandz.com/2020/08/07/cardi-b-and-megan-thee-stallion-drops-super-raunchy-wap-video/">WAP</a>” rapper. </p>
<p>With her own name now being linked to abuse, Megan Thee Stallion took to Instagram to clear her name. “Stop lying on me,” she said during the IG Live session. “That n**** not talkin&#8217; &#8217;bout me. Stop puttin&#8217; n****s on me. Stop making stories up. F*** y&#8217;all, &#8217;cause I&#8217;mma hit you with the facts every time you tell a lie.” To prove her point, Meg recorded a phone call with Karim in which he confirmed that his message was not about her and that he and the rapper are still friends. </p>
<p>Recently, Megan has been on the abused end of relationships, with it alleged that she was romantically involved with Tory Lanez at the time that he shot her in the foot. </p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CFJMZmghjr0/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/CFJMZmghjr0/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CFJMZmghjr0/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">#PressPlay: #MeganTheeStallion clears up rumors that she was abusive towards an ex. Thoughts? (swipe left)</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/hollywoodunlocked/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> HOLLYWOOD UNLOCKED</a> (@hollywoodunlocked) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-09-15T04:23:57+00:00">Sep 14, 2020 at 9:23pm PDT</time></p>
</div>
</blockquote>
<p></p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CFIy3uPDZrY/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/CFIy3uPDZrY/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CFIy3uPDZrY/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Megan’s old boo thang saying something, y’all ??? . via @milagrogramz UPDATE: Megan’s ex just stated via his IG story he wasn’t talking about Megan.</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/its_onsite/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> OnSite!</a> (@its_onsite) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-09-15T00:40:53+00:00">Sep 14, 2020 at 5:40pm PDT</time></p>
</div>
</blockquote>
<p></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-246733" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-246733" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/megan-thee-stallion/" rel="tag">Megan Thee Stallion</a></div>
<div class="related">
<div class="related-heading">More Megan Thee Stallion News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/09/14/megan-thee-stallion-gets-iced-out-jimmy-choo-x-timberland-boots/" rel="bookmark" title="Permanent Link to Megan Thee Stallion Gets Iced Out Jimmy Choo X Timberland Boots">Megan Thee Stallion Gets Iced Out Jimmy Choo X Timberland Boots</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/09/09/tory-lanez-drunk-megan-thee-stallion-text-apologize/" rel="bookmark" title="Permanent Link to Tory Lanez Claims He Was &#8216;Too Drunk&#8217; Apologize To Megan Thee Stallion In Text Messages">Tory Lanez Claims He Was &#8216;Too Drunk&#8217; Apologize To Megan Thee Stallion In Text Messages</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/09/07/slim-thug-still-trying-to-bag-megan-thee-stallion-let-me-be-yo-video-ho/" rel="bookmark" title="Permanent Link to Slim Thug Still Trying To Bag Megan Thee Stallion, &#8220;Let me be yo video ho&#8221;">Slim Thug Still Trying To Bag Megan Thee Stallion, &#8220;Let me be yo video ho&#8221;</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-246745" class="post-246745 post type-post status-publish format-standard has-post-thumbnail category-news">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/09/15/taraji-p-hensen-slips-into-tiny-white-bikini-for-her-50th-birthday-celebration/" title="Taraji P. Hensen Slips Into Tiny White Bikini For Her 50th Birthday Celebration">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/09/Taraji-P-Henson-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2020/09/Taraji-P-Henson-800x480.jpg 800w, https://urbanislandz.com/wp-content/uploads/2020/09/Taraji-P-Henson-300x180.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/09/Taraji-P-Henson-700x420.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/09/Taraji-P-Henson-768x461.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/09/Taraji-P-Henson.jpg 1250w" sizes="(max-width: 800px) 100vw, 800px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/09/15/taraji-p-hensen-slips-into-tiny-white-bikini-for-her-50th-birthday-celebration/" title="Taraji P. Hensen Slips Into Tiny White Bikini For Her 50th Birthday Celebration">Taraji P. Hensen Slips Into Tiny White Bikini For Her 50th Birthday Celebration</a></h3>
<p>Taraji P. Henson slipped into a tiny white bikini on a yacht as she celebrated her 50th birthday. Taraji P.<a class="read-more" href="https://urbanislandz.com/2020/09/15/taraji-p-hensen-slips-into-tiny-white-bikini-for-her-50th-birthday-celebration/">[Read More&#8230;]</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-246745" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/09/15/taraji-p-hensen-slips-into-tiny-white-bikini-for-her-50th-birthday-celebration/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-246745" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/09/15/taraji-p-hensen-slips-into-tiny-white-bikini-for-her-50th-birthday-celebration/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="entry-meta">
<span class="entry-date">16 mins ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-246741 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-juice-wrld tag-pop-smoke tag-tekashi">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/09/15/tekashi-6ix9ine-album-debuts-at-no-4-lower-than-juice-wrld-and-pop-smoke/" title="Tekashi 6ix9ine Album Debuts At No. 4 Lower Than Juice WRLD and Pop Smoke">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/09/Tekashi-6ix9ine-6-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/09/15/tekashi-6ix9ine-album-debuts-at-no-4-lower-than-juice-wrld-and-pop-smoke/" title="Tekashi 6ix9ine Album Debuts At No. 4 Lower Than Juice WRLD and Pop Smoke">Tekashi 6ix9ine Album Debuts At No. 4 Lower Than Juice WRLD and Pop Smoke</a></h3>
<div class="entry-meta">
<span class="entry-date">52 mins ago</span> </div>
</div>
</li>
<li class="post-246738 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-drake tag-lil-durk tag-tekashi">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/09/15/tekashi-6ix9ine-says-drake-is-the-goat-and-lil-durk-need-him-to-get-a-hit/" title="Tekashi 6ix9ine Says Drake Is The GOAT And Lil Durk Need Him To Get A Hit">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/08/Tekashi-69-Lil-Durk-beef-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/09/15/tekashi-6ix9ine-says-drake-is-the-goat-and-lil-durk-need-him-to-get-a-hit/" title="Tekashi 6ix9ine Says Drake Is The GOAT And Lil Durk Need Him To Get A Hit">Tekashi 6ix9ine Says Drake Is The GOAT And Lil Durk Need Him To Get A Hit</a></h3>
<div class="entry-meta">
<span class="entry-date">2 hours ago</span> </div>
</div>
</li>
<li class="post-246733 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-megan-thee-stallion">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/" title="Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/" title="Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse">Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse</a></h3>
<div class="entry-meta">
<span class="entry-date">2 hours ago</span> </div>
</div>
</li>
<li class="post-246724 post type-post status-publish format-standard has-post-thumbnail category-news category-trending tag-toots-hibbert">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/09/15/toots-hibbert-most-important-name-reggae-music-history/" title="Why Toots Hibbert Is The Most Important Name In Reggae Music">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/09/Toots-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/09/15/toots-hibbert-most-important-name-reggae-music-history/" title="Why Toots Hibbert Is The Most Important Name In Reggae Music">Why Toots Hibbert Is The Most Important Name In Reggae Music</a></h3>
<div class="entry-meta">
<span class="entry-date">September 15, 2020</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments">Comments are closed.</p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-43"><h3 class="title">Whats Trending</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/09/15/tekashi-6ix9ine-says-drake-is-the-goat-and-lil-durk-need-him-to-get-a-hit/"><img src="https://urbanislandz.com/wp-content/uploads/2020/08/Tekashi-69-Lil-Durk-beef-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine Says Drake Is The GOAT And Lil Durk Need Him To Get A Hit" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/09/15/tekashi-6ix9ine-says-drake-is-the-goat-and-lil-durk-need-him-to-get-a-hit/">Tekashi 6ix9ine Says Drake Is The GOAT And Lil Durk Need Him To Get A Hit</a></h3><br />2 hours ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/"><img src="https://urbanislandz.com/wp-content/uploads/2020/09/Megan-Thee-Stallion-120x100.jpg" height="100" width="120" alt="Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/09/15/megan-thee-stallion-speak-out-after-ex-boyfriend-accused-her-of-abuse/">Megan Thee Stallion Speak Out After Ex-Boyfriend Accused Her Of Abuse</a></h3><br />2 hours ago<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/09/15/toots-hibbert-most-important-name-reggae-music-history/"><img src="https://urbanislandz.com/wp-content/uploads/2020/09/Toots-120x100.jpg" height="100" width="120" alt="Why Toots Hibbert Is The Most Important Name In Reggae Music" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/09/15/toots-hibbert-most-important-name-reggae-music-history/">Why Toots Hibbert Is The Most Important Name In Reggae Music</a></h3><br />September 15, 2020<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/09/14/reggae-singer-jesse-royal-and-his-girlfriend-kandi-king-announces-pregnancy/"><img src="https://urbanislandz.com/wp-content/uploads/2020/09/Jesse-Royal-Kandi-King-120x100.jpg" height="100" width="120" alt="Reggae Singer Jesse Royal And His Girlfriend Kandi King Announces Pregnancy" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/09/14/reggae-singer-jesse-royal-and-his-girlfriend-kandi-king-announces-pregnancy/">Reggae Singer Jesse Royal And His Girlfriend Kandi King Announces Pregnancy</a></h3><br />September 14, 2020<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/09/14/50-cent-beefs-with-the-game-jimmy-henchman-to-be-chronicled-in-new-starz-series/"><img src="https://urbanislandz.com/wp-content/uploads/2019/11/The-Game-and-50-Cent-120x100.jpg" height="100" width="120" alt="50 Cent Beefs With The Game &#038; Jimmy Henchman To Be Chronicled In New STARZ Series" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/09/14/50-cent-beefs-with-the-game-jimmy-henchman-to-be-chronicled-in-new-starz-series/">50 Cent Beefs With The Game &#038; Jimmy Henchman To Be Chronicled In New STARZ Series</a></h3><br />September 14, 2020<small></small> <br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/09/14/ray-j-files-for-divorce-from-princess-love-wants-joint-custody-of-kids/"><img src="https://urbanislandz.com/wp-content/uploads/2019/11/Ray-J-and-Princess-Love-120x100.jpg" height="100" width="120" alt="Ray J Files For Divorce From Princess Love Wants Joint Custody Of Kids" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/09/14/ray-j-files-for-divorce-from-princess-love-wants-joint-custody-of-kids/">Ray J Files For Divorce From Princess Love Wants Joint Custody Of Kids</a></h3><br />September 14, 2020<small></small> <br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" rel="nofollow noopener">
<span class="zoom-social_icons-list-span social-icon socicon socicon-feedburner" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3>
<ul>
<li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li>
<li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<span class="copyright">Copyright © 2020 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://urbanislandz.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "ec7d9b8c64", post_id : 246733 } ); } ); /* ]]> */</script>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script async src="//www.instagram.com/embed.js"></script><script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/a4ff7.js?71040"></script></body>
</html>
