<!DOCTYPE html><html lang="en-US"><head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/css/e1fafb4f181c34091ed510c41c6e06f6.css?ver=e4a84" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://urbanislandz.com/xmlrpc.php"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><title>Rihanna &amp; Tems Show Each Other Love As &quot;Lift Me Up&quot; Dominate Streaming - Urban Islandz</title><meta name="description" content="Tems is expressing gratitude and giving Rihanna her flowers after the two recently worked on the &quot;Lift Me Up&quot; soundtrack for Black Panther: Wakanda" /><link rel="canonical" href="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Rihanna &amp; Tems Show Each Other Love As &quot;Lift Me Up&quot; Dominate Streaming" /><meta property="og:description" content="Tems is expressing gratitude and giving Rihanna her flowers after the two recently worked on the &quot;Lift Me Up&quot; soundtrack for Black Panther: Wakanda" /><meta property="og:url" content="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/" /><meta property="og:site_name" content="Urban Islandz" /><meta property="article:publisher" content="https://www.facebook.com/urbanislandz" /><meta property="article:published_time" content="2022-10-29T18:58:26+00:00" /><meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi.jpg" /><meta property="og:image:width" content="1600" /><meta property="og:image:height" content="1050" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Devi Seitaram" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@Rav1989" /><meta name="twitter:site" content="@urbanislandz" />
<style id='wp-block-library-theme-inline-css' type='text/css'>/**
 * Colors
 */
/**
 * Breakpoints & Media Queries
 */
/**
 * SCSS Variables.
 *
 * Please use variables from this sheet to ensure consistency across the UI.
 * Don't add to this sheet unless you're pretty sure the value will be reused in many places.
 * For example, don't add rules to this sheet that affect block visuals. It's purely for UI.
 */
/**
 * Colors
 */
/**
 * Fonts & basic variables.
 */
/**
 * Grid System.
 * https://make.wordpress.org/design/2019/10/31/proposal-a-consistent-spacing-system-for-wordpress/
 */
/**
 * Dimensions.
 */
/**
 * Shadows.
 */
/**
 * Editor widths.
 */
/**
 * Block & Editor UI.
 */
/**
 * Block paddings.
 */
/**
 * React Native specific.
 * These variables do not appear to be used anywhere else.
 */
/**
*  Converts a hex value into the rgb equivalent.
*
* @param {string} hex - the hexadecimal value to convert
* @return {string} comma separated rgb values
*/
/**
 * Breakpoint mixins
 */
/**
 * Long content fade mixin
 *
 * Creates a fading overlay to signify that the content is longer
 * than the space allows.
 */
/**
 * Focus styles.
 */
/**
 * Applies editor left position to the selector passed as argument
 */
/**
 * Styles that are reused verbatim in a few places
 */
/**
 * Allows users to opt-out of animations via OS-level preferences.
 */
/**
 * Reset default styles for JavaScript UI based pages.
 * This is a WP-admin agnostic reset
 */
/**
 * Reset the WP Admin page styles for Gutenberg-like pages.
 */
.wp-block-audio figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-audio figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-code {
  border: 1px solid #ccc;
  border-radius: 4px;
  font-family: Menlo, Consolas, monaco, monospace;
  padding: 0.8em 1em;
}

.wp-block-embed figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-embed figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.blocks-gallery-caption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .blocks-gallery-caption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-image figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-image figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-pullquote {
  border-top: 4px solid currentColor;
  border-bottom: 4px solid currentColor;
  margin-bottom: 1.75em;
  color: currentColor;
}
.wp-block-pullquote cite,
.wp-block-pullquote footer, .wp-block-pullquote__citation {
  color: currentColor;
  text-transform: uppercase;
  font-size: 0.8125em;
  font-style: normal;
}

.wp-block-quote {
  border-left: 0.25em solid currentColor;
  margin: 0 0 1.75em 0;
  padding-left: 1em;
}
.wp-block-quote cite,
.wp-block-quote footer {
  color: currentColor;
  font-size: 0.8125em;
  position: relative;
  font-style: normal;
}
.wp-block-quote.has-text-align-right {
  border-left: none;
  border-right: 0.25em solid currentColor;
  padding-left: 0;
  padding-right: 1em;
}
.wp-block-quote.has-text-align-center {
  border: none;
  padding-left: 0;
}
.wp-block-quote.is-style-plain, .wp-block-quote.is-style-large, .wp-block-quote.is-large {
  border: none;
}

.wp-block-search .wp-block-search__label {
  font-weight: bold;
}

:where(.wp-block-group.has-background) {
  padding: 1.25em 2.375em;
}

.wp-block-separator.has-css-opacity {
  opacity: 0.4;
}

.wp-block-separator {
  border: none;
  border-bottom: 2px solid currentColor;
  margin-left: auto;
  margin-right: auto;
}
.wp-block-separator.has-alpha-channel-opacity {
  opacity: initial;
}
.wp-block-separator:not(.is-style-wide):not(.is-style-dots) {
  width: 100px;
}
.wp-block-separator.has-background:not(.is-style-dots) {
  border-bottom: none;
  height: 1px;
}
.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots) {
  height: 2px;
}

.wp-block-table thead {
  border-bottom: 3px solid;
}
.wp-block-table tfoot {
  border-top: 3px solid;
}
.wp-block-table td,
.wp-block-table th {
  padding: 0.5em;
  border: 1px solid;
  word-break: normal;
}
.wp-block-table figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-table figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-video figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-video figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-template-part.has-background {
  padding: 1.25em 2.375em;
  margin-top: 0;
  margin-bottom: 0;
}</style><style id='global-styles-inline-css' type='text/css'>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</style><link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin /><link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin /><link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/289152" /><link rel='amphtml' href='https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/amp/' /><link rel="alternate" type="application/rss+xml" href="https://feeds.feedburner.com/urbanislandz" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi.jpg" />
<style type="text/css" id="wpzoom-prime-news-custom-css">.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#ffdcdc;
}
.header_misc a:hover{
	color:#ffdcdc;
}
.header_misc .navbar-wpz > .current-menu-item > a, .header_misc .navbar-wpz > .current_page_item > a{
	color:#ffdcdc;
}
.sb-search .sb-icon-search{
	color:#ffdcdc;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}</style> <script type="application/ld+json" class="saswp-schema-markup-output">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</script> <link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" /><meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" /><style type="text/css" id="wp-custom-css">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</style> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');</script> <meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" /></head><body class="post-template-default single single-post postid-289152 single-format-standard wp-custom-logo"><div class="page-wrap"><header class="site-header"><div class="inner-wrap"><div class="brand-wrap"><div class="navbar-brand-wpz"></div><div class="header_misc"></div></div></div><nav class="main-navbar" role="navigation"><div class="inner-wrap"><div class="side-panel-btn"></div><div class="navbar-header-main"><div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li><li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li><li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li><li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li><li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li><li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li><li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li></ul></div></div><div id="navbar-main"><div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="header_social1"><div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget"><ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels"><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" title="Facebook" rel=" noopener noreferrer">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" title="Twitter" rel=" noopener noreferrer">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" title="Instagram" rel=" noopener noreferrer">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a></li></ul></div></div><div id="sb-search" class="sb-search"><form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span></form></div><div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li><li id="menu-item-279817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279817"><a href="https://urbanislandz.com/category/dancehall/">DANCEHALL</a></li><li id="menu-item-279816" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279816"><a href="https://urbanislandz.com/category/hip-hop/">HIP HOP</a></li><li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li><li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li></ul></div></div></div></nav><div class="clear"></div></header><div class="musicad11 ad-label"><div class="musicad112"><style type="text/css">.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }</style><ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="inner-wrap"><main id="main" class="site-main" role="main"><div class="content-area"><article id="post-289152" class="post-289152 post type-post status-publish format-standard has-post-thumbnail category-news category-trending tag-rihanna tag-tems"><header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><span class="cat-links"><a href="https://urbanislandz.com/category/news/" rel="category tag">News</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/trending/" rel="category tag">Trending</a></span><h1 class="entry-title fn">Rihanna &#038; Tems Show Each Other Love As &#8220;Lift Me Up&#8221; Dominate Streaming</h1><div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a></span> <span class="entry-date">On: <time class="entry-date" datetime="2022-10-29T14:58:26-04:00">October 29, 2022 2:58 PM</time> </span></div></header><header class="entry-image"><div class="post-thumb">
<img width="1600" height="1050" src="https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi.jpg 1600w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-300x197.jpg 300w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-700x459.jpg 700w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-768x504.jpg 768w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-600x394.jpg 600w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-200x131.jpg 200w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-1536x1008.jpg 1536w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-760x500.jpg 760w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-165x109.jpg 165w" sizes="(max-width: 1600px) 100vw, 1600px" /></div></header><div class="entry_wrapper"><div class="entry-details"><ul class="entry-meta"><li class="post_author_side"><a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a> <span class="entry-author">Author</span></li></ul></div><div class="post_wrapper"><div class="entry-content"><p><a href="https://urbanislandz.com/artist/tems/">Tems</a> is expressing gratitude and giving <a href="https://urbanislandz.com/artist/rihanna/">Rihanna</a> her flowers after the two recently worked on the &#8220;Lift Me Up&#8221; soundtrack for <em><a href="https://urbanislandz.com/2022/10/27/rihanna-aap-rocky-turn-heads-at-black-panther-wakanda-forever-premiere/">Black Panther: Wakanda Forever</a></em> movie.</p><p>In a post on Friday afternoon, Tems, who is co-credited for writing the track along with the movie&#8217;s director Ryan Coogler and Ludwig Göransson, expressed satisfaction at Rihanna&#8217;s execution of the song.</p><p>&#8220;Blessed to have written this song in honour of Chadwick Boseman and even more blessed to hear the baddest @badgalriri voice it to perfection,&#8221; Tems wrote on Instagram.</p><p>Rihanna also showed love to the Nigerian artist as she commended her penmanship. &#8220;It&#8217;s the pen for me. love to you sistren,&#8221; Rihanna wrote with the muscle and heart emoji.</p><p>The &#8220;Free Mind&#8221; singer previously shared her adoration for Rihanna, covering the song as the director sought to bring the song to life.</p><p><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI4MDAiIGhlaWdodD0iOTgwIiB2aWV3Qm94PSIwIDAgODAwIDk4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526.webp" alt="tems comment" width="800" height="980" class="aligncenter size-full wp-image-289153" data-srcset="https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526.webp 800w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-245x300.webp 245w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-700x858.webp 700w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-768x941.webp 768w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-600x735.webp 600w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-200x245.webp 200w" data-sizes="(max-width: 800px) 100vw, 800px" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526.webp" alt="tems comment" width="800" height="980" class="aligncenter size-full wp-image-289153" srcset="https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526.webp 800w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-245x300.webp 245w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-700x858.webp 700w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-768x941.webp 768w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-600x735.webp 600w, https://urbanislandz.com/wp-content/uploads/2022/10/IMG_0526-200x245.webp 200w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></p><p>&#8220;After speaking with Ryan and hearing his direction for the film and the song, I wanted to write something that portrays a warm embrace from all the people that I&#8217;ve lost in my life,&#8221; she said of the track, which is speculated to convey emotions of loss and pain at the death of the <em>Black Panther</em> and actor <a href="https://urbanislandz.com/2020/08/28/chadwick-boseman-black-panther-star-dead-at-43-from-cancer-celebrities-reacts/">Chadwick Boseman who passed away in 2020</a>.</p><p>&#8220;I tried to imagine what it would feel like if I could sing to them now and express how much I miss them. Rihanna has been an inspiration to me so hearing her convey this song is a great honor,&#8221; she added.</p><p>In the meantime, &#8220;Lift Me Up&#8221; reached No. 1 on the US Apple Music charts, and it also entered the Top 10 chart on US iTunes on Friday afternoon.</p><p>In the meantime, other artists reacted to Tems&#8217; post as they co-signed the magical record.</p><p>&#8220;AMAZING,&#8221; H.E.R wrote.</p><p>&#8220;INCREDIBLE! Such a beautiful record,&#8221; SZA said.</p><p>Others who reacted were Sevyn, T.I., and Stefflon Don, among others.</p><p><iframe data-lazyloaded="1" src="about:blank" title="Rihanna - Lift Me Up" width="750" height="422" data-src="https://www.youtube.com/embed/Mx_OexsUI2M?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe><noscript><iframe title="Rihanna - Lift Me Up" width="750" height="422" src="https://www.youtube.com/embed/Mx_OexsUI2M?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></noscript></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-289152" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-289152" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class="clear"></div></div></div></div><div class="clear"></div><footer class="entry-footer"><div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/rihanna/" rel="tag">Rihanna</a>, <a href="https://urbanislandz.com/artist/tems/" rel="tag">Tems</a></div><div class="related"><div class="related-heading">More Rihanna News</div><ul class="related-list"><div class="related-title"><li>
<a href="https://urbanislandz.com/2022/10/28/rihannas-first-solo-song-in-6-years-lift-me-up-invoke-fans-emotions/" rel="bookmark" title="Permanent Link to Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions">Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions</a></li></div><div class="related-title"><li>
<a href="https://urbanislandz.com/2022/10/27/rihanna-aap-rocky-turn-heads-at-black-panther-wakanda-forever-premiere/" rel="bookmark" title="Permanent Link to Rihanna &#038; A$AP Rocky Turn Heads At &#8216;Black Panther Wakanda Forever&#8217; Premiere">Rihanna &#038; A$AP Rocky Turn Heads At &#8216;Black Panther Wakanda Forever&#8217; Premiere</a></li></div><div class="related-title"><li>
<a href="https://urbanislandz.com/2022/10/26/rihanna-tributes-chadwick-boseman-in-new-song-lift-me-up/" rel="bookmark" title="Permanent Link to Rihanna Tributes Chadwick Boseman In New Song &#8220;Lift Me Up&#8221;">Rihanna Tributes Chadwick Boseman In New Song &#8220;Lift Me Up&#8221;</a></li></div></ul></div><div class="postrelated"><div class="home-widgetized-sections"><div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3><div class="featured-grid-single"><div class="left_col_posts"><div id="post-289158" class="post-289158 post type-post status-publish format-standard has-post-thumbnail category-news tag-50-cent"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/10/29/50-cents-g-unit-films-finds-new-home-at-lusid-media-after-starz-exit/" title="50 Cent&#8217;s G-Unit Films Finds New Home At Lusid Media After Starz Exit">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2022/03/50-Cent-Joseph-800x480.jpeg" class="attachment-loop-large size-loop-large wp-post-image" alt="50 Cent Joseph Sikora" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/10/29/50-cents-g-unit-films-finds-new-home-at-lusid-media-after-starz-exit/" title="50 Cent&#8217;s G-Unit Films Finds New Home At Lusid Media After Starz Exit">50 Cent&#8217;s G-Unit Films Finds New Home At Lusid Media After Starz Exit</a></h3><div class="entry-meta"><span class="entry-date">2 hours ago</span></div></div></div></div><ul class="right_col_posts"><li class="post-289156 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news category-trending tag-berner tag-diddy tag-dr-dre tag-jay-z tag-kanye-west"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/10/29/diddy-replaced-kanye-west-on-hip-hops-billionaires-list/" title="Diddy Replaced Kanye West On Hip Hop&#8217;s Billionaires List">
<img width="500" height="300" src="https://urbanislandz.com/wp-content/uploads/2022/10/Diddy-12-500x300.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Diddy" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2022/10/Diddy-12-500x300.jpg 500w, https://urbanislandz.com/wp-content/uploads/2022/10/Diddy-12-800x480.jpg 800w" sizes="(max-width: 500px) 100vw, 500px" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/10/29/diddy-replaced-kanye-west-on-hip-hops-billionaires-list/" title="Diddy Replaced Kanye West On Hip Hop&#8217;s Billionaires List">Diddy Replaced Kanye West On Hip Hop&#8217;s Billionaires List</a></h3><div class="entry-meta"><span class="entry-date">3 hours ago</span></div></div></li><li class="post-289152 post type-post status-publish format-standard has-post-thumbnail category-news category-trending tag-rihanna tag-tems"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/" title="Rihanna &#038; Tems Show Each Other Love As &#8220;Lift Me Up&#8221; Dominate Streaming">
<img width="500" height="300" src="https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-500x300.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-500x300.jpg 500w, https://urbanislandz.com/wp-content/uploads/2022/10/Tems-RiRi-800x480.jpg 800w" sizes="(max-width: 500px) 100vw, 500px" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/10/29/rihanna-tems-show-each-other-love-as-lift-me-up-dominate-streaming/" title="Rihanna &#038; Tems Show Each Other Love As &#8220;Lift Me Up&#8221; Dominate Streaming">Rihanna &#038; Tems Show Each Other Love As &#8220;Lift Me Up&#8221; Dominate Streaming</a></h3><div class="entry-meta"><span class="entry-date">4 hours ago</span></div></div></li><li class="post-289148 post type-post status-publish format-standard has-post-thumbnail category-music category-news tag-wizkid"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/10/29/wizkid-announces-new-album-shares-video-for-new-song-money-love/" title="Wizkid Announces New Album, Shares Video for New Song “Money &#038; Love”">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/07/Wizkid-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/10/29/wizkid-announces-new-album-shares-video-for-new-song-money-love/" title="Wizkid Announces New Album, Shares Video for New Song “Money &#038; Love”">Wizkid Announces New Album, Shares Video for New Song “Money &#038; Love”</a></h3><div class="entry-meta"><span class="entry-date">5 hours ago</span></div></div></li><li class="post-289145 post type-post status-publish format-standard has-post-thumbnail category-feature category-music category-news tag-rihanna"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/10/28/rihannas-first-solo-song-in-6-years-lift-me-up-invoke-fans-emotions/" title="Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/06/Rihanna9754-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Rihanna" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/10/28/rihannas-first-solo-song-in-6-years-lift-me-up-invoke-fans-emotions/" title="Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions">Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions</a></h3><div class="entry-meta"><span class="entry-date">October 28, 2022</span></div></div></li></ul></div><div class="clear">&nbsp;</div></div></div></div><div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div> <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <div class="clear"></div></footer><div class="clear"></div></article><div id="comments"><p class="nocomments"></p></div></div><section id="site-sidebar"><div class="adv_side"><div class="musicad2 ad-label"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Features</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/10/28/rihannas-first-solo-song-in-6-years-lift-me-up-invoke-fans-emotions/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/06/Rihanna9754-140x100.jpeg" height="100" width="140" alt="Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/06/Rihanna9754-140x100.jpeg" height="100" width="140" alt="Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/10/28/rihannas-first-solo-song-in-6-years-lift-me-up-invoke-fans-emotions/">Rihanna&#8217;s First Solo Song In 6 Years &#8220;Lift Me Up&#8221; Invoke Fans Emotions</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/10/26/kanye-west-adidas-continues-selling-yeezy-george-floyd-brother-pause-lawsuit/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2020/10/Kanye-West-6-140x100.jpg" height="100" width="140" alt="Kanye West: Adidas Continues Selling Yeezy, George Floyd Brother Pause Lawsuit" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2020/10/Kanye-West-6-140x100.jpg" height="100" width="140" alt="Kanye West: Adidas Continues Selling Yeezy, George Floyd Brother Pause Lawsuit" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/10/26/kanye-west-adidas-continues-selling-yeezy-george-floyd-brother-pause-lawsuit/">Kanye West: Adidas Continues Selling Yeezy, George Floyd Brother Pause Lawsuit</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/10/25/rihanna-releasing-reggae-inspired-song-for-black-panther-wakanda-forever-on-friday/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2020/10/Rihanna-85-140x100.jpg" height="100" width="140" alt="Rihanna Releasing Reggae Inspired Song For &#8216;Black Panther: Wakanda Forever&#8217; On Friday" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2020/10/Rihanna-85-140x100.jpg" height="100" width="140" alt="Rihanna Releasing Reggae Inspired Song For &#8216;Black Panther: Wakanda Forever&#8217; On Friday" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/10/25/rihanna-releasing-reggae-inspired-song-for-black-panther-wakanda-forever-on-friday/">Rihanna Releasing Reggae Inspired Song For &#8216;Black Panther: Wakanda Forever&#8217; On Friday</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/10/25/shaggy-invites-jamaican-artists-to-learn-from-his-mistakes-anybody-can-come/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/02/Shaggy-443-140x100.jpg" height="100" width="140" alt="Shaggy Invites Jamaican Artists To Learn From His Mistakes: &#8220;Anybody Can Come&#8221;" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/02/Shaggy-443-140x100.jpg" height="100" width="140" alt="Shaggy Invites Jamaican Artists To Learn From His Mistakes: &#8220;Anybody Can Come&#8221;" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/10/25/shaggy-invites-jamaican-artists-to-learn-from-his-mistakes-anybody-can-come/">Shaggy Invites Jamaican Artists To Learn From His Mistakes: &#8220;Anybody Can Come&#8221;</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/10/25/50-cent-cuban-link-split-unfollow-delete-each-other-photos-instagram/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/05/50-Cent-Cuban-Link-3-140x100.jpeg" height="100" width="140" alt="50 Cent and Cuban Link Split, Unfollow and Delete Each Other Photos On IG" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/05/50-Cent-Cuban-Link-3-140x100.jpeg" height="100" width="140" alt="50 Cent and Cuban Link Split, Unfollow and Delete Each Other Photos On IG" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/10/25/50-cent-cuban-link-split-unfollow-delete-each-other-photos-instagram/">50 Cent and Cuban Link Split, Unfollow and Delete Each Other Photos On IG</a></h3><br /></div><div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div><div class="clear"></div></section><div class="clear"></div></main></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="inner-wrap"><div class="footer-widgets widgets"><div class="widget-areas"><div class="column"><div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3><ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded"><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" title="Facebook" rel=" noopener noreferrer">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" title="Twitter" rel=" noopener noreferrer">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" title="Instagram" rel=" noopener noreferrer">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a></li></ul><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li><li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li><li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li><li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li><li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li><li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li></ul></div><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li><li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li><li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li></ul></div><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_text" id="text-88"><h3 class="title">URBANISLANDZ.COM</h3><div class="textwidget"><p>Advancing the culture and building bridges. Latest dancehall and hip hop news and music at your fingertips.</p></div><div class="clear"></div></div><div class="clear"></div></div></div></div><div class="site-info"><div class="site-copyright"><div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li><li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li></ul></div>
<span class="copyright">Copyright © 2022 Urban Islandz</span></div></div></div></footer></div> <script type='text/javascript' id='primenews-script-js-extra'>/*  */
var zoomOptions = {"slideshow_auto":"","slideshow_speed":"4000"};
/*  */</script> <script type='text/javascript' id='sharing-js-js-extra'>/*  */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/*  */</script> <script type='text/javascript' id='sharing-js-js-after'>var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();</script> <script data-no-optimize="1" defer>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</script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/js/97ad905b31531d646c3e4f8e09f3008a.js?ver=e4a84"></script></body></html>

