<!DOCTYPE html><html lang="en-US"><head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/css/ced2c764a5f1ea8c0b906ed4d26ee837.css?ver=a4f24" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://urbanislandz.com/xmlrpc.php"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><title>Sidney Starr Reacts To Rapper Chingy&#039;s New Interview About Their Past Issues - Urban Islandz</title><meta name="description" content="Sidney Starr says she&#039;s sorry for the lies she told about Chingy in the past. In an interview this week, Chingy spoke about how the claims by Starr, who" /><link rel="canonical" href="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Sidney Starr Reacts To Rapper Chingy&#039;s New Interview About Their Past Issues" /><meta property="og:description" content="Sidney Starr says she&#039;s sorry for the lies she told about Chingy in the past. In an interview this week, Chingy spoke about how the claims by Starr, who" /><meta property="og:url" content="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/" /><meta property="og:site_name" content="Urban Islandz" /><meta property="article:publisher" content="https://www.facebook.com/urbanislandz" /><meta property="article:published_time" content="2022-11-10T01:31:47+00:00" /><meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2022/11/Chingy.webp" /><meta property="og:image:width" content="1400" /><meta property="og:image:height" content="920" /><meta property="og:image:type" content="image/webp" /><meta name="author" content="Soje Leslie" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@urbanislandz" /><meta name="twitter:site" content="@urbanislandz" />
<style id='wp-block-library-theme-inline-css' type='text/css'>/**
 * Colors
 */
/**
 * Breakpoints & Media Queries
 */
/**
 * SCSS Variables.
 *
 * Please use variables from this sheet to ensure consistency across the UI.
 * Don't add to this sheet unless you're pretty sure the value will be reused in many places.
 * For example, don't add rules to this sheet that affect block visuals. It's purely for UI.
 */
/**
 * Colors
 */
/**
 * Fonts & basic variables.
 */
/**
 * Grid System.
 * https://make.wordpress.org/design/2019/10/31/proposal-a-consistent-spacing-system-for-wordpress/
 */
/**
 * Dimensions.
 */
/**
 * Shadows.
 */
/**
 * Editor widths.
 */
/**
 * Block & Editor UI.
 */
/**
 * Block paddings.
 */
/**
 * React Native specific.
 * These variables do not appear to be used anywhere else.
 */
/**
*  Converts a hex value into the rgb equivalent.
*
* @param {string} hex - the hexadecimal value to convert
* @return {string} comma separated rgb values
*/
/**
 * Breakpoint mixins
 */
/**
 * Long content fade mixin
 *
 * Creates a fading overlay to signify that the content is longer
 * than the space allows.
 */
/**
 * Focus styles.
 */
/**
 * Applies editor left position to the selector passed as argument
 */
/**
 * Styles that are reused verbatim in a few places
 */
/**
 * Allows users to opt-out of animations via OS-level preferences.
 */
/**
 * Reset default styles for JavaScript UI based pages.
 * This is a WP-admin agnostic reset
 */
/**
 * Reset the WP Admin page styles for Gutenberg-like pages.
 */
.wp-block-audio figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-audio figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-audio {
  margin: 0 0 1em 0;
}

.wp-block-code {
  border: 1px solid #ccc;
  border-radius: 4px;
  font-family: Menlo, Consolas, monaco, monospace;
  padding: 0.8em 1em;
}

.wp-block-embed figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-embed figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-embed {
  margin: 0 0 1em 0;
}

.blocks-gallery-caption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .blocks-gallery-caption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-image figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-image figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-image {
  margin: 0 0 1em 0;
}

.wp-block-pullquote {
  border-top: 4px solid currentColor;
  border-bottom: 4px solid currentColor;
  margin-bottom: 1.75em;
  color: currentColor;
}
.wp-block-pullquote cite,
.wp-block-pullquote footer, .wp-block-pullquote__citation {
  color: currentColor;
  text-transform: uppercase;
  font-size: 0.8125em;
  font-style: normal;
}

.wp-block-quote {
  border-left: 0.25em solid currentColor;
  margin: 0 0 1.75em 0;
  padding-left: 1em;
}
.wp-block-quote cite,
.wp-block-quote footer {
  color: currentColor;
  font-size: 0.8125em;
  position: relative;
  font-style: normal;
}
.wp-block-quote.has-text-align-right {
  border-left: none;
  border-right: 0.25em solid currentColor;
  padding-left: 0;
  padding-right: 1em;
}
.wp-block-quote.has-text-align-center {
  border: none;
  padding-left: 0;
}
.wp-block-quote.is-style-plain, .wp-block-quote.is-style-large, .wp-block-quote.is-large {
  border: none;
}

.wp-block-search .wp-block-search__label {
  font-weight: bold;
}

.wp-block-search__button {
  border: 1px solid #ccc;
  padding: 0.375em 0.625em;
}

:where(.wp-block-group.has-background) {
  padding: 1.25em 2.375em;
}

.wp-block-separator.has-css-opacity {
  opacity: 0.4;
}

.wp-block-separator {
  border: none;
  border-bottom: 2px solid currentColor;
  margin-left: auto;
  margin-right: auto;
}
.wp-block-separator.has-alpha-channel-opacity {
  opacity: initial;
}
.wp-block-separator:not(.is-style-wide):not(.is-style-dots) {
  width: 100px;
}
.wp-block-separator.has-background:not(.is-style-dots) {
  border-bottom: none;
  height: 1px;
}
.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots) {
  height: 2px;
}

.wp-block-table {
  margin: "0 0 1em 0";
}
.wp-block-table thead {
  border-bottom: 3px solid;
}
.wp-block-table tfoot {
  border-top: 3px solid;
}
.wp-block-table td,
.wp-block-table th {
  padding: 0.5em;
  border: 1px solid;
  word-break: normal;
}
.wp-block-table figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-table figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-video figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-video figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-video {
  margin: 0 0 1em 0;
}

.wp-block-template-part.has-background {
  padding: 1.25em 2.375em;
  margin-top: 0;
  margin-bottom: 0;
}</style><style id='global-styles-inline-css' type='text/css'>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</style><link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin /><link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin /><link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/289401" /><link rel='amphtml' href='https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/amp/' /><link rel="alternate" type="application/rss+xml" href="https://feeds.feedburner.com/urbanislandz" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2022/11/Chingy.webp" />
<style type="text/css" id="wpzoom-prime-news-custom-css">.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#ffdcdc;
}
.header_misc a:hover{
	color:#ffdcdc;
}
.header_misc .navbar-wpz > .current-menu-item > a, .header_misc .navbar-wpz > .current_page_item > a{
	color:#ffdcdc;
}
.sb-search .sb-icon-search{
	color:#ffdcdc;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}</style> <script type="application/ld+json" class="saswp-schema-markup-output">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</script> <link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" /><meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" /><style type="text/css" id="wp-custom-css">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</style> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');</script> <meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" /> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6028873096749132" crossorigin="anonymous"></script> </head><body class="post-template-default single single-post postid-289401 single-format-standard wp-custom-logo"><div class="page-wrap"><header class="site-header"><div class="inner-wrap"><div class="brand-wrap"><div class="navbar-brand-wpz"></div><div class="header_misc"></div></div></div><nav class="main-navbar" role="navigation"><div class="inner-wrap"><div class="side-panel-btn"></div><div class="navbar-header-main"><div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" decoding="async" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li><li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li><li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li><li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li><li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li><li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li><li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li></ul></div></div><div id="navbar-main"><div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" decoding="async" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="header_social1"><div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget"><ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels"><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" title="Facebook" rel=" noopener noreferrer">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" title="Twitter" rel=" noopener noreferrer">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" title="Instagram" rel=" noopener noreferrer">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a></li></ul></div></div><div id="sb-search" class="sb-search"><form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span></form></div><div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li><li id="menu-item-279817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279817"><a href="https://urbanislandz.com/category/dancehall/">DANCEHALL</a></li><li id="menu-item-279816" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-279816"><a href="https://urbanislandz.com/category/hip-hop/">HIP HOP</a></li><li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li><li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li></ul></div></div></div></nav><div class="clear"></div></header><div class="musicad11 ad-label"><div class="musicad112"><style type="text/css">.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }</style><ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="inner-wrap"><main id="main" class="site-main" role="main"><div class="content-area"><article id="post-289401" class="post-289401 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-chingy"><header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><span class="cat-links"><a href="https://urbanislandz.com/category/hip-hop/" rel="category tag">Hip Hop</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/news/" rel="category tag">News</a></span><h1 class="entry-title fn">Sidney Starr Reacts To Rapper Chingy&#8217;s New Interview About Their Past Issues</h1><div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/njcuser/" title="Posts by Soje Leslie" rel="author">Soje Leslie</a></span> <span class="entry-date">On: <time class="entry-date" datetime="2022-11-09T20:31:47-05:00">November 9, 2022 8:31 PM</time> </span></div></header><header class="entry-image"><div class="post-thumb">
<img width="1400" height="920" src="https://urbanislandz.com/wp-content/uploads/2022/11/Chingy.webp" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Chingy" decoding="async" srcset="https://urbanislandz.com/wp-content/uploads/2022/11/Chingy.webp 1400w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-300x197.webp 300w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-700x460.webp 700w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-768x505.webp 768w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-600x394.webp 600w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-200x131.webp 200w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-760x500.webp 760w, https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-165x109.webp 165w" sizes="(max-width: 1400px) 100vw, 1400px" /></div></header><div class="entry_wrapper"><div class="entry-details"><ul class="entry-meta"><li class="post_author_side"><a href="https://urbanislandz.com/author/njcuser/" title="Posts by Soje Leslie" rel="author">Soje Leslie</a> <span class="entry-author">Author</span></li></ul></div><div class="post_wrapper"><div class="entry-content"><p>Sidney Starr says she&#8217;s sorry for the lies she told about Chingy in the past. In an interview this week, <a href="https://urbanislandz.com/artist/chingy/">Chingy</a> spoke about how the claims by Starr, who is transgender, destroyed his career after fans believed that he was romantically involved with Starr.</p><p>In 2012, a rumor surfaced that Chingy had dated a transgender person. He says he later lost a record deal because of the bad publicity. He later shared that he had met Starr, who appeared as a female backup dancer for Ludacris and obliged after she asked for a photo.</p><p>Starr later used the photo to support her claim that she and the artist date.</p><p>In his Vlad TV interview this week, the artist shared that after the rumors by Starr, he was traumatized and became afraid to pose with his gay fans out of fear that they may also spread rumors about him.</p><p>He said that he eventually overcame the stigma that overshadowed his career.</p><p>&#8220;I was about to stop taking pictures with homosexual individuals because I felt like they may try to do something like that. But Then I said you know what, everybody else ain&#8217;t do something to me, I ain&#8217;t gonna do that. I have fans that are homosexual, I have nothing against them. So I took that risk or chance because I appreciate my fans,&#8221; he said.</p><p>Starr, who got wind of the comments by Chingy, also claimed to have apologized to the artist 10 years ago and said she had made the comments 10 years ago.</p><p>&#8220;Wow! I was young Af and made a mistake! My god! I will never be able to move on from this! SMH I&#8217;m done.&#8221;</p><p>In other comments, she wrote, &#8220;I am definitely remorseful I was then and I still am now,!!! I am truly sorry! Yall don&#8217;t even know me as a person how do you know what I truly feel ???? Like I said I&#8217;m dammed if I do and I&#8217;m dammed if I don&#8217;t. I&#8217;m not looking for clarity from nobody but God knows my heart and the people who are close to me! So if y&#8217;all want to continue to bash me for something I owned up too .go right ahead … I&#8217;m strong and I will get through if I could turn back the hands if time I would! But I&#8217;m human and sometimes as humans we make mistakes!!!! Nobody is perfect! And I&#8217;m not playing the victim… and I&#8217;m not saying my apology changed anything.. but I owned up to it… smh.&#8221;</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/reel/CkvfhLrAtAr/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/reel/CkvfhLrAtAr/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"></p><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div><p></a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/reel/CkvfhLrAtAr/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by The Neighborhood Talk (@theneighborhoodtalk)</a></p></div></blockquote><p><script async src="//platform.instagram.com/en_US/embeds.js"></script></p><p>Meanwhile, fans of the &#8220;Right Thurr&#8221; artist dragged Sidney for her actions.</p><p>&#8220;You&#8217;re mistake cost him a career while you are running around on reality shows with a career. That apology should&#8217;ve been said the moment you started that rumor. Being young isn&#8217;t an excuse! You flat out lied and damaged a black man&#8217;s promising career. He has never recovered since but you have that&#8217;s the messed up part,&#8221; one fan wrote.</p><p>&#8220;this was not a mistake you knew what you were doing and you ruined his life he should&#8217;ve sued you for everything! You do clown ish to this day you&#8217;re literally not sorry. You make the community both black and [pride] look bad,&#8221; Another said.</p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-289401" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-289401" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class="clear"></div></div></div></div><div class="clear"></div><footer class="entry-footer"><div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/chingy/" rel="tag">Chingy</a></div><div class="related"><div class="related-heading">More Chingy News</div><ul class="related-list"><div class="related-title"><li>
<a href="https://urbanislandz.com/2022/03/01/chingy-unbothered-by-racist-meme-shared-by-estee-lauder-exec-john-demsey/" rel="bookmark" title="Permanent Link to Chingy Unbothered By Racist Meme Shared By Estée Lauder Exec John Demsey">Chingy Unbothered By Racist Meme Shared By Estée Lauder Exec John Demsey</a></li></div><div class="related-title"><li>
<a href="https://urbanislandz.com/2019/10/03/chingy-calls-tiffany-haddish-a-liar-over-hookup-claims-she-claps-back/" rel="bookmark" title="Permanent Link to Chingy Calls Tiffany Haddish A Liar Over Hookup Claims, She Claps Back">Chingy Calls Tiffany Haddish A Liar Over Hookup Claims, She Claps Back</a></li></div><div class="related-title"><li>
<a href="https://urbanislandz.com/2019/10/02/right-thurr-rapper-chingy-opens-up-about-career-ending-mistake/" rel="bookmark" title="Permanent Link to &#8220;Right Thurr&#8221; Rapper Chingy Talks Career Ending Mistake &#038; Transgender Model Starr">&#8220;Right Thurr&#8221; Rapper Chingy Talks Career Ending Mistake &#038; Transgender Model Starr</a></li></div></ul></div><div class="postrelated"><div class="home-widgetized-sections"><div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3><div class="featured-grid-single"><div class="left_col_posts"><div id="post-289401" class="post-289401 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-chingy"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/" title="Sidney Starr Reacts To Rapper Chingy&#8217;s New Interview About Their Past Issues">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2022/11/Chingy-800x480.webp" class="attachment-loop-large size-loop-large wp-post-image" alt="Chingy" decoding="async" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/11/09/sidney-starr-reacts-to-rapper-chingys-new-interview-about-their-past-issues/" title="Sidney Starr Reacts To Rapper Chingy&#8217;s New Interview About Their Past Issues">Sidney Starr Reacts To Rapper Chingy&#8217;s New Interview About Their Past Issues</a></h3><div class="entry-meta"><span class="entry-date">5 seconds ago</span></div></div></div></div><ul class="right_col_posts"><li class="post-289395 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-feature category-news tag-spice"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/11/09/spice-breaks-silence-on-her-health-reveals-she-had-damaged-hernia/" title="Spice Speak On Her Health Reveals She Had Damaged Hernia, Sepsis">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/11/Spice-recoverying--400x230.webp" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Spice" decoding="async" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/11/09/spice-breaks-silence-on-her-health-reveals-she-had-damaged-hernia/" title="Spice Speak On Her Health Reveals She Had Damaged Hernia, Sepsis">Spice Speak On Her Health Reveals She Had Damaged Hernia, Sepsis</a></h3><div class="entry-meta"><span class="entry-date">6 hours ago</span></div></div></li><li class="post-289387 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-kanye-west"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/11/09/bandman-kevo-roasted-for-wlm-elon-musk-and-kanye-west-tattoos/" title="Bandman Kevo Roasted For WLM, Elon Musk and Kanye West Tattoos">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/11/Bandman-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Bandman Kevo" decoding="async" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/11/09/bandman-kevo-roasted-for-wlm-elon-musk-and-kanye-west-tattoos/" title="Bandman Kevo Roasted For WLM, Elon Musk and Kanye West Tattoos">Bandman Kevo Roasted For WLM, Elon Musk and Kanye West Tattoos</a></h3><div class="entry-meta"><span class="entry-date">6 hours ago</span></div></div></li><li class="post-289389 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news category-trending tag-kenneth-petty tag-nicki-minaj"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/11/09/nicki-minaj-responds-to-tik-toker-claiming-her-sons-name-is-jacob/" title="Nicki Minaj Responds To Tik Toker Claiming Her Son&#8217;s Name Is Jacob">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/11/Petty-Nicki-son-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Petty Nicki Minaj son" decoding="async" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/11/09/nicki-minaj-responds-to-tik-toker-claiming-her-sons-name-is-jacob/" title="Nicki Minaj Responds To Tik Toker Claiming Her Son&#8217;s Name Is Jacob">Nicki Minaj Responds To Tik Toker Claiming Her Son&#8217;s Name Is Jacob</a></h3><div class="entry-meta"><span class="entry-date">7 hours ago</span></div></div></li><li class="post-289280 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-baby-racks tag-gucci-mane"><div class="post-thumb">
<a href="https://urbanislandz.com/2022/11/09/rapper-baby-racks-addresses-gucci-mane-dropping-him-from-1017/" title="Rapper Baby Racks Addresses Gucci Mane Dropping Him From 1017">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/11/Baby-Racks-Gucci-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Baby Racks Gucci" decoding="async" loading="lazy" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2022/11/09/rapper-baby-racks-addresses-gucci-mane-dropping-him-from-1017/" title="Rapper Baby Racks Addresses Gucci Mane Dropping Him From 1017">Rapper Baby Racks Addresses Gucci Mane Dropping Him From 1017</a></h3><div class="entry-meta"><span class="entry-date">11 hours ago</span></div></div></li></ul></div><div class="clear">&nbsp;</div></div></div></div><div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div> <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <div class="clear"></div></footer><div class="clear"></div></article><div id="comments"><p class="nocomments"></p></div></div><section id="site-sidebar"><div class="adv_side"><div class="musicad2 ad-label"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div><div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Features</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/11/09/spice-breaks-silence-on-her-health-reveals-she-had-damaged-hernia/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/11/Spice-recoverying--140x100.webp" height="100" width="140" alt="Spice Speak On Her Health Reveals She Had Damaged Hernia, Sepsis" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/11/Spice-recoverying--140x100.webp" height="100" width="140" alt="Spice Speak On Her Health Reveals She Had Damaged Hernia, Sepsis" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/11/09/spice-breaks-silence-on-her-health-reveals-she-had-damaged-hernia/">Spice Speak On Her Health Reveals She Had Damaged Hernia, Sepsis</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/11/07/rihanna-was-back-working-3-days-after-giving-birth-talks-motherhood/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/11/Rihanna44343-140x100.jpeg" height="100" width="140" alt="Rihanna Was Back Working 3 Days After Giving Birth, Talks Motherhood" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/11/Rihanna44343-140x100.jpeg" height="100" width="140" alt="Rihanna Was Back Working 3 Days After Giving Birth, Talks Motherhood" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/11/07/rihanna-was-back-working-3-days-after-giving-birth-talks-motherhood/">Rihanna Was Back Working 3 Days After Giving Birth, Talks Motherhood</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/11/07/former-bob-marley-and-the-wailers-keyboardist-tyrone-downie-dead-at-66/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/11/Tyrone-Downie-140x100.jpeg" height="100" width="140" alt="Former Bob Marley and The Wailers Keyboardist Tyrone Downie Dead At 66" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/11/Tyrone-Downie-140x100.jpeg" height="100" width="140" alt="Former Bob Marley and The Wailers Keyboardist Tyrone Downie Dead At 66" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/11/07/former-bob-marley-and-the-wailers-keyboardist-tyrone-downie-dead-at-66/">Former Bob Marley and The Wailers Keyboardist Tyrone Downie Dead At 66</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/11/07/dancehall-star-demarco-says-he-is-done-with-music-promoting-violence/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/06/Demarco-music-140x100.jpeg" height="100" width="140" alt="Dancehall Star Demarco Says He Is Done With Music Promoting Violence" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/06/Demarco-music-140x100.jpeg" height="100" width="140" alt="Dancehall Star Demarco Says He Is Done With Music Promoting Violence" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/11/07/dancehall-star-demarco-says-he-is-done-with-music-promoting-violence/">Dancehall Star Demarco Says He Is Done With Music Promoting Violence</a></h3><br /></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/11/04/drake-diss-kanye-west-ice-spice-thee-stallion-serena-williams-husband-on-her-loss/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/10/Drake-live-140x100.jpeg" height="100" width="140" alt="Drake Diss Kanye West, Ice Spice, Thee Stallion &#038; Serena Williams&#8217; Husband on &#8216;Her Loss&#8217;" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/10/Drake-live-140x100.jpeg" height="100" width="140" alt="Drake Diss Kanye West, Ice Spice, Thee Stallion &#038; Serena Williams&#8217; Husband on &#8216;Her Loss&#8217;" /></noscript></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2022/11/04/drake-diss-kanye-west-ice-spice-thee-stallion-serena-williams-husband-on-her-loss/">Drake Diss Kanye West, Ice Spice, Thee Stallion &#038; Serena Williams&#8217; Husband on &#8216;Her Loss&#8217;</a></h3><br /></div><div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div><div class="clear"></div></section><div class="clear"></div></main></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="inner-wrap"><div class="footer-widgets widgets"><div class="widget-areas"><div class="column"><div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3><ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded"><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" title="Facebook" rel=" noopener noreferrer">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" title="Twitter" rel=" noopener noreferrer">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" title="Instagram" rel=" noopener noreferrer">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a></li></ul><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li><li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li><li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li><li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li><li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li><li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li></ul></div><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li><li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li><li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li></ul></div><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_text" id="text-88"><h3 class="title">URBANISLANDZ.COM</h3><div class="textwidget"><p>Advancing the culture and building bridges. Latest dancehall and hip hop news and music at your fingertips.</p></div><div class="clear"></div></div><div class="clear"></div></div></div></div><div class="site-info"><div class="site-copyright"><div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li><li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li></ul></div>
<span class="copyright">Copyright © 2022 Urban Islandz</span></div></div></div></footer></div><style id='core-block-supports-inline-css' type='text/css'>/**
 * Core styles: block-supports
 */</style> <script type='text/javascript' id='primenews-script-js-extra'>/*  */
var zoomOptions = {"slideshow_auto":"","slideshow_speed":"4000"};
/*  */</script> <script type='text/javascript' id='sharing-js-js-extra'>/*  */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/*  */</script> <script type='text/javascript' id='sharing-js-js-after'>var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();</script> <script data-no-optimize="1">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</script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/js/5550f7e9f96d13fcba501428710a7a1e.js?ver=a4f24"></script></body></html>

