<!DOCTYPE html>
<html lang="en-US">
<head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/css/9f7f95a91536831db48b2c8ed5cece2d.css?ver=66564" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Drake Follow And DM A Troll&#039;s Wife Who Joke About His Son Adonis - Urban Islandz</title>
<meta name="description" content="Drake made an example out of a social media troll who commented about his son Adonis Graham. There is an unspoken rule when it comes to taking jabs at" />
<link rel="canonical" href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Drake Follow And DM A Troll&#039;s Wife Who Joke About His Son Adonis" />
<meta property="og:description" content="Drake made an example out of a social media troll who commented about his son Adonis Graham. There is an unspoken rule when it comes to taking jabs at" />
<meta property="og:url" content="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2022-05-04T18:23:50+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="873" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Rav1989" />
<meta name="twitter:site" content="@urbanislandz" />

<link rel="amphtml" href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/amp/" /><style id='wp-block-library-theme-inline-css' type='text/css'>
/**
 * Colors
 */
/**
 * Breakpoints & Media Queries
 */
/**
 * SCSS Variables.
 *
 * Please use variables from this sheet to ensure consistency across the UI.
 * Don't add to this sheet unless you're pretty sure the value will be reused in many places.
 * For example, don't add rules to this sheet that affect block visuals. It's purely for UI.
 */
/**
 * Colors
 */
/**
 * Fonts & basic variables.
 */
/**
 * Grid System.
 * https://make.wordpress.org/design/2019/10/31/proposal-a-consistent-spacing-system-for-wordpress/
 */
/**
 * Dimensions.
 */
/**
 * Shadows.
 */
/**
 * Editor widths.
 */
/**
 * Block & Editor UI.
 */
/**
 * Block paddings.
 */
/**
 * React Native specific.
 * These variables do not appear to be used anywhere else.
 */
/**
*  Converts a hex value into the rgb equivalent.
*
* @param {string} hex - the hexadecimal value to convert
* @return {string} comma separated rgb values
*/
/**
 * Breakpoint mixins
 */
/**
 * Long content fade mixin
 *
 * Creates a fading overlay to signify that the content is longer
 * than the space allows.
 */
/**
 * Focus styles.
 */
/**
 * Applies editor left position to the selector passed as argument
 */
/**
 * Styles that are reused verbatim in a few places
 */
/**
 * Allows users to opt-out of animations via OS-level preferences.
 */
/**
 * Reset default styles for JavaScript UI based pages.
 * This is a WP-admin agnostic reset
 */
/**
 * Reset the WP Admin page styles for Gutenberg-like pages.
 */
.wp-block-audio figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-audio figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-code > code {
  font-family: Menlo, Consolas, monaco, monospace;
  color: #1e1e1e;
  padding: 0.8em 1em;
  border: 1px solid #ddd;
  border-radius: 4px;
}

.wp-block-embed figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-embed figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.blocks-gallery-caption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .blocks-gallery-caption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-image figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-image figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-pullquote {
  border-top: 4px solid currentColor;
  border-bottom: 4px solid currentColor;
  margin-bottom: 1.75em;
  color: currentColor;
}
.wp-block-pullquote cite,
.wp-block-pullquote footer, .wp-block-pullquote__citation {
  color: currentColor;
  text-transform: uppercase;
  font-size: 0.8125em;
  font-style: normal;
}

.wp-block-quote {
  border-left: 0.25em solid currentColor;
  margin: 0 0 1.75em 0;
  padding-left: 1em;
}
.wp-block-quote cite,
.wp-block-quote footer {
  color: currentColor;
  font-size: 0.8125em;
  position: relative;
  font-style: normal;
}
.wp-block-quote.has-text-align-right {
  border-left: none;
  border-right: 0.25em solid currentColor;
  padding-left: 0;
  padding-right: 1em;
}
.wp-block-quote.has-text-align-center {
  border: none;
  padding-left: 0;
}
.wp-block-quote.is-style-plain, .wp-block-quote.is-style-large, .wp-block-quote.is-large {
  border: none;
}

.wp-block-search .wp-block-search__label {
  font-weight: bold;
}

.wp-block-group:where(.has-background) {
  padding: 1.25em 2.375em;
}

.wp-block-separator {
  border: none;
  border-bottom: 2px solid currentColor;
  margin-left: auto;
  margin-right: auto;
  opacity: 0.4;
}
.wp-block-separator:not(.is-style-wide):not(.is-style-dots) {
  width: 100px;
}
.wp-block-separator.has-background:not(.is-style-dots) {
  border-bottom: none;
  height: 1px;
}
.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots) {
  height: 2px;
}

.wp-block-table thead {
  border-bottom: 3px solid;
}
.wp-block-table tfoot {
  border-top: 3px solid;
}
.wp-block-table td,
.wp-block-table th {
  padding: 0.5em;
  border: 1px solid;
  word-break: normal;
}
.wp-block-table figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-table figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-video figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-video figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-template-part.has-background {
  padding: 1.25em 2.375em;
  margin-top: 0;
  margin-bottom: 0;
}
</style>
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/282195" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4.jpg" />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#ffdcdc;
}
.header_misc a:hover{
	color:#ffdcdc;
}
.header_misc .navbar-wpz > .current-menu-item > a, .header_misc .navbar-wpz > .current_page_item > a{
	color:#ffdcdc;
}
.sb-search .sb-icon-search{
	color:#ffdcdc;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}

</style>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-PGHYXV6763"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-PGHYXV6763');
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6028873096749132" crossorigin="anonymous"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-282195 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">feed</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-258068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258068"><a href="https://urbanislandz.com/category/trending/">TRENDING</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a>
<ul class="sub-menu">
<li id="menu-item-279816" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-279816"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-279817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279817"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
</ul>
</li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="musicad11 ad-label">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<div class="inner-wrap">
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-282195" class="post-282195 post type-post status-publish format-standard has-post-thumbnail category-feature category-hip-hop category-news tag-drake">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/feature/" rel="category tag">Feature</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/hip-hop/" rel="category tag">Hip Hop</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/news/" rel="category tag">News</a></span>
<h1 class="entry-title fn">Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis</h1> <div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a></span> <span class="entry-date">Published: <time class="entry-date" datetime="2022-05-04T14:23:50-04:00">May 4, 2022</time> </span>
</div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAwIiBoZWlnaHQ9Ijg3MyIgdmlld0JveD0iMCAwIDE0MDAgODczIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjZmVmZmZmIi8+PC9zdmc+" width="1400" height="873" data-src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Drake" data-srcset="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-300x187.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-768x479.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-700x437.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-600x374.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-200x125.jpg 200w" data-sizes="(max-width: 1400px) 100vw, 1400px" /><noscript><img width="1400" height="873" src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Drake" srcset="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-300x187.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-768x479.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-700x437.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-600x374.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-200x125.jpg 200w" sizes="(max-width: 1400px) 100vw, 1400px" /></noscript> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Drake made an example out of a social media troll who commented about his son Adonis Graham.</p>
<p>There is an unspoken rule when it comes to taking jabs at adults; children are off-limits. A random man on Instagram is getting taught this valuable lesson by <a href="https://urbanislandz.com/artist/drake/">Drake</a>, albeit in a very petty way. The man who commented under Drake&#8217;s post with his son Adonis took a jab at the rapper&#8217;s writing skills but drew Adonis in to pack a punch.</p>
<p>Under Drake&#8217;s post, the man commented, &#8220;ya son prolly play with ghost writers.&#8221;</p>
<p>Drake&#8217;s response was in line with the reputation he is alleged to have- Mr. Steal your girl and being the King of Petty that even 50 Cent has nothing on him.</p>
<p>&#8220;I just followed your girl cause she&#8217;s prob miserable and needs some excitement in her life,&#8221; Drake wrote back.</p>
<p>Drake wasn&#8217;t joking when he made the threat as he straightaway followed the woman who has 1700 followers and even jumped into her DMs.</p>
<p>&#8220;I&#8217;m here for u ma,&#8221; Drake wrote.</p>
<p>The woman also seemed excited to have one of the biggest rappers follow her as she reacted to her husband creating a problem with the Toronto rapper.</p>
<p>&#8220;My husband decides to be a troll and now @champagnepapi thinking I need excitement in my life.&#8221;</p>
<p>The husband also responded by sharing a screenshot of the DM sent by Drake.</p>
<p>&#8220;Oh nahhhhhh fool really DM&#8217;d my wife. I&#8217;m [laughing emojis]&#8221; he said.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Drake got this man down bad after responding to a troll’s comment about his son Adonis….? Drizzy hopped in his petty bag, followed dude’s wife &amp; even slid in her DM! ??<br />•<br />?: Getty Images <a href="https://t.co/fXnaNrTUJh">pic.twitter.com/fXnaNrTUJh</a></p>
<p>&mdash; Power 106 (@Power106LA) <a href="https://twitter.com/Power106LA/status/1521872672027598848?ref_src=twsrc%5Etfw">May 4, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Drake is insane LMAOOOOO <a href="https://t.co/vl6v7UuiLg">pic.twitter.com/vl6v7UuiLg</a></p>
<p>&mdash; stas (@AstasiaWill) <a href="https://twitter.com/AstasiaWill/status/1521853918321557506?ref_src=twsrc%5Etfw">May 4, 2022</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>By now, many in the hip hop industry know not to play with Aubrey &#8216;Drake&#8217; Graham, especially when it comes to the apple of his eyes, Adonis.</p>
<p>The claim that Drake uses ghostwriters comes from Drake and Pusha T&#8217;s beef as the rappers exchanged blows in 2016, and Drake got downright petty.</p>
<p>After claiming Drake uses others to write his bars, Drake responded by calling into question Pusha&#8217;s alleged drug dealer past on &#8220;Two Birds, One Stone.&#8221;</p>
<p>&#8220;But really it&#8217;s you with all the drug dealer stories / That&#8217;s gotta stop, though / You made a couple chops and now you think you Chapo / If you ask me though, you ain&#8217;t lining the trunk with kilos.&#8221;</p>
<p>The G.O.O.D Music rapper went on to respond to Drake in &#8220;Infrared,&#8221; referring to <a href="https://urbanislandz.com/2020/02/14/quentin-miller-says-drake-meek-mill-ghost-writing-beef-ruined-iyrtitl/">Quentin Miller</a>, whom <a href="https://urbanislandz.com/artist/meek-mill/">Meek Mill</a> claimed was the ghostwriter behind Drake&#8217;s bars.</p>
<p>&#8220;Your hooks did it/The lyrics pennin&#8217; equals to Trump&#8217;s winnin’/The bigger question is how the Russians did it/It was written like Nas but it came from Quentin.&#8221;</p>
<p>Drake went on to diss <a href="https://urbanislandz.com/artist/pusha-t/">Pusha T</a> in &#8220;<a href="https://urbanislandz.com/2018/05/26/drakes-duppy-freestyle-jamaican-meaning/">Duppy Freestyle</a>&#8221; and even sent shots after Kanye West.</p>
<p>&#8220;So if you rebuke me for working with someone else on a couple of Vs / What do you really think of the n**** that&#8217;s making your beats?&#8221; Drake raps. &#8220;Tell &#8216;Ye we got an invoice comin&#8217; to you / Considering we just sold another 20 for you.&#8221;</p>
<p>The beef spilled onto Twitter as Pusha T told Drake to send the invoice, and in true petty fashion, Drake sent the invoice for $100,000 for &#8220;professional services rendered. Promotional assistance and career reviving,&#8221; taking a deep stab at Pusha&#8217;s fledgling career which got a surge from his <a href="https://urbanislandz.com/2021/11/17/fans-antagonize-pusha-t-on-twitter-after-drake-kanye-west-end-beef/">beef with Drake</a>.</p>
<figure id="attachment_211708" aria-describedby="caption-attachment-211708" style="width: 1200px" class="wp-caption aligncenter"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAwIiBoZWlnaHQ9Ijc2OCIgdmlld0JveD0iMCAwIDEyMDAgNzY4Ij48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjZmVmZmZmIi8+PC9zdmc+" data-src="https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad.jpg" alt="Meek Mill and Drake Going Bad" width="1200" height="768" class="size-full wp-image-211708" data-srcset="https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad.jpg 1200w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-300x192.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-768x492.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-700x448.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-600x384.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-200x128.jpg 200w" data-sizes="(max-width: 1200px) 100vw, 1200px" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad.jpg" alt="Meek Mill and Drake Going Bad" width="1200" height="768" class="size-full wp-image-211708" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad.jpg 1200w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-300x192.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-768x492.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-700x448.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-600x384.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/02/Meek-Mill-and-Drake-Going-Bad-200x128.jpg 200w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript><figcaption id="caption-attachment-211708" class="wp-caption-text">Meek Mill and Drake</figcaption></figure>
<p>Drake&#8217;s pettiness is not new, though, as he has been hard-hitting with his responses just as with his captions on Instagram.</p>
<p>In response to Meek Mill in 2015 over the same claims that he uses ghost-writers, Drake crushed Meek Mill with the coldest blow &#8211; &#8220;Is that a world tour or your girls tour?&#8221; Drizzy raps in the infamous diss track &#8220;<a href="https://urbanislandz.com/2016/10/28/meek-mill-weighs-in-on-drakes-back-to-back-it-was-hot/">Back to Back</a>&#8221; because <a href="https://urbanislandz.com/2015/06/08/nicki-minaj-meek-mill-rekindle-relationship-xgames-news/">Meek was dating Nicki Minaj</a> at the time and was on tour with her.</p>
<p>His pettiness even spanned him sharing a PowerPoint presentation of memes of Meek at his OvO Festival in Toronto. Of late, though, he&#8217;s been keeping his cool and bringing in the bag with his latest <a href="https://urbanislandz.com/2022/05/03/drake-gets-big-payday-signs-400m-deal-with-universal-music-group/">$400 M Universal Music Group deal</a>.</p>
<p>Still, Drake is showing that rappers and even followers can get a dose of pettiness if required.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-282195" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-282195" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/drake/" rel="tag">Drake</a></div>
<div class="related">
<div class="related-heading">More Drake News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/05/04/jack-harlow-taps-drake-lil-wayne-for-come-home-the-kids-miss-you-album-tracklist/" rel="bookmark" title="Permanent Link to Jack Harlow Taps Drake &#038; Lil Wayne For &#8216;Come Home The Kids Miss You&#8217; Album Tracklist">Jack Harlow Taps Drake &#038; Lil Wayne For &#8216;Come Home The Kids Miss You&#8217; Album Tracklist</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/05/03/drake-gets-big-payday-signs-400m-deal-with-universal-music-group/" rel="bookmark" title="Permanent Link to Drake Gets Big Payday Signs $400m Deal With Universal Music Group">Drake Gets Big Payday Signs $400m Deal With Universal Music Group</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/05/03/future-says-im-on-one-with-drake-was-inevitable-preps-new-music/" rel="bookmark" title="Permanent Link to Future Says &#8220;I&#8217;m On One&#8221; With Drake Was Inevitable, Preps New Music">Future Says &#8220;I&#8217;m On One&#8221; With Drake Was Inevitable, Preps New Music</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-282195" class="post-282195 post type-post status-publish format-standard has-post-thumbnail category-feature category-hip-hop category-news tag-drake">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/" title="Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI4MDAiIGhlaWdodD0iNDgwIiB2aWV3Qm94PSIwIDAgODAwIDQ4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="800" height="480" data-src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="Drake" loading="lazy" /><noscript><img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="Drake" loading="lazy" /></noscript> </a>
</div>
 <div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/" title="Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis">Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis</a></h3>
<div class="entry-meta">
<span class="entry-date">25 seconds ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-282187 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-feature category-news tag-shenseea">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/05/04/shenseea-says-her-sophomore-album-will-be-completely-different/" title="Shenseea Says Her Sophomore Album Will Be &#8216;Completely Different&#8217;">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/05/Shenseea-Courtesy-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Shenseea" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/05/Shenseea-Courtesy-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Shenseea" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/05/04/shenseea-says-her-sophomore-album-will-be-completely-different/" title="Shenseea Says Her Sophomore Album Will Be &#8216;Completely Different&#8217;">Shenseea Says Her Sophomore Album Will Be &#8216;Completely Different&#8217;</a></h3>
<div class="entry-meta">
<span class="entry-date">12 hours ago</span> </div>
</div>
</li>
<li class="post-282169 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-music category-news tag-drake tag-dua-lipa tag-jack-harlow tag-justin-timberlake tag-lil-wayne tag-pharrell-williams">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/05/04/jack-harlow-taps-drake-lil-wayne-for-come-home-the-kids-miss-you-album-tracklist/" title="Jack Harlow Taps Drake &#038; Lil Wayne For &#8216;Come Home The Kids Miss You&#8217; Album Tracklist">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/01/Jack-Harlow-1-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Jack Harlow" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/01/Jack-Harlow-1-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Jack Harlow" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/05/04/jack-harlow-taps-drake-lil-wayne-for-come-home-the-kids-miss-you-album-tracklist/" title="Jack Harlow Taps Drake &#038; Lil Wayne For &#8216;Come Home The Kids Miss You&#8217; Album Tracklist">Jack Harlow Taps Drake &#038; Lil Wayne For &#8216;Come Home The Kids Miss You&#8217; Album Tracklist</a></h3>
<div class="entry-meta">
<span class="entry-date">13 hours ago</span> </div>
</div>
</li>
<li class="post-282182 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news category-trending tag-jada-kingdom">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/05/04/jada-kingdom-says-female-in-a-viral-video-on-twitter-is-not-her/" title="Jada Kingdom Says Female In A Viral Video On Twitter Is Not Her">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2021/08/Jada-Kingdom-3-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/08/Jada-Kingdom-3-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/05/04/jada-kingdom-says-female-in-a-viral-video-on-twitter-is-not-her/" title="Jada Kingdom Says Female In A Viral Video On Twitter Is Not Her">Jada Kingdom Says Female In A Viral Video On Twitter Is Not Her</a></h3>
<div class="entry-meta">
<span class="entry-date">14 hours ago</span> </div>
</div>
</li>
<li class="post-282172 post type-post status-publish format-standard has-post-thumbnail category-feature category-hip-hop category-news tag-drake tag-universal-music-group">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/05/03/drake-gets-big-payday-signs-400m-deal-with-universal-music-group/" title="Drake Gets Big Payday Signs $400m Deal With Universal Music Group">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2021/07/Drake-8-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Drake" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/07/Drake-8-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Drake" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/05/03/drake-gets-big-payday-signs-400m-deal-with-universal-music-group/" title="Drake Gets Big Payday Signs $400m Deal With Universal Music Group">Drake Gets Big Payday Signs $400m Deal With Universal Music Group</a></h3>
<div class="entry-meta">
<span class="entry-date">15 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments"></p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">
<div class="musicad2 ad-label">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Features</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-140x100.jpg" height="100" width="140" alt="Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-4-140x100.jpg" height="100" width="140" alt="Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/05/04/drake-follow-and-dm-a-trolls-wife-who-joke-about-his-son-adonis/">Drake Follow And DM A Troll&#8217;s Wife Who Joke About His Son Adonis</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/05/04/shenseea-says-her-sophomore-album-will-be-completely-different/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/05/Shenseea-Courtesy-140x100.jpg" height="100" width="140" alt="Shenseea Says Her Sophomore Album Will Be &#8216;Completely Different&#8217;" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/05/Shenseea-Courtesy-140x100.jpg" height="100" width="140" alt="Shenseea Says Her Sophomore Album Will Be &#8216;Completely Different&#8217;" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/05/04/shenseea-says-her-sophomore-album-will-be-completely-different/">Shenseea Says Her Sophomore Album Will Be &#8216;Completely Different&#8217;</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/05/03/drake-gets-big-payday-signs-400m-deal-with-universal-music-group/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/07/Drake-8-140x100.jpg" height="100" width="140" alt="Drake Gets Big Payday Signs $400m Deal With Universal Music Group" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/07/Drake-8-140x100.jpg" height="100" width="140" alt="Drake Gets Big Payday Signs $400m Deal With Universal Music Group" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/05/03/drake-gets-big-payday-signs-400m-deal-with-universal-music-group/">Drake Gets Big Payday Signs $400m Deal With Universal Music Group</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/04/30/sean-paul-lends-his-voice-to-call-for-music-streaming-platforms-fairness/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/11/Sean-Paul-32-140x100.jpeg" height="100" width="140" alt="Sean Paul Lends His Voice To Call For Music Streaming Platforms Fairness" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/11/Sean-Paul-32-140x100.jpeg" height="100" width="140" alt="Sean Paul Lends His Voice To Call For Music Streaming Platforms Fairness" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/04/30/sean-paul-lends-his-voice-to-call-for-music-streaming-platforms-fairness/">Sean Paul Lends His Voice To Call For Music Streaming Platforms Fairness</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/04/29/sean-paul-says-shenseea-pen-game-is-potent-but-she-went-pop-too-early/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Sean-Paul-Shenseea32-140x100.jpeg" height="100" width="140" alt="Sean Paul Says Shenseea Pen Game Is &#8216;Potent&#8217; But She Went Pop Too Early" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/Sean-Paul-Shenseea32-140x100.jpeg" height="100" width="140" alt="Sean Paul Says Shenseea Pen Game Is &#8216;Potent&#8217; But She Went Pop Too Early" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/04/29/sean-paul-says-shenseea-pen-game-is-potent-but-she-went-pop-too-early/">Sean Paul Says Shenseea Pen Game Is &#8216;Potent&#8217; But She Went Pop Too Early</a></h3><br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li>
<li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li>
<li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>
<span class="copyright">Copyright © 2021 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script data-no-optimize="1" defer>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</script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/js/926913b6e6c83f1b5a3c77c64025e5a3.js?ver=66564"></script></body>
</html>
