<!DOCTYPE html>
<html lang="en-US">
<head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/css/9f7f95a91536831db48b2c8ed5cece2d.css?ver=46913" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Jayda Cheaves Announces She Ended Lil Baby Relationship: &quot;Y&#039;all Will See&quot; - Urban Islandz</title>
<meta name="description" content="Jayda Cheaves announces she has ended her relationship with Lil Baby months after the two rekindled their romance. The rapper and mother of his child" />
<link rel="canonical" href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jayda Cheaves Announces She Ended Lil Baby Relationship: &quot;Y&#039;all Will See&quot;" />
<meta property="og:description" content="Jayda Cheaves announces she has ended her relationship with Lil Baby months after the two rekindled their romance. The rapper and mother of his child" />
<meta property="og:url" content="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2022-03-19T17:18:05+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves.jpeg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="850" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Rav1989" />
<meta name="twitter:site" content="@urbanislandz" />

<link rel="amphtml" href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/amp/" /><style id='wp-block-library-theme-inline-css' type='text/css'>
/**
 * Colors
 */
/**
 * Breakpoints & Media Queries
 */
/**
 * SCSS Variables.
 *
 * Please use variables from this sheet to ensure consistency across the UI.
 * Don't add to this sheet unless you're pretty sure the value will be reused in many places.
 * For example, don't add rules to this sheet that affect block visuals. It's purely for UI.
 */
/**
 * Colors
 */
/**
 * Fonts & basic variables.
 */
/**
 * Grid System.
 * https://make.wordpress.org/design/2019/10/31/proposal-a-consistent-spacing-system-for-wordpress/
 */
/**
 * Dimensions.
 */
/**
 * Shadows.
 */
/**
 * Editor widths.
 */
/**
 * Block & Editor UI.
 */
/**
 * Block paddings.
 */
/**
 * React Native specific.
 * These variables do not appear to be used anywhere else.
 */
/**
*  Converts a hex value into the rgb equivalent.
*
* @param {string} hex - the hexadecimal value to convert
* @return {string} comma separated rgb values
*/
/**
 * Breakpoint mixins
 */
/**
 * Long content fade mixin
 *
 * Creates a fading overlay to signify that the content is longer
 * than the space allows.
 */
/**
 * Focus styles.
 */
/**
 * Applies editor left position to the selector passed as argument
 */
/**
 * Styles that are reused verbatim in a few places
 */
/**
 * Allows users to opt-out of animations via OS-level preferences.
 */
/**
 * Reset default styles for JavaScript UI based pages.
 * This is a WP-admin agnostic reset
 */
/**
 * Reset the WP Admin page styles for Gutenberg-like pages.
 */
.wp-block-audio figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-audio figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-code > code {
  font-family: Menlo, Consolas, monaco, monospace;
  color: #1e1e1e;
  padding: 0.8em 1em;
  border: 1px solid #ddd;
  border-radius: 4px;
}

.wp-block-embed figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-embed figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.blocks-gallery-caption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .blocks-gallery-caption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-image figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-image figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-pullquote {
  border-top: 4px solid currentColor;
  border-bottom: 4px solid currentColor;
  margin-bottom: 1.75em;
  color: currentColor;
}
.wp-block-pullquote cite,
.wp-block-pullquote footer, .wp-block-pullquote__citation {
  color: currentColor;
  text-transform: uppercase;
  font-size: 0.8125em;
  font-style: normal;
}

.wp-block-quote {
  border-left: 0.25em solid currentColor;
  margin: 0 0 1.75em 0;
  padding-left: 1em;
}
.wp-block-quote cite,
.wp-block-quote footer {
  color: currentColor;
  font-size: 0.8125em;
  position: relative;
  font-style: normal;
}
.wp-block-quote.has-text-align-right {
  border-left: none;
  border-right: 0.25em solid currentColor;
  padding-left: 0;
  padding-right: 1em;
}
.wp-block-quote.has-text-align-center {
  border: none;
  padding-left: 0;
}
.wp-block-quote.is-style-plain, .wp-block-quote.is-style-large, .wp-block-quote.is-large {
  border: none;
}

.wp-block-search .wp-block-search__label {
  font-weight: bold;
}

.wp-block-group:where(.has-background) {
  padding: 1.25em 2.375em;
}

.wp-block-separator {
  border: none;
  border-bottom: 2px solid currentColor;
  margin-left: auto;
  margin-right: auto;
  opacity: 0.4;
}
.wp-block-separator:not(.is-style-wide):not(.is-style-dots) {
  width: 100px;
}
.wp-block-separator.has-background:not(.is-style-dots) {
  border-bottom: none;
  height: 1px;
}
.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots) {
  height: 2px;
}

.wp-block-table thead {
  border-bottom: 3px solid;
}
.wp-block-table tfoot {
  border-top: 3px solid;
}
.wp-block-table td,
.wp-block-table th {
  padding: 0.5em;
  border: 1px solid;
  word-break: normal;
}
.wp-block-table figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-table figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-video figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-video figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-template-part.has-background {
  padding: 1.25em 2.375em;
  margin-top: 0;
  margin-bottom: 0;
}
</style>
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/280983" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves.jpeg" />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#ffdcdc;
}
.header_misc a:hover{
	color:#ffdcdc;
}
.header_misc .navbar-wpz > .current-menu-item > a, .header_misc .navbar-wpz > .current_page_item > a{
	color:#ffdcdc;
}
.sb-search .sb-icon-search{
	color:#ffdcdc;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}

</style>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6028873096749132" crossorigin="anonymous"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-280983 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">feed</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
</ul>
</div>  </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-258068" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258068"><a href="https://urbanislandz.com/category/trending/">TRENDING</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a>
<ul class="sub-menu">
<li id="menu-item-279816" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-279816"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-279817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279817"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
</ul>
</li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="musicad11 ad-label">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<div class="inner-wrap">
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-280983" class="post-280983 post type-post status-publish format-standard has-post-thumbnail category-feature category-hip-hop category-trending tag-jayda-cheaves tag-lil-baby">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/feature/" rel="category tag">Feature</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/hip-hop/" rel="category tag">Hip Hop</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/trending/" rel="category tag">Trending</a></span>
<h1 class="entry-title fn">Jayda Cheaves Announces She Ended Lil Baby Relationship: &#8220;Y&#8217;all Will See&#8221;</h1> <div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a></span> <span class="entry-date">Published: <time class="entry-date" datetime="2022-03-19T13:18:05-04:00">March 19, 2022 1:18 pm</time> </span>
</div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAwIiBoZWlnaHQ9Ijg1MCIgdmlld0JveD0iMCAwIDE0MDAgODUwIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjZmVmZmZmIi8+PC9zdmc+" width="1400" height="850" data-src="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves.jpeg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Lil Baby Jayda Cheaves" data-srcset="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves.jpeg 1400w, https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-300x182.jpeg 300w, https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-700x425.jpeg 700w, https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-768x466.jpeg 768w" data-sizes="(max-width: 1400px) 100vw, 1400px" /><noscript><img width="1400" height="850" src="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves.jpeg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Lil Baby Jayda Cheaves" srcset="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves.jpeg 1400w, https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-300x182.jpeg 300w, https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-700x425.jpeg 700w, https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-768x466.jpeg 768w" sizes="(max-width: 1400px) 100vw, 1400px" /></noscript> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Jayda Cheaves announces she has ended her relationship with Lil Baby months after the two rekindled their romance.</p>
<p>The rapper and mother of his child sparked break-up rumors on Friday after sharing subliminal posts about breaking up. <a href="https://urbanislandz.com/artist/jayda-cheaves/">Jayda Cheaves</a> and <a href="https://urbanislandz.com/artist/lil-baby/">Lil Baby</a> surprised fans after they were <a href="https://urbanislandz.com/2022/01/19/lil-baby-splurge-on-jayda-cheaves-pre-valentines-romance-with-red-rose-gifts/">seen together after the holidays</a> at fashion shows in Paris. The couple apparently broke up sometime earlier in 2021, but towards the end of the year, it seemed they were working on their relationship. </p>
<p>It was a whirlwind few months for Jayda as Lil Baby showed out on Christmas Day as he gifted her two of her favorite Chanel purses and a brand-new Rolls Royce.</p>
<p>The couple was later seen on vacation in the Caribbean island of St Barts at the end of the year after weeks of speculation that they were back together. </p>
<p>Their reconciliation came after an interview Jayda did with Hollywood Unlocked after news surfaced that Lil Baby was dating Saweetie and even dropped a bag on her at the Chanel store. </p>
<p>During the interview, she spoke about the problems they had. </p>
<p>“It’s just a lot of damage as far as what has been done on social media, so once we can get over that part, I feel like maybe we could rekindle and rebuild another relationship. But as far as right now, it’s so much damage publicly to just put a band-aid over something and say, ‘Ok, let’s just get back together. No.”</p>
<p>The pair had broken up after it was alleged that Lil Baby had cheated on her.</p>
<p>Now. It seems that their relationship has gotten rocky once again and a far cry from their Cabo San Lucas trip in January and the extravagant romantic surprise Jayda received on Valentine’s Day. </p>
<p>On her Instagram Story, she said, “I’m finally standing up. Everything comes to an end. Never force it,” Jayda wrote. “Be happy.”</p>
<figure id="attachment_280984" aria-describedby="caption-attachment-280984" style="width: 405px" class="wp-caption aligncenter"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDUiIGhlaWdodD0iMjE2IiB2aWV3Qm94PSIwIDAgNDA1IDIxNiI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Jayda-message-.webp" alt="Jayda message" width="405" height="216" class="size-full wp-image-280984" data-srcset="https://urbanislandz.com/wp-content/uploads/2022/03/Jayda-message-.webp 405w, https://urbanislandz.com/wp-content/uploads/2022/03/Jayda-message--300x160.webp 300w" data-sizes="(max-width: 405px) 100vw, 405px" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/Jayda-message-.webp" alt="Jayda message" width="405" height="216" class="size-full wp-image-280984" srcset="https://urbanislandz.com/wp-content/uploads/2022/03/Jayda-message-.webp 405w, https://urbanislandz.com/wp-content/uploads/2022/03/Jayda-message--300x160.webp 300w" sizes="(max-width: 405px) 100vw, 405px" /></noscript><figcaption id="caption-attachment-280984" class="wp-caption-text">Jayda Cheaves IG Story message</figcaption></figure>
<p>Fans immediately reacted to the Instagram Story, which was reposted by the Shaderoom and which prompted a response from Jayda as fans trolled her about breaking up with Lil Baby. </p>
<p>“I’m fr y’all lmfao we ain’t gon talk about it,” Jayda wrote. “Y’all will see.”</p>
<p>Jayda also shared an image of Empire character Cookie Lyons crying and Lucious telling her, “I gotta put me first.”</p>
<p>She captioned the image: “I’m willing to X anybody out for my happiness and peace.”</p>
<p>She also added another comment.</p>
<p>“I post my own [teacup emoticon] so I can clown myself before I get clowned. Cuz shiddddd it’s cold out here,” Jayda wrote along with crying emojis. “Ion know how this [poop emoticon] gon go.”</p>
<p>Meanwhile, Lil Baby also responded with his own subs at Jayda. </p>
<p>Lil Baby seemingly took a jab at his baby mama while sharing a video of D.C. Young Fly speed dancing on a basketball court.</p>
<p>“When a mf think they can play wit me,” he wrote. </p>
<figure id="attachment_280985" aria-describedby="caption-attachment-280985" style="width: 439px" class="wp-caption aligncenter"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MzkiIGhlaWdodD0iNDkxIiB2aWV3Qm94PSIwIDAgNDM5IDQ5MSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/lil-baby-message.webp" alt="lil baby message" width="439" height="491" class="size-full wp-image-280985" data-srcset="https://urbanislandz.com/wp-content/uploads/2022/03/lil-baby-message.webp 439w, https://urbanislandz.com/wp-content/uploads/2022/03/lil-baby-message-268x300.webp 268w" data-sizes="(max-width: 439px) 100vw, 439px" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/lil-baby-message.webp" alt="lil baby message" width="439" height="491" class="size-full wp-image-280985" srcset="https://urbanislandz.com/wp-content/uploads/2022/03/lil-baby-message.webp 439w, https://urbanislandz.com/wp-content/uploads/2022/03/lil-baby-message-268x300.webp 268w" sizes="(max-width: 439px) 100vw, 439px" /></noscript><figcaption id="caption-attachment-280985" class="wp-caption-text">Lil Baby IG Story message</figcaption></figure>
<p>Jayda seems to have responded directly to Lil Baby where she said. </p>
<p>“Think they can play with you? LMFAO you played with me for 6 years straight,” Jayda said, referring to past issues. “I text a ni**a back now your chest hurt. Bye.”</p>
<p>She later deleted her posts addressing Lil Baby and talking about her posting her tea. </p>
<p>Meanwhile, fans were quick to react to the exchange and latest development in what appears to be just another bump in the on-and-off-again relationship of the pair. </p>
<p>Some have been joking that they won’t be breaking up, as has been the case. The pair are parents to a two-year-old son. </p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CbQSq6XrkJ6/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/CbQSq6XrkJ6/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;">View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p></a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/CbQSq6XrkJ6/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by The Shade Room (@theshaderoom)</a></p>
</div>
</blockquote>
<p><script async src="//platform.instagram.com/en_US/embeds.js"></script></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-280983" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-280983" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/jayda-cheaves/" rel="tag">Jayda Cheaves</a>, <a href="https://urbanislandz.com/artist/lil-baby/" rel="tag">Lil Baby</a></div>
<div class="related">
<div class="related-heading">More Jayda Cheaves News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/01/19/lil-baby-splurge-on-jayda-cheaves-pre-valentines-romance-with-red-rose-gifts/" rel="bookmark" title="Permanent Link to Lil Baby Splurge On Jayda Cheaves Pre-Valentine&#8217;s Romance With Red Rose &#038; Gifts">Lil Baby Splurge On Jayda Cheaves Pre-Valentine&#8217;s Romance With Red Rose &#038; Gifts</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/12/29/jayda-cheaves-lil-baby-spotted-on-vacation-in-the-caribbean-with-meek-mill/" rel="bookmark" title="Permanent Link to Jayda Cheaves, Lil Baby Spotted On Vacation In The Caribbean With Meek Mill">Jayda Cheaves, Lil Baby Spotted On Vacation In The Caribbean With Meek Mill</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/12/18/jayda-cheaves-says-she-knew-lil-baby-drop-a-bag-on-saweetie-at-chanel/" rel="bookmark" title="Permanent Link to Jayda Cheaves Says She Knew Lil Baby Drop A Bag On Saweetie At Chanel">Jayda Cheaves Says She Knew Lil Baby Drop A Bag On Saweetie At Chanel</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-280987" class="post-280987 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news tag-deep-jahi">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/03/19/dancehall-artiste-deep-jahi-hospitalized-thank-fans-for-support/" title="Dancehall Artiste Deep Jahi Hospitalized Thank Fans For Support">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI4MDAiIGhlaWdodD0iNDgwIiB2aWV3Qm94PSIwIDAgODAwIDQ4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="800" height="480" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Deep-Jahi-800x480.jpeg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /><noscript><img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2022/03/Deep-Jahi-800x480.jpeg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/03/19/dancehall-artiste-deep-jahi-hospitalized-thank-fans-for-support/" title="Dancehall Artiste Deep Jahi Hospitalized Thank Fans For Support">Dancehall Artiste Deep Jahi Hospitalized Thank Fans For Support</a></h3>
<div class="entry-meta">
<span class="entry-date">24 seconds ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-280978 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-music category-news category-videos tag-eeka-mouse tag-ninjaman tag-shaggy">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/03/19/shaggy-samples-ninjaman-eek-a-mouse-classics-on-mi-nuh-know-listen/" title="Shaggy Samples Ninjaman &#038; Eek-A-Mouse Classics On &#8220;Mi Nuh Know&#8221; &#8211; Listen">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Shaggy-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Shaggy" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/03/Shaggy-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Shaggy" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/03/19/shaggy-samples-ninjaman-eek-a-mouse-classics-on-mi-nuh-know-listen/" title="Shaggy Samples Ninjaman &#038; Eek-A-Mouse Classics On &#8220;Mi Nuh Know&#8221; &#8211; Listen">Shaggy Samples Ninjaman &#038; Eek-A-Mouse Classics On &#8220;Mi Nuh Know&#8221; &#8211; Listen</a></h3>
<div class="entry-meta">
<span class="entry-date">33 mins ago</span> </div>
</div>
</li>
<li class="post-280973 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-feature category-news tag-megan-thee-stallion tag-shenseea">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/03/18/shenseea-interscope-records-hit-with-10-million-lawsuit-over-lick/" title="Shenseea &#038; Interscope Records Hit With $10 Million Lawsuit Over &#8220;Lick&#8221;">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Shenseea-875-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Shenseea" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/03/Shenseea-875-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Shenseea" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/03/18/shenseea-interscope-records-hit-with-10-million-lawsuit-over-lick/" title="Shenseea &#038; Interscope Records Hit With $10 Million Lawsuit Over &#8220;Lick&#8221;">Shenseea &#038; Interscope Records Hit With $10 Million Lawsuit Over &#8220;Lick&#8221;</a></h3>
<div class="entry-meta">
<span class="entry-date">18 hours ago</span> </div>
</div>
</li>
<li class="post-280957 post type-post status-publish format-standard has-post-thumbnail category-feature category-hip-hop category-music category-news category-trending tag-coi-leray tag-nicki-minaj">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/03/18/nicki-minaj-coi-lerays-blick-blick-debuts-at-top-of-itunes-chart/" title="Nicki Minaj &#038; Coi Leray&#8217;s “Blick Blick!” Debuts At Top Of iTunes Chart">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Coi-Nicki-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Coi Leray Nicki Minaj" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/03/Coi-Nicki-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Coi Leray Nicki Minaj" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/03/18/nicki-minaj-coi-lerays-blick-blick-debuts-at-top-of-itunes-chart/" title="Nicki Minaj &#038; Coi Leray&#8217;s “Blick Blick!” Debuts At Top Of iTunes Chart">Nicki Minaj &#038; Coi Leray&#8217;s “Blick Blick!” Debuts At Top Of iTunes Chart</a></h3>
<div class="entry-meta">
 <span class="entry-date">21 hours ago</span> </div>
</div>
</li>
<li class="post-280963 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news category-trending tag-young-thug">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/03/18/young-thugs-baby-mother-lakevia-jackson-shot-dead-in-atlanta-over-bowling-dispute/" title="Young Thug&#8217;s Baby Mother LaKevia Jackson Shot Dead In Atlanta Over Bowling Dispute">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/LaKevia-Thug-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="LaKevia Jackson Young Thug" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/03/LaKevia-Thug-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="LaKevia Jackson Young Thug" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/03/18/young-thugs-baby-mother-lakevia-jackson-shot-dead-in-atlanta-over-bowling-dispute/" title="Young Thug&#8217;s Baby Mother LaKevia Jackson Shot Dead In Atlanta Over Bowling Dispute">Young Thug&#8217;s Baby Mother LaKevia Jackson Shot Dead In Atlanta Over Bowling Dispute</a></h3>
<div class="entry-meta">
<span class="entry-date">23 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments"></p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">
<div class="musicad2 ad-label">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Features</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-140x100.jpeg" height="100" width="140" alt="Jayda Cheaves Announces She Ended Lil Baby Relationship: &#8220;Y&#8217;all Will See&#8221;" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/09/Lil-Baby-Jayda-Cheaves-140x100.jpeg" height="100" width="140" alt="Jayda Cheaves Announces She Ended Lil Baby Relationship: &#8220;Y&#8217;all Will See&#8221;" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/03/19/jayda-cheaves-announces-she-ended-lil-baby-relationship-yall-will-see/">Jayda Cheaves Announces She Ended Lil Baby Relationship: &#8220;Y&#8217;all Will See&#8221;</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/03/18/shenseea-interscope-records-hit-with-10-million-lawsuit-over-lick/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Shenseea-875-140x100.jpeg" height="100" width="140" alt="Shenseea &#038; Interscope Records Hit With $10 Million Lawsuit Over &#8220;Lick&#8221;" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/Shenseea-875-140x100.jpeg" height="100" width="140" alt="Shenseea &#038; Interscope Records Hit With $10 Million Lawsuit Over &#8220;Lick&#8221;" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/03/18/shenseea-interscope-records-hit-with-10-million-lawsuit-over-lick/">Shenseea &#038; Interscope Records Hit With $10 Million Lawsuit Over &#8220;Lick&#8221;</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/03/18/nicki-minaj-coi-lerays-blick-blick-debuts-at-top-of-itunes-chart/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Coi-Nicki-140x100.jpeg" height="100" width="140" alt="Nicki Minaj &#038; Coi Leray&#8217;s “Blick Blick!” Debuts At Top Of iTunes Chart" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/Coi-Nicki-140x100.jpeg" height="100" width="140" alt="Nicki Minaj &#038; Coi Leray&#8217;s “Blick Blick!” Debuts At Top Of iTunes Chart" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/03/18/nicki-minaj-coi-lerays-blick-blick-debuts-at-top-of-itunes-chart/">Nicki Minaj &#038; Coi Leray&#8217;s “Blick Blick!” Debuts At Top Of iTunes Chart</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/03/17/gov-ministers-who-attended-shenseeas-alpha-party-fined-100k-by-pm-andrew-holness/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Shenseea-gov-ministers-140x100.jpeg" height="100" width="140" alt="Gov Ministers Who Attended Shenseea&#8217;s Alpha Party Fined $100K By PM Andrew Holness" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/Shenseea-gov-ministers-140x100.jpeg" height="100" width="140" alt="Gov Ministers Who Attended Shenseea&#8217;s Alpha Party Fined $100K By PM Andrew Holness" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/03/17/gov-ministers-who-attended-shenseeas-alpha-party-fined-100k-by-pm-andrew-holness/">Gov Ministers Who Attended Shenseea&#8217;s Alpha Party Fined $100K By PM Andrew Holness</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/03/17/nicki-minaj-exposed-rt-boss-false-claims-she-bought-him-1-5m-house-in-atlanta/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/03/Nicki-RT-Boss-140x100.jpg" height="100" width="140" alt="Nicki Minaj Exposed RT Boss False Claims She Bought Him $1.5m House In Atlanta" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/03/Nicki-RT-Boss-140x100.jpg" height="100" width="140" alt="Nicki Minaj Exposed RT Boss False Claims She Bought Him $1.5m House In Atlanta" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/03/17/nicki-minaj-exposed-rt-boss-false-claims-she-bought-him-1-5m-house-in-atlanta/">Nicki Minaj Exposed RT Boss False Claims She Bought Him $1.5m House In Atlanta</a></h3><br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li>
<li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li>
<li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>
<span class="copyright">Copyright © 2021 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script data-no-optimize="1" defer>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</script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/js/926913b6e6c83f1b5a3c77c64025e5a3.js?ver=46913"></script></body>
</html>
