<!DOCTYPE html>
<html lang="en-US">
<head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/cssjs/c4661.css?b2610" /><meta http-equiv="x-dns-prefetch-control" content="on"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>&quot;Dirt To Bentley&quot; - Jahvillani Drops Debut Album Feat. Skillibeng &amp; Kranium - Review - Urban Islandz</title>
<meta name="description" content="Jahvillani’s highly anticipated debut album “Dirt to Bentley” is officially out on all digital platforms. After announcing the new album back in June," />
<link rel="canonical" href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&quot;Dirt To Bentley&quot; - Jahvillani Drops Debut Album Feat. Skillibeng &amp; Kranium - Review - Urban Islandz" />
<meta property="og:description" content="Jahvillani’s highly anticipated debut album “Dirt to Bentley” is officially out on all digital platforms. After announcing the new album back in June," />
<meta property="og:url" content="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2021-07-11T17:41:12+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley.jpeg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="751" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />

<link rel="amphtml" href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/amp/" />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/271300" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley.jpeg" />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#ffdcdc;
}
.header_misc a:hover{
	color:#ffdcdc;
}
.header_misc .navbar-wpz > .current-menu-item > a, .header_misc .navbar-wpz > .current_page_item > a{
	color:#ffdcdc;
}
.sb-search .sb-icon-search{
	color:#ffdcdc;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}

</style>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-271300 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">feed</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-258068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258068"><a href="https://urbanislandz.com/category/trending/">TRENDING</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="musicad11 ad-label">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<div class="inner-wrap">
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-271300" class="post-271300 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-music category-news tag-jahvillani tag-kranium tag-skillibeng">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/dancehall/" rel="category tag">Dancehall</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/music/" rel="category tag">Music</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/news/" rel="category tag">News</a></span>
<h1 class="entry-title fn">&#8220;Dirt To Bentley&#8221; &#8211; Jahvillani Drops Debut Album Feat. Skillibeng &#038; Kranium &#8211; Review</h1> <div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/odowlatt/" title="Posts by Orlando Dowlatt" rel="author">Orlando Dowlatt</a></span> <span class="entry-date">Published: <time class="entry-date" datetime="2021-07-11T13:41:12-04:00">July 11, 2021 1:41 pm</time> </span>
</div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1200" height="751" src="https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley.jpeg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley.jpeg 1200w, https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley-300x188.jpeg 300w, https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley-700x438.jpeg 700w, https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley-768x481.jpeg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/odowlatt/" title="Posts by Orlando Dowlatt" rel="author">Orlando Dowlatt</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Jahvillani’s highly anticipated debut album “Dirt to Bentley” is officially out on all digital platforms.</p>
<p>After announcing the new album back in June, fans were anxiously awaiting the release, which was scheduled for July 9th, and it has finally arrived.</p>
<p>The 13-track project is nothing less than impressive and smooth, with additional voices from other Dancehall artists, including New York-based Dancehall singer, <a href="https://urbanislandz.com/artist/kranium/">Kranium</a>, Dancehall sensation, <a href="https://urbanislandz.com/artist/skillibeng/">Skillibeng</a>, and up and coming talent, Prince Swanny.</p>
<p>As the name of the album suggests, the tracks are spreading a positive vibe and giving ‘ghetto youths’ hope, as the deejay tells the story of his origin and his subsequent rise to success, going from nothing (dirt) to riches and success (Bentley). The deejay also added tunes about love, money, progress, and of course, women.</p>
<p>In an interview with The Jamaica Observer’s Splash last week, Jahvillani said, “Di title of di album is really about progression, from nothing to something. Dat&#8217;s me an&#8217; my journey. So, mi haffi sing my reality. Mi haffi give di fans a compilation of di journey from Dirt to Bentley.”</p>
<p><a href="https://urbanislandz.com/artist/jahvillani/">Jahvillani</a> only emerged on the Dancehall scene with high recognition four years ago, but the deejay has not forgotten where he is coming from.</p>
<p>The lead single from which the project is titled “Dirt to Bentley” features Kranium. It tells a tale around the theme of “Pro-Gress” (which is the name of the follow-up single).</p>
<p>“From dirt to the Bentley, now a we dem rich boys envy/ From nil to a century, we lock the streets evidently,” Jahvillani opens on the chorus.</p>
<p>While the lead single was introduced to the world with the rest of the album and is definitely expected to make waves, the follow-up single “Pro-Gress” was premiered by his record label, VP records, two weeks ago and had since been taking Jamaica by storm. Even after three weeks, the song still trends on YouTube.</p>
<p>“From a dollar to a mill, from di ghetto now we inna Bugatti/ Every man a look a ting..” Jahvillani bellows in tune.</p>
<p>The Wileside Government originator has carved his own space within Jamaica’s musical landscape, even while his career is still in its infancy.</p>
<p>According to a press release from the deejay’s management team, ‘Dirt to Bentley’ is just the beginning.</p>
<p>Check it out now.</p>
<p><iframe allow="autoplay *; encrypted-media *; fullscreen *" frameborder="0" height="450" style="width:100%;max-width:660px;overflow:hidden;background:transparent;" sandbox="allow-forms allow-popups allow-same-origin allow-scripts allow-storage-access-by-user-activation allow-top-navigation-by-user-activation" src="https://embed.music.apple.com/us/album/dirt-to-bentley/1574377342"></iframe></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-271300" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-271300" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/jahvillani/" rel="tag">Jahvillani</a>, <a href="https://urbanislandz.com/artist/kranium/" rel="tag">Kranium</a>, <a href="https://urbanislandz.com/artist/skillibeng/" rel="tag">Skillibeng</a></div>
<div class="related">
<div class="related-heading">More Jahvillani News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/04/03/tommy-lee-sparta-says-15-dancehall-artists-collab-brighter-days-took-3-years/" rel="bookmark" title="Permanent Link to Tommy Lee Sparta Says 15 Dancehall Artists Collab &#8220;Brighter Days&#8221; Took 3 Years">Tommy Lee Sparta Says 15 Dancehall Artists Collab &#8220;Brighter Days&#8221; Took 3 Years</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/01/11/dacehall-artiste-jahvillani-appears-to-bleach-his-skin-left-some-fans-shook/" rel="bookmark" title="Permanent Link to Dacehall Artiste Jahvillani Appears To Bleach His Skin Left Some Fans Shook">Dacehall Artiste Jahvillani Appears To Bleach His Skin Left Some Fans Shook</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/09/23/jahvillani-went-on-crime-spree-in-cinematic-visual-kentucky/" rel="bookmark" title="Permanent Link to Jahvillani Went On Crime Spree In Cinematic Visual &#8220;Kentucky&#8221;">Jahvillani Went On Crime Spree In Cinematic Visual &#8220;Kentucky&#8221;</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-271324" class="post-271324 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-g-herbo tag-nicki-minaj">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/07/11/g-herbo-praises-nicki-minaj-for-her-skills-says-she-harder-than-male-rappers/" title="G Herbo Praises Nicki Minaj For Her Skills, Says She Harder Than Male Rappers">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2019/02/G-Herbo-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="G Herbo" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/07/11/g-herbo-praises-nicki-minaj-for-her-skills-says-she-harder-than-male-rappers/" title="G Herbo Praises Nicki Minaj For Her Skills, Says She Harder Than Male Rappers">G Herbo Praises Nicki Minaj For Her Skills, Says She Harder Than Male Rappers</a></h3>
<div class="entry-meta">
<span class="entry-date">8 hours ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-271300 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-music category-news tag-jahvillani tag-kranium tag-skillibeng">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/" title="&#8220;Dirt To Bentley&#8221; &#8211; Jahvillani Drops Debut Album Feat. Skillibeng &#038; Kranium &#8211; Review">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/07/Jahvillani-Dirt-To-Bentley-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/07/11/dirt-to-bentley-jahvillani-drops-debut-album-feat-skillibeng-kranium-review/" title="&#8220;Dirt To Bentley&#8221; &#8211; Jahvillani Drops Debut Album Feat. Skillibeng &#038; Kranium &#8211; Review">&#8220;Dirt To Bentley&#8221; &#8211; Jahvillani Drops Debut Album Feat. Skillibeng &#038; Kranium &#8211; Review</a></h3>
<div class="entry-meta">
<span class="entry-date">8 hours ago</span> </div>
</div>
</li>
<li class="post-271306 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news tag-shenseea">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/07/11/shenseea-back-in-jamaica-for-a-mud-massage-after-finishing-album-in-the-us/" title="Shenseea Back In Jamaica For A Mud Massage After Finishing Album In The US">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/07/Shenseea-35-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/07/11/shenseea-back-in-jamaica-for-a-mud-massage-after-finishing-album-in-the-us/" title="Shenseea Back In Jamaica For A Mud Massage After Finishing Album In The US">Shenseea Back In Jamaica For A Mud Massage After Finishing Album In The US</a></h3>
<div class="entry-meta">
<span class="entry-date">9 hours ago</span> </div>
</div>
</li>
<li class="post-271309 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news category-trending tag-barack-obama tag-bob-marley tag-koffee tag-protoje">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/07/11/protoje-koffee-bob-marley-featured-on-barrack-obama-summer-playlist-2021/" title="Protoje, Koffee, Bob Marley Featured On Barrack Obama Summer Playlist 2021">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/07/Protoje-Koffee-1-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/07/11/protoje-koffee-bob-marley-featured-on-barrack-obama-summer-playlist-2021/" title="Protoje, Koffee, Bob Marley Featured On Barrack Obama Summer Playlist 2021">Protoje, Koffee, Bob Marley Featured On Barrack Obama Summer Playlist 2021</a></h3>
<div class="entry-meta">
<span class="entry-date">9 hours ago</span> </div>
</div>
</li>
<li class="post-271281 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-music category-news category-videos tag-govana">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/07/09/govana-dishes-money-lessons-to-choppers-in-chap-chop-visual/" title="Govana Dishes Money Lessons To &#8216;Choppas&#8217; In &#8220;Chap Chop&#8221; Visual">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/12/Govana-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/07/09/govana-dishes-money-lessons-to-choppers-in-chap-chop-visual/" title="Govana Dishes Money Lessons To &#8216;Choppas&#8217; In &#8220;Chap Chop&#8221; Visual">Govana Dishes Money Lessons To &#8216;Choppas&#8217; In &#8220;Chap Chop&#8221; Visual</a></h3>
<div class="entry-meta">
<span class="entry-date">July 9, 2021</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments"></p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">
<div class="musicad2 ad-label">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Features</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/07/09/lil-wayne-told-nicki-minaj-hes-not-married-his-favorite-sex-position/"><img src="https://urbanislandz.com/wp-content/uploads/2018/09/Lil-Wayne-Nicki-Minaj-140x100.jpg" height="100" width="140" alt="Lil Wayne Told Nicki Minaj He&#8217;s Not Married &#038; His Favorite Sex Position" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/07/09/lil-wayne-told-nicki-minaj-hes-not-married-his-favorite-sex-position/">Lil Wayne Told Nicki Minaj He&#8217;s Not Married &#038; His Favorite Sex Position</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/07/09/love-hip-hop-safaree-turn-up-in-jamaica-as-erica-mena-remains-in-hospital-with-newborn/"><img src="https://urbanislandz.com/wp-content/uploads/2021/07/Safare-Erica-baby-140x100.jpg" height="100" width="140" alt="Love &#038; Hip Hop: Safaree Turn Up In Jamaica As Erica Mena Remains In Hospital With Newborn" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/07/09/love-hip-hop-safaree-turn-up-in-jamaica-as-erica-mena-remains-in-hospital-with-newborn/">Love &#038; Hip Hop: Safaree Turn Up In Jamaica As Erica Mena Remains In Hospital With Newborn</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/07/08/tony-matterhorn-says-bounty-killer-beefing-with-him-over-a-female/"><img src="https://urbanislandz.com/wp-content/uploads/2021/07/Tony-Matterhorn-and-Bounty-Killer-1200x741-1-140x100.jpeg" height="100" width="140" alt="Tony Matterhorn Says Bounty Killer Beefing With Him Over A Female" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/07/08/tony-matterhorn-says-bounty-killer-beefing-with-him-over-a-female/">Tony Matterhorn Says Bounty Killer Beefing With Him Over A Female</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/07/08/the-top-10-summer-songs-in-dancehall-in-2021/"><img src="https://urbanislandz.com/wp-content/uploads/2021/07/Sean-Paul-Spice-Shaggy-song-140x100.jpeg" height="100" width="140" alt="The Top 10 Summer Songs In Dancehall In 2021" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/07/08/the-top-10-summer-songs-in-dancehall-in-2021/">The Top 10 Summer Songs In Dancehall In 2021</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/07/07/dancehall-artist-squash-exposed-for-fake-us570k-richard-mille-watch/"><img src="https://urbanislandz.com/wp-content/uploads/2021/07/Squash-Richard-Mille-140x100.jpg" height="100" width="140" alt="Dancehall Artist Squash Exposed For Fake US$570K Richard Mille Watch" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/07/07/dancehall-artist-squash-exposed-for-fake-us570k-richard-mille-watch/">Dancehall Artist Squash Exposed For Fake US$570K Richard Mille Watch</a></h3><br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
 <a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li>
<li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li>
<li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>
<span class="copyright">Copyright © 2021 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/65f3d.js?fa1ac"></script></body>
</html>
