<!DOCTYPE html>
<html lang="en-US">
<head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/cssjs/c4661.css?4d68a" /><meta http-equiv="x-dns-prefetch-control" content="on"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Buju Banton Leads IRAWMA Nominations With 11 Nods, Vybz Kartel Absent - Urban Islandz</title>
<meta name="description" content="The nominations for the 39th staging of the International Reggae and World Music Awards (IRAWMA) are in, and veteran performer Buju Banton is leading the" />
<link rel="canonical" href="https://urbanislandz.com/2021/03/25/buju-banton-leads-irawma-nominations-with-11-nods-vybz-kartel-absent/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Buju Banton Leads IRAWMA Nominations With 11 Nods, Vybz Kartel Absent - Urban Islandz" />
<meta property="og:description" content="The nominations for the 39th staging of the International Reggae and World Music Awards (IRAWMA) are in, and veteran performer Buju Banton is leading the" />
<meta property="og:url" content="https://urbanislandz.com/2021/03/25/buju-banton-leads-irawma-nominations-with-11-nods-vybz-kartel-absent/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2021-03-26T02:42:32+00:00" />
<meta property="article:modified_time" content="2021-03-26T02:44:08+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="865" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@KayeRenae" />
<meta name="twitter:site" content="@urbanislandz" />

<link rel="amphtml" href="https://urbanislandz.com/2021/03/25/buju-banton-leads-irawma-nominations-with-11-nods-vybz-kartel-absent/amp/" />
<link rel="preload" as="font" id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='text/css' type="font/woff" crossorigin />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/265348" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1.jpg" />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#000000;
}
.sb-search .sb-icon-search{
	color:#000000;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}

</style>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-265348 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #000000; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
 <span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #000000; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #000000; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">feed</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="color" data-hover-color="#dd3333" style="color : #000000; font-size: 16px; padding:6px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-258068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258068"><a href="https://urbanislandz.com/category/trending/">TRENDING</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="musicad11">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<div class="inner-wrap">
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-265348" class="post-265348 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news tag-buju-banton tag-vybz-kartel">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/dancehall/" rel="category tag">Dancehall</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/news/" rel="category tag">News</a></span>
<h1 class="entry-title fn">Buju Banton Leads IRAWMA Nominations With 11 Nods, Vybz Kartel Absent</h1> <div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/annakaye/" title="Posts by Anna-Kaye Kerr" rel="author">Anna-Kaye Kerr</a></span> <span class="entry-date">Published on <time class="entry-date" datetime="2021-03-25T22:42:32-04:00">March 25, 2021</time> </span>
</div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1400" height="865" src="https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1-300x185.jpg 300w, https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1-700x433.jpg 700w, https://urbanislandz.com/wp-content/uploads/2021/03/Buju-i-D-1-768x475.jpg 768w" sizes="(max-width: 1400px) 100vw, 1400px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/annakaye/" title="Posts by Anna-Kaye Kerr" rel="author">Anna-Kaye Kerr</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>The nominations for the 39th staging of the International Reggae and World Music Awards (IRAWMA) are in, and veteran performer Buju Banton is leading the pack with a whopping 11 nominations. </p>
<p>The nominees for what will be the event’s second virtual staging were announced at a press conference hosted by reggae artist Gramps Morgan on March 23. This year’s show is being celebrated under the theme ‘Reggae &#038; World Music Still Rise’ &#8211; a subtle nod to the COVID-19 pandemic and the hardships faced in the past year.</p>
<p>Now in what came as no surprise to many, <a href="https://urbanislandz.com/artist/buju-banton/">Buju Banton</a> was heavily featured among the nominee categories, improving on last year’s showing where he scored 10 nominations. He walked away with 7 of those awards.</p>
<p>This year, Buju Banton will be going up for the Peter Tosh Award for Recording Artiste of the Year, the Emperor of Reggae and World Music – Bob Marley Award for Entertainer of the Year, the Gregory Isaacs Award for Best Song (Blessed), and the Toots Hibbert Award for Best Album/CD (for his album Upside Down), among several other musical awards.</p>
<p>In recognition of his philanthropic efforts, the entertainer has also been nominated for the Marcus Garvey Humanitarian Award. Through his foundation, Buju has been making an impact in the lives of children in state care and other facilities. He has donated computers, tablets, and other electronic devices to allow needy students access to classes during the COVID-19 pandemic, in addition to providing scholarships. Buju goes up against Bounty Killer, Sharon Wiles, and Sonia Patterson for the Humanitarian award.</p>
<p>Bounty Killer is one of the artists that also picked up multiple nominations for this year’s IRAWMA, with six. Young performers Koffee and Popcaan also scored six nominations.</p>
<p>Veteran Beenie Man and newcomer Skip Marley picked up five nominations each, while multiple IRAWMA winners Gramps Morgan and Tarrus Riley scored four nominations each.</p>
<h3>Vybz Kartel absent from nominations</h3>
<p>In an unexpected twist, Gaza Boss Vybz Kartel was not among the nominees. The snub came as a shock to many as Vybz Kartel has featured on the nominee and winners list almost every year since the early 2000s. He has consistently featured in the Best Male Dancehall Artiste category, but this year, the competitors for that title will be Bounty Killer, Beenie Man, Buju Banton, Govana, and Popcaan.</p>
<p>Meantime, a surprise nominee came in the form of D’Angel, who will go up against heavyweights Spice and Shenseea for the Best Female Dancehall/Rap Artiste award.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-265348" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2021/03/25/buju-banton-leads-irawma-nominations-with-11-nods-vybz-kartel-absent/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-265348" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2021/03/25/buju-banton-leads-irawma-nominations-with-11-nods-vybz-kartel-absent/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2021/03/25/buju-banton-leads-irawma-nominations-with-11-nods-vybz-kartel-absent/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/buju-banton/" rel="tag">Buju Banton</a>, <a href="https://urbanislandz.com/artist/vybz-kartel/" rel="tag">Vybz Kartel</a></div>
<div class="related">
<div class="related-heading">More Buju Banton News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/03/22/bounty-killer-buju-banton-speak-out-against-jamaicas-gov-stricter-lockdown/" rel="bookmark" title="Permanent Link to Bounty Killer &#038; Buju Banton Speak Out Against Jamaica&#8217;s Gov Stricter Lockdown">Bounty Killer &#038; Buju Banton Speak Out Against Jamaica&#8217;s Gov Stricter Lockdown</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/03/16/buju-banton-calls-out-jamaicas-pm-andrew-holness-for-oppression-tyranny/" rel="bookmark" title="Permanent Link to Buju Banton Calls Out Jamaica&#8217;s PM Andrew Holness For, &#8220;Oppression &#038; Tyranny&#8221;">Buju Banton Calls Out Jamaica&#8217;s PM Andrew Holness For, &#8220;Oppression &#038; Tyranny&#8221;</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2021/03/16/popcaan-beenie-man-koffee-sean-paul-more-covers-i-d-magazine-jamaicazine-issue/" rel="bookmark" title="Permanent Link to Popcaan, Beenie Man, Koffee, Sean Paul &#038; More Covers i-D Magazine Jamaicazine Issue">Popcaan, Beenie Man, Koffee, Sean Paul &#038; More Covers i-D Magazine Jamaicazine Issue</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">UP NEXT</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-265407" class="post-265407 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news tag-tommy-lee-sparta">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/03/26/tommy-lee-spartas-elegante-debuts-no-2-on-usa-itunes-reggae-chart/" title="Tommy Lee Sparta’s &#8220;Elegante&#8221; Debuts No. 2 On USA iTunes Reggae Chart">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2018/10/Tommy-Lee-Sparta-1000x600.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="Tommy Lee Sparta" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/03/26/tommy-lee-spartas-elegante-debuts-no-2-on-usa-itunes-reggae-chart/" title="Tommy Lee Sparta’s &#8220;Elegante&#8221; Debuts No. 2 On USA iTunes Reggae Chart">Tommy Lee Sparta’s &#8220;Elegante&#8221; Debuts No. 2 On USA iTunes Reggae Chart</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-265403 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-feature category-news tag-aidonia tag-popcaan tag-teejay">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/03/26/popcaan-shenseea-beenie-man-condemns-khanice-jacksons-murder-dancehall-reacts/" title="Popcaan, Shenseea, Beenie Man Condemns Khanice Jackson&#8217;s Murder, Dancehall Reacts">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2018/09/Popcaan-and-Shenseea-665x380.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Popcaan and Shenseea" loading="lazy" /> </a>
</div>

<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/03/26/popcaan-shenseea-beenie-man-condemns-khanice-jacksons-murder-dancehall-reacts/" title="Popcaan, Shenseea, Beenie Man Condemns Khanice Jackson&#8217;s Murder, Dancehall Reacts">Popcaan, Shenseea, Beenie Man Condemns Khanice Jackson&#8217;s Murder, Dancehall Reacts</a></h3>
<div class="entry-meta">
<span class="entry-date">5 hours ago</span> </div>
</div>
</li>
<li class="post-265399 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news category-trending tag-bounty-killer tag-vybz-kartel">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/03/26/vybz-kartel-praised-bounty-killer-for-gifting-wheelchairs-to-elderly/" title="Vybz Kartel Praised Bounty Killer For Gifting Wheelchairs To Elderly">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2018/08/Vybz-Kartel-Bounty-Killer-665x380.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Vybz Kartel and Bounty Killer" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/03/26/vybz-kartel-praised-bounty-killer-for-gifting-wheelchairs-to-elderly/" title="Vybz Kartel Praised Bounty Killer For Gifting Wheelchairs To Elderly">Vybz Kartel Praised Bounty Killer For Gifting Wheelchairs To Elderly</a></h3>
<div class="entry-meta">
<span class="entry-date">8 hours ago</span> </div>
</div>
</li>
<li class="post-265396 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news category-trending tag-cardi-b tag-eminem">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/03/26/cardi-b-calls-eminem-rejection-rumors-big-lies/" title="Cardi B Calls Eminem Rejection Rumors: &#8220;BIG LIES&#8221;">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/03/Cardi-B-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/03/26/cardi-b-calls-eminem-rejection-rumors-big-lies/" title="Cardi B Calls Eminem Rejection Rumors: &#8220;BIG LIES&#8221;">Cardi B Calls Eminem Rejection Rumors: &#8220;BIG LIES&#8221;</a></h3>
<div class="entry-meta">
<span class="entry-date">9 hours ago</span> </div>
</div>
</li>
<li class="post-265388 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news category-trending tag-koffee">
<div class="post-thumb">
<a href="https://urbanislandz.com/2021/03/26/koffee-lockdown-an-naacp-image-award-for-outstanding-international-song/" title="Koffee &#8220;Lockdown&#8221; An NAACP Image Award For Outstanding International Song">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/01/Koffee-music-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2021/03/26/koffee-lockdown-an-naacp-image-award-for-outstanding-international-song/" title="Koffee &#8220;Lockdown&#8221; An NAACP Image Award For Outstanding International Song">Koffee &#8220;Lockdown&#8221; An NAACP Image Award For Outstanding International Song</a></h3>
<div class="entry-meta">
<span class="entry-date">9 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments"></p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Trending</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/03/26/vybz-kartel-praised-bounty-killer-for-gifting-wheelchairs-to-elderly/"><img src="https://urbanislandz.com/wp-content/uploads/2018/08/Vybz-Kartel-Bounty-Killer-140x100.jpg" height="100" width="140" alt="Vybz Kartel Praised Bounty Killer For Gifting Wheelchairs To Elderly" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/03/26/vybz-kartel-praised-bounty-killer-for-gifting-wheelchairs-to-elderly/">Vybz Kartel Praised Bounty Killer For Gifting Wheelchairs To Elderly</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/03/26/cardi-b-calls-eminem-rejection-rumors-big-lies/"><img src="https://urbanislandz.com/wp-content/uploads/2021/03/Cardi-B-140x100.jpeg" height="100" width="140" alt="Cardi B Calls Eminem Rejection Rumors: &#8220;BIG LIES&#8221;" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/03/26/cardi-b-calls-eminem-rejection-rumors-big-lies/">Cardi B Calls Eminem Rejection Rumors: &#8220;BIG LIES&#8221;</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/03/26/koffee-lockdown-an-naacp-image-award-for-outstanding-international-song/"><img src="https://urbanislandz.com/wp-content/uploads/2020/01/Koffee-music-140x100.jpg" height="100" width="140" alt="Koffee &#8220;Lockdown&#8221; An NAACP Image Award For Outstanding International Song" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/03/26/koffee-lockdown-an-naacp-image-award-for-outstanding-international-song/">Koffee &#8220;Lockdown&#8221; An NAACP Image Award For Outstanding International Song</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/03/26/boosie-badazz-on-wifing-lori-harvey-i-dont-want-a-car-after-it-had-8-owners/"><img src="https://urbanislandz.com/wp-content/uploads/2021/02/Boosie-Lori-Harvey-140x100.jpg" height="100" width="140" alt="Boosie Badazz On Wifing Lori Harvey: &#8220;I don’t want a car after it had 8 owners&#8221;" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/03/26/boosie-badazz-on-wifing-lori-harvey-i-dont-want-a-car-after-it-had-8-owners/">Boosie Badazz On Wifing Lori Harvey: &#8220;I don’t want a car after it had 8 owners&#8221;</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2021/03/26/intence-drops-public-enemy-no-1-mixtape-feat-govana-jah-cure-i-waata/"><img src="https://urbanislandz.com/wp-content/uploads/2021/02/Intence-music-140x100.jpg" height="100" width="140" alt="Intence Drops &#8220;Public Enemy No. 1&#8221; Mixtape Feat. Govana, Jah Cure &#038; I Waata" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2021/03/26/intence-drops-public-enemy-no-1-mixtape-feat-govana-jah-cure-i-waata/">Intence Drops &#8220;Public Enemy No. 1&#8221; Mixtape Feat. Govana, Jah Cure &#038; I Waata</a></h3><br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
 <span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li>
<li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li>
<li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>
<span class="copyright">Copyright © 2021 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/65f3d.js?fe4f1"></script></body>
</html>
