<!DOCTYPE html>
<html lang="en-US">
<head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/cssjs/7494c.css?92640" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">

<title>Nicholas Lall Claims Spice Wanted To Abort Son, Shares Baby Cham Story - Urban Islandz</title>
<meta name="description" content="In a lengthy interview, Nicholas Lall did on social media, the father of Spice’s two children has not taken a DNA test yet, but he claims that he has" />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://urbanislandz.com/2020/12/29/nicholas-lall-spice-abortion-son-shares-baby-cham-story/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Nicholas Lall Claims Spice Wanted To Abort Son, Shares Baby Cham Story - Urban Islandz" />
<meta property="og:description" content="In a lengthy interview, Nicholas Lall did on social media, the father of Spice’s two children has not taken a DNA test yet, but he claims that he has" />
<meta property="og:url" content="https://urbanislandz.com/2020/12/29/nicholas-lall-spice-abortion-son-shares-baby-cham-story/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2020-12-29T18:56:34+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />

<link rel="amphtml" href="https://urbanislandz.com/2020/12/29/nicholas-lall-spice-abortion-son-shares-baby-cham-story/amp/" /><meta name="generator" content="AMP for WP 1.0.73" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='stylesheet' id='primenews-google-fonts-css' href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2C700%2C700i%2Citalic%7CWork+Sans%3Aregular%2C600%2C700%7CLibre+Franklin%3Aregular%2C500%2C600&#038;ver=5.6' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/253801" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice.jpg" />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.site-footer{
	background-color:#000000;
	color:#cccccc;
}
.site-footer .widget .title{
	color:#cccccc;
}
.site-footer a{
	color:#cccccc;
}
body{
	font-family:"PT Sans";
}
.slides li h3{
	font-family:"PT Sans";
	font-weight:normal;
}
.widget h3.title{
	font-family:"PT Sans";
	font-weight:bold;
}
.entry-title{
	font-size:22px;
}
.single h1.entry-title{
	font-family:"PT Sans";
	font-size:28px;
}
.page h1.entry-title{
	font-size:28px;
}

</style>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-253801 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">

<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" loading="lazy" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-10" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">rss</span>
<span class="zoom-social_icons-list-span social-icon socicon socicon-rss" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="inner-wrap">
<div class="musicad11">
<div class="musicad112">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-253801" class="post-253801 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-non category-news tag-spice">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/news/dancehall/" rel="category tag">Dancehall</a>, <a href="https://urbanislandz.com/category/non/" rel="category tag">Feature</a>, <a href="https://urbanislandz.com/category/news/" rel="category tag">News</a></span>
<h1 class="entry-title fn">Nicholas Lall Claims Spice Wanted To Abort Son, Shares Baby Cham Story</h1> <div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a></span> <span class="entry-date"> <time class="entry-date" datetime="2020-12-29T13:56:34-05:00">December 29, 2020</time> </span> </div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1400" height="800" src="https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice-300x171.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice-700x400.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice-400x230.jpg 400w" sizes="(max-width: 1400px) 100vw, 1400px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/dseitaram/" title="Posts by Devi Seitaram" rel="author">Devi Seitaram</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>In a lengthy interview, Nicholas Lall did on social media, the <a href="https://urbanislandz.com/2020/12/23/love-hip-hop-atl-star-spice-baby-daddy-requests-dna-test-amid-baby-cham-rumors/">father of Spice’s two children has not taken a DNA test ye</a>t, but he claims that he has doubts about the paternity of the children, who he says Spice wanted to abort when she got pregnant both times.</p>
<p>In the interview, Nicholas Lall said <a href="https://urbanislandz.com/artist/spice/">Spice</a> wanted to have abortions when she was pregnant, but he begged her not to. He also seems to suspect that his son might be fathered by Baby Cham as he claims Spice had a photo of Cham’s son when her own son was yet a baby, and both children have a stark resemblance.</p>
<p>“Now allegations are out there now that my son is not mine. Yeah, yeah, I’ve never shared this with nobody else. When my son was four months in the house, a likkle baby, newborn baby too, it was Cham, baby Cham son and I was going through the draw and see the baby. She told me is her bredda, her musical bredda…”</p>
<p>He continued, “anyways, when I found the pic and I called her and I looked at my son and I was like damn, they look alike. Mi call her and say Cham a di father and yow, that woman she cried ‘am evil, wicked, how could you even say that’ till mi even start feel bad.”</p>
<p>Lall says he has compared recent images of Cham’s son to his son, and it is like he was looking at his own son. “When all of these allegations come out…a video of that kid and it was like I was looking at my own son and I was like damn, that shit hurt me yow. Mi cry till me all fricken vomit. The worse part of it is I love this kid so much, I would die for this kid, that’s how much I love him.”</p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CJOY1NBnFT-/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/CJOY1NBnFT-/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p></a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/CJOY1NBnFT-/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by QUEEN OF DANCEHALL (@spiceofficial)</a></p>
</div>
</blockquote>
<p><script async src="//platform.instagram.com/en_US/embeds.js"></script></p>
<p>Nicholas Lall says his family has confirmed to him their suspicions that the child is not his, but they were afraid to hurt him due to the bond he shared with Spice’s son. He says even if a DNA precludes him from being the father, he will still play the role in the child’s life.</p>
<p>“Even if I do DNA and it comes back he is not my son, he is my son. I cya stop loving him. Unconditional love is not something you can turn off. The most hurtful thing when him call me and say ‘daddy I see everything that’s going on on the internet and this guy talking things on the internet about my mom, can you stop it?’ I said I tried to stop it but Nicholas this is your mom, cousin or friend or whoever she tell me he was. She make him see everything.”</p>
<p>Lall also says the rumors of his son being fathered by another man has hurt his son, who brought it to his attention.</p>
<p>“‘Daddy they say im a jacket,’ when he said that to me mi start cry. So I said to him – I call him Papi- Papi if you are a jacket, then you are a jacket I’m gonna wear. I’m gonna wear this jacket till it torn up, till it can’t wear no more…whether or not I am your biological father I am still your dad and nothing in the world will ever change that.”</p>
<p>Lall says he plans to do DNA on both children because Spice was not faithful during the relationship. “She wasn’t faithful at no point during the relationship.”</p>
<p>Lall also says he believes Spice acted Shady by not giving his son his last name when they moved to Atlanta. Usually, children will need both parents to sign, and even children are migrating, the U.S embassy can require DNA tests to prove paternity. However, he also said he did not sign the son’s birth certificate at birth, so the child goes by Spice’s maiden name Hamilton. </p>
<p>“Next thing that draw my accusation- she lied to me about my son, she lied to me and said she can’t gi him my last name because I wasn’t there to sign his birth certificate. No, she could have given him my name ‘Lall’ my name wouldn’t be on the birth certificate. She give him the name Hamilton. Lall is his middle name.”</p>
<p>Meanwhile, it seems that Spice and Baby Cham are closer than both let on as Baby Cham is the alleged God Father of Spice’s son. “Cham is my son’s God father. “When she was pregnant she and Cham have a big falling out and them never talk for years, they never talk for a year.”</p>
<p>Lall also claims that Spice did not want to be a mother as she was more focused on her career. “I had to beg her not to abort that kid. Both kids I had to beg her not to abort. My mother that is dead and gone had to beg her not to abort and told her ‘have the baby and bring them mi wi tek care a dem’….She never want no pickney, she was thinking about career…I had to take her breast out to give the baby to suck- she not even want to do that.”</p>
<p><iframe title="(Exclusive) Nicholas Talk Baby Cham Being Spice Baby Father AB0RTION And When Last He Talk To Dancer" width="750" height="563" src="https://www.youtube.com/embed/XISq84zoXeU?start=167&#038;feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<style>@media (max-width: 1000px) {
							
							
						}</style><style>body .novashare-buttons.novashare-inline .novashare-button-icon { width: 100%; }</style><div class='novashare-buttons novashare-inline novashare-inline-below novashare-no-print'><div class='novashare-buttons-wrapper'><a href='https://twitter.com/intent/tweet?text=Nicholas%20Lall%20Claims%20Spice%20Wanted%20To%20Abort%20Son%2C%20Shares%20Baby%20Cham%20Story&url=https%3A%2F%2Furbanislandz.com%2F2020%2F12%2F29%2Fnicholas-lall-spice-abortion-son-shares-baby-cham-story%2F' aria-label='Twitter' target='_blank' class='novashare-button twitter' rel='nofollow noopener noreferrer'><span class='novashare-button-wrapper novashare-button-block'><span class='novashare-button-icon novashare-button-block'><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 512 512"><path fill="currentColor" d="M459.37 151.716c.325 4.548.325 9.097.325 13.645 0 138.72-105.583 298.558-298.558 298.558-59.452 0-114.68-17.219-161.137-47.106 8.447.974 16.568 1.299 25.34 1.299 49.055 0 94.213-16.568 130.274-44.832-46.132-.975-84.792-31.188-98.112-72.772 6.498.974 12.995 1.624 19.818 1.624 9.421 0 18.843-1.3 27.614-3.573-48.081-9.747-84.143-51.98-84.143-102.985v-1.299c13.969 7.797 30.214 12.67 47.431 13.319-28.264-18.843-46.781-51.005-46.781-87.391 0-19.492 5.197-37.36 14.294-52.954 51.655 63.675 129.3 105.258 216.365 109.807-1.624-7.797-2.599-15.918-2.599-24.04 0-57.828 46.782-104.934 104.934-104.934 30.213 0 57.502 12.67 76.67 33.137 23.715-4.548 46.456-13.32 66.599-25.34-7.798 24.366-24.366 44.833-46.132 57.827 21.117-2.273 41.584-8.122 60.426-16.243-14.292 20.791-32.161 39.308-52.628 54.253z"></path></svg></span><span class='novashare-button-label novashare-button-block novashare-hide'><span class='novashare-button-label-wrapper'>Twitter</span></span></span></a><a href='https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Furbanislandz.com%2F2020%2F12%2F29%2Fnicholas-lall-spice-abortion-son-shares-baby-cham-story%2F' aria-label='Facebook' target='_blank' class='novashare-button facebook' rel='nofollow noopener noreferrer'><span class='novashare-button-wrapper novashare-button-block'><span class='novashare-button-icon novashare-button-block'><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 320 512"><path fill="currentColor" d="M279.14 288l14.22-92.66h-88.91v-60.13c0-25.35 12.42-50.06 52.24-50.06h40.42V6.26S260.43 0 225.36 0c-73.22 0-121.08 44.38-121.08 124.72v70.62H22.89V288h81.39v224h100.17V288z"></path></svg></span><span class='novashare-button-label novashare-button-block novashare-hide'><span class='novashare-button-label-wrapper'>Facebook</span></span></span></a></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/spice/" rel="tag">Spice</a></div>
<div class="related">
<div class="related-heading">More Spice News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/12/23/ishawna-fired-back-at-lisa-hyper-following-call-for-peace/" rel="bookmark" title="Permanent Link to Ishawna Fired Back at Lisa Hyper Following Call for Peace">Ishawna Fired Back at Lisa Hyper Following Call for Peace</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/12/23/love-hip-hop-atl-star-spice-baby-daddy-requests-dna-test-amid-baby-cham-rumors/" rel="bookmark" title="Permanent Link to Love &#038; Hip Hop ATL Star Spice Baby Daddy Requests DNA Test Amid Baby Cham Rumors">Love &#038; Hip Hop ATL Star Spice Baby Daddy Requests DNA Test Amid Baby Cham Rumors</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/12/21/rt-boss-claism-he-made-spice-turned-down-shenseea-collab/" rel="bookmark" title="Permanent Link to RT Boss Claism He Made Spice Turned Down Shenseea Collab">RT Boss Claism He Made Spice Turned Down Shenseea Collab</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-253604" class="post-253604 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-videos tag-intence">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/12/29/intence-light-up-the-place-with-new-visual/" title="Intence &#8220;Light Up&#8221; The Place With New Visual">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/11/Intence-dancehall-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/12/29/intence-light-up-the-place-with-new-visual/" title="Intence &#8220;Light Up&#8221; The Place With New Visual">Intence &#8220;Light Up&#8221; The Place With New Visual</a></h3>
<p>Intence has teamed up with Zimi Entertainment for yet another release this year. This time he delivers a brand new<a class="read-more" href="https://urbanislandz.com/2020/12/29/intence-light-up-the-place-with-new-visual/">[Read More&#8230;]</a></p>
<div class="entry-meta">
<span class="entry-date">44 mins ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-253542 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-migos tag-quavo">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/12/29/quavo-shares-good-news-on-culture-iii-release-date-feature-list/" title="Quavo Shares Good News On &#8220;Culture III&#8221; Release Date &#038; Feature List">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2018/08/Quavo-and-Migos-665x380.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Quavo and Migos" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/12/29/quavo-shares-good-news-on-culture-iii-release-date-feature-list/" title="Quavo Shares Good News On &#8220;Culture III&#8221; Release Date &#038; Feature List">Quavo Shares Good News On &#8220;Culture III&#8221; Release Date &#038; Feature List</a></h3>
<div class="entry-meta">
<span class="entry-date">46 mins ago</span> </div>
</div>
</li>
<li class="post-253832 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-kenneth-petty tag-meek-mill tag-nicki-minaj">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/12/29/nicki-minaj-barbz-drags-meek-mill-for-mentioning-her-baby-in-clubhouse-rant/" title="Nicki Minaj Barbz Drags Meek Mill For Mentioning Her Baby In Clubhouse Rant">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/07/Meek-Mill-Nicki-Minaj-pregnant-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" srcset="https://urbanislandz.com/wp-content/uploads/2020/07/Meek-Mill-Nicki-Minaj-pregnant-400x230.jpg 400w, https://urbanislandz.com/wp-content/uploads/2020/07/Meek-Mill-Nicki-Minaj-pregnant-700x400.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/07/Meek-Mill-Nicki-Minaj-pregnant-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/07/Meek-Mill-Nicki-Minaj-pregnant.jpg 1400w" sizes="(max-width: 400px) 100vw, 400px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/12/29/nicki-minaj-barbz-drags-meek-mill-for-mentioning-her-baby-in-clubhouse-rant/" title="Nicki Minaj Barbz Drags Meek Mill For Mentioning Her Baby In Clubhouse Rant">Nicki Minaj Barbz Drags Meek Mill For Mentioning Her Baby In Clubhouse Rant</a></h3>
<div class="entry-meta">
<span class="entry-date">2 hours ago</span> </div>
</div>
</li>
<li class="post-253822 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news category-trending tag-jay-z tag-lil-wayne tag-young-thug">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/12/29/young-thug-gets-backlash-for-dising-jay-z-calls-out-lil-wayne-for-verzuz-challenge/" title="Young Thug Gets Backlash For Dising Jay-Z, Calls Out Lil Wayne For Verzuz Challenge">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/08/Young-Thug-Thugger-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/12/29/young-thug-gets-backlash-for-dising-jay-z-calls-out-lil-wayne-for-verzuz-challenge/" title="Young Thug Gets Backlash For Dising Jay-Z, Calls Out Lil Wayne For Verzuz Challenge">Young Thug Gets Backlash For Dising Jay-Z, Calls Out Lil Wayne For Verzuz Challenge</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
<li class="post-253795 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-french-montana">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/12/29/french-montana-says-near-death-cause-him-to-quit-alcohol-drugs/" title="French Montana Says Near Death Cause Him To Quit Alcohol &#038; Drugs">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/08/French-Montana-4-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/12/29/french-montana-says-near-death-cause-him-to-quit-alcohol-drugs/" title="French Montana Says Near Death Cause Him To Quit Alcohol &#038; Drugs">French Montana Says Near Death Cause Him To Quit Alcohol &#038; Drugs</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments">Comments are closed.</p>
</div>
 </div>
<section id="site-sidebar">
<div class="adv_side">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-48"><h3 class="title">Feature</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/12/29/nicholas-lall-spice-abortion-son-shares-baby-cham-story/"><img src="https://urbanislandz.com/wp-content/uploads/2020/12/Nicholas-Lall-and-Spice-120x100.jpg" height="100" width="120" alt="Nicholas Lall Claims Spice Wanted To Abort Son, Shares Baby Cham Story" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/12/29/nicholas-lall-spice-abortion-son-shares-baby-cham-story/">Nicholas Lall Claims Spice Wanted To Abort Son, Shares Baby Cham Story</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/12/28/tommy-lee-sparta-hosts-impromptu-jailhouse-party-in-leaked-video/"><img src="https://urbanislandz.com/wp-content/uploads/2018/05/Tommy-Lee-Sparta-live-120x100.jpg" height="100" width="120" alt="Tommy Lee Sparta Hosts Impromptu Jailhouse Party In Leaked Video" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/12/28/tommy-lee-sparta-hosts-impromptu-jailhouse-party-in-leaked-video/">Tommy Lee Sparta Hosts Impromptu Jailhouse Party In Leaked Video</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/12/26/iggy-azalea-exposed-playboi-cart-for-cheating-during-pregnancy-side-chick-respond/"><img src="https://urbanislandz.com/wp-content/uploads/2020/12/Iggy-Azalea-son-Playboi-Carti-120x100.jpg" height="100" width="120" alt="Iggy Azalea Exposed Playboi Cart For Cheating During Pregnancy, Side Chick Respond" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/12/26/iggy-azalea-exposed-playboi-cart-for-cheating-during-pregnancy-side-chick-respond/">Iggy Azalea Exposed Playboi Cart For Cheating During Pregnancy, Side Chick Respond</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/12/23/love-hip-hop-atl-star-spice-baby-daddy-requests-dna-test-amid-baby-cham-rumors/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Spice-and-Nicholas-Lall-120x100.jpg" height="100" width="120" alt="Love &#038; Hip Hop ATL Star Spice Baby Daddy Requests DNA Test Amid Baby Cham Rumors" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/12/23/love-hip-hop-atl-star-spice-baby-daddy-requests-dna-test-amid-baby-cham-rumors/">Love &#038; Hip Hop ATL Star Spice Baby Daddy Requests DNA Test Amid Baby Cham Rumors</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/12/22/tekashi-6ix9ine-responds-to-lawsuit-from-robbery-victim-vows-to-fight/"><img src="https://urbanislandz.com/wp-content/uploads/2020/08/Tekashi-6ix9ine-LA-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine Responds To Lawsuit From Robbery Victim, Vows To Fight" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/12/22/tekashi-6ix9ine-responds-to-lawsuit-from-robbery-victim-vows-to-fight/">Tekashi 6ix9ine Responds To Lawsuit From Robbery Victim, Vows To Fight</a></h3><br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-feedburner" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3>
<ul>
<li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li>
<li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<span class="copyright">Copyright © 2020 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/9b1c5.js?46b8f"></script></body>
</html>
