<!DOCTYPE html>
<html lang="en-US">
<head><link rel='stylesheet' id='primenews-google-fonts-css' href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2Citalic%2C700%2C700italic%26subset%3Dlatin%2C&#038;ver=5.3.2' type='text/css' media='all' /><link data-optimized='2' rel='stylesheet' href='https://urbanislandz.com/min/fbe0c.css' /><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<title>Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports - Urban Islandz</title>

<meta name="description" content="Dancehall selector Foota Hype has gone missing in action for the past five days, and his fans are worried that he has been captured by the United States" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports - Urban Islandz" />
<meta property="og:description" content="Dancehall selector Foota Hype has gone missing in action for the past five days, and his fans are worried that he has been captured by the United States" />
<meta property="og:url" content="https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:tag" content="Foota Hype" />
<meta property="article:section" content="Dancehall" />
<meta property="article:published_time" content="2019-12-18T23:36:50+00:00" />
<meta property="article:modified_time" content="2019-12-19T00:40:16+00:00" />
<meta property="og:updated_time" content="2019-12-19T00:40:16+00:00" />
<meta property="fb:app_id" content="137673839610560" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8.jpg" />
<meta property="og:image:secure_url" content="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8.jpg" />
<meta property="og:image:width" content="1250" />
<meta property="og:image:height" content="764" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Dancehall selector Foota Hype has gone missing in action for the past five days, and his fans are worried that he has been captured by the United States" />
<meta name="twitter:title" content="Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports - Urban Islandz" />
<meta name="twitter:site" content="@urbanislandz" />
<meta name="twitter:image" content="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8.jpg" />
<meta name="twitter:creator" content="@urbanislandz" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://urbanislandz.com/#organization","name":"Urban Islandz","url":"https://urbanislandz.com/","sameAs":["https://www.facebook.com/urbanislandz","https://instagram.com/urbanislandz","https://www.youtube.com/user/CaribbeanUrbanMedia/","https://twitter.com/urbanislandz"],"logo":{"@type":"ImageObject","@id":"https://urbanislandz.com/#logo","url":"https://urbanislandz.com/wp-content/uploads/2018/01/Urbanislandz-logo-amp-1.png","width":300,"height":26,"caption":"Urban Islandz"},"image":{"@id":"https://urbanislandz.com/#logo"}},{"@type":"WebSite","@id":"https://urbanislandz.com/#website","url":"https://urbanislandz.com/","name":"Urban Islandz","description":"Dancehall &amp; Hip Hop","publisher":{"@id":"https://urbanislandz.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://urbanislandz.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#primaryimage","url":"https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8.jpg","width":1250,"height":764},{"@type":"WebPage","@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#webpage","url":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/","inLanguage":"en-US","name":"Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports - Urban Islandz","isPartOf":{"@id":"https://urbanislandz.com/#website"},"primaryImageOfPage":{"@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#primaryimage"},"datePublished":"2019-12-18T23:36:50+00:00","dateModified":"2019-12-19T00:40:16+00:00","description":"Dancehall selector Foota Hype has gone missing in action for the past five days, and his fans are worried that he has been captured by the United States","breadcrumb":{"@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/","url":"https://urbanislandz.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/dancehall/","url":"https://urbanislandz.com/category/dancehall/","name":"Dancehall"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/","url":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/","name":"Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports"}}]},{"@type":"NewsArticle","@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#article","isPartOf":{"@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#webpage"},"author":{"@id":"https://urbanislandz.com/#/schema/person/4f75c157b6b406574a21d020f28b7521"},"headline":"Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports","datePublished":"2019-12-18T23:36:50+00:00","dateModified":"2019-12-19T00:40:16+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#webpage"},"publisher":{"@id":"https://urbanislandz.com/#organization"},"image":{"@id":"https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/#primaryimage"},"keywords":"Foota Hype","articleSection":"Dancehall,News,Trending","copyrightYear":"2019","copyrightHolder":{"@id":"https://urbanislandz.com/#organization"}},{"@type":["Person"],"@id":"https://urbanislandz.com/#/schema/person/4f75c157b6b406574a21d020f28b7521","name":"Claudia Gardner","sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='https://api.w.org/' href='https://urbanislandz.com/wp-json/' />
<link rel='amphtml' href='https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/amp/' /><script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script>

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"PT Sans";
}
.entry-title a{
	color:#444444;
}
.cat-links a{
	color:#dd0000;
}
.page h1.entry-title, .single h1.entry-title{
	color:#444444;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"PT Sans";
	font-weight:normal;
}
.top-navbar a{
	font-family:"PT Sans";
	font-weight:normal;
}
.main-navbar a{
	font-family:"PT Sans";
	font-weight:700;
}
.slides li h3{
	font-family:"PT Sans";
	font-weight:normal;
}
.widget h3.title{
	font-family:"PT Sans";
	font-weight:700;
}
.site-footer .widget h3.title{
	font-family:"PT Sans";
	font-weight:700;
}
.entry-title{
	font-family:"PT Sans";
	font-weight:700;
}
.single h1.entry-title{
	font-family:"PT Sans";
	font-size:34px;
	font-weight:700;
}
.page h1.entry-title{
	font-family:"PT Sans";
	font-weight:normal;
}

</style>

<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-229613 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-123078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-123078"><a href="https://urbanislandz.com/category/lyrics/">Lyrics</a></li>
<li id="menu-item-83085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83085"><a href="https://urbanislandz.com/category/photos/">Photos</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="24" src="https://urbanislandz.com/wp-content/uploads/2019/02/Logo-UI-default-300x24.png" class="custom-logo" alt="Urban Islandz" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/Logo-UI-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/Logo-UI-default-200x16.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-10" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook</span>
<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#dd0000" style="background-color : #000000; font-size: 16px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#dd0000" style="background-color : #000000; font-size: 16px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#dd0000" style="background-color : #000000; font-size: 16px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">rss</span>
<span class="zoom-social_icons-list-span socicon socicon-rss" data-hover-rule="background-color" data-hover-color="#dd0000" style="background-color : #000000; font-size: 16px; padding:8px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="inner-wrap">
<div class="musicad11">
<div class="musicad112">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-229613" class="post-229613 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news category-trending tag-foota-hype">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/dancehall/" rel="category tag">Dancehall</a>, <a href="https://urbanislandz.com/category/news/" rel="category tag">News</a>, <a href="https://urbanislandz.com/category/trending/" rel="category tag">Trending</a></span>
<h1 class="entry-title fn">Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports</h1> <div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/cgardner/" title="Posts by Claudia Gardner" rel="author">Claudia Gardner</a></span> <span class="entry-date"> <time class="entry-date" datetime="2019-12-18T18:36:50-05:00">December 18, 2019</time> </span> </div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1250" height="764" src="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8.jpg 1250w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8-300x183.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8-768x469.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8-700x428.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8-600x367.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8-200x122.jpg 200w" sizes="(max-width: 1250px) 100vw, 1250px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/cgardner/" title="Posts by Claudia Gardner" rel="author">Claudia Gardner</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Dancehall selector Foota Hype has gone missing in action for the past five days, and his fans are worried that he has been captured by the United States Immigration and Customs Enforcement (ICE) agency.</p>
<p><a href="https://urbanislandz.com/artist/foota-hype/">Foota Hype</a>, who has declared himself the global Viral King, and who makes daily Instagram posts whether via live feed, regular posts, or on his IG stories, has not made a post for the last five days. His last post was on Saturday, which pictured him aboard the Welcome to Jamrock Reggae Cruise, clad in monochromatic black with the caption &#8220;Doreen son @welcometojamrockreggaecruise F.H.M.&#8221;</p>
<p>&#8220;Hopefully Foota get bail,&#8221; one woman posted in the comments section on Foota&#8217;s last post, while one fan wrote: &#8220;Free Foota.&#8221;</p>
<p>Some concerned persons also queried whether all was well with the entertainer, who had been uncharacteristically quiet. &#8220;Homie Is everything good with you cuz yuh nevah quiet suh,&#8221; one follower asked. </p>
<p>Another follower though, openly declared: &#8220;ICE still have him,&#8221; fueling further speculations that the selector was indeed in the custody of the immigration organization, which was created in 2003 through a merger of the investigative and interior enforcement elements of the former U.S. Customs Service and the Immigration and Naturalization Service.</p>
<p><img src="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-4.jpg" alt="" width="700" height="742" class="aligncenter size-full wp-image-219635" srcset="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-4.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-4-283x300.jpg 283w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-4-600x636.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-4-200x212.jpg 200w" sizes="(max-width: 700px) 100vw, 700px" /></p>
<p>ICE is responsible for immigration enforcement, combating transnational crime, and preventing terrorism. The organization has more than 20,000 law enforcement and support personnel in more than 400 offices in the United States and across the world.</p>
<p>According to ICE&#8217;s website, the organization&#8217;s mission is to protect the United States from the cross-border crime and illegal immigration that threaten the country&#8217;s national security and public safety. This, it says, is undertaken through the enforcement of more than 400 federal statutes and a focus on smart immigration enforcement, preventing terrorism and combating the illegal movement of people and goods.</p>
<p>Among the reasons given as to why a person can be detained by ICE are: if the detainee has committed a crime or multiple crimes; arrived at the border without a visa prior to formally applying for asylum or refugee status; has a deportation order on record, either pending or past due, or missed prior immigration hearing dates.</p>
<p>If Foota has indeed been captured by ICE, he joins a long list of Jamaicans who have been detained by the agency this year.</p>
<p>Some followers have not been very tactful in their remarks and found news of the likely detention of the entertainer amusing.</p>
<p>&#8220;Him beta mek sure the news fake&#8230;cause a wah day mi hear him a tell Kartel him better shut up cause him kno weh him deh&#8221; one woman said, while one young man jeered: &#8220;Hope yuh nuh drop the soap brogad &#8230;.bless up&#8221;.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-229613" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-229613" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/foota-hype/" rel="tag">Foota Hype</a></div>
 <div class="related">
<div class="related-heading">More Foota Hype News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2019/12/04/foota-hype-gets-push-backs-from-dancehall-fans-for-criticizing-walk-a-mile-in-her-shoes-protesters/" rel="bookmark" title="Permanent Link to Foota Hype Gets Push Backs From Dancehall Fans For Criticizing &#8216;Walk a Mile in Her Shoes&#8217; Protesters">Foota Hype Gets Push Backs From Dancehall Fans For Criticizing &#8216;Walk a Mile in Her Shoes&#8217; Protesters</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2019/12/03/vybz-kartel-to-be-blamed-for-sikka-rymes-getting-shot-foota-hype-speak/" rel="bookmark" title="Permanent Link to Is Vybz Kartel Affiliation The Reason Sikka Rymes Got Shot? Foota Hype Speak">Is Vybz Kartel Affiliation The Reason Sikka Rymes Got Shot? Foota Hype Speak</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2019/11/17/foota-hype-says-he-is-strapping-up-after-getting-threats-from-lgbt-community/" rel="bookmark" title="Permanent Link to Foota Hype Says He Is Strapping Up After Getting Threats From LGBT Community">Foota Hype Says He Is Strapping Up After Getting Threats From LGBT Community</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-229634" class="post-229634 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-gucci-mane">
<div class="post-thumb">
<a href="https://urbanislandz.com/2019/12/18/gucci-manes-east-atlanta-santa-3-arrives-friday-drops-jingle-bales-single/" title="Gucci Mane&#8217;s &#8216;East Atlanta Santa 3&#8217; Arrives Friday, Drops &#8220;Jingle Bales&#8221; Single">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa-400x230.jpg 400w, https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa-700x400.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa-600x343.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa-200x114.jpg 200w, https://urbanislandz.com/wp-content/uploads/2019/12/Gucci-Mane-Santa.jpg 1400w" sizes="(max-width: 400px) 100vw, 400px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2019/12/18/gucci-manes-east-atlanta-santa-3-arrives-friday-drops-jingle-bales-single/" title="Gucci Mane&#8217;s &#8216;East Atlanta Santa 3&#8217; Arrives Friday, Drops &#8220;Jingle Bales&#8221; Single">Gucci Mane&#8217;s &#8216;East Atlanta Santa 3&#8217; Arrives Friday, Drops &#8220;Jingle Bales&#8221; Single</a></h3>
<div class="entry-meta">
<span class="entry-date">14 hours ago</span>  </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-229630 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-eminem tag-kendrick-lamar tag-the-game">
<div class="post-thumb">
<a href="https://urbanislandz.com/2019/12/18/the-game-says-kendrick-lamar-is-the-eminem-of-this-rap-era/" title="The Game Says Kendrick Lamar Is The Eminem Of This Rap Era">
<img width="220" height="130" src="https://urbanislandz.com/wp-content/uploads/2019/12/The-Game-and-Kendrick-Lamar-220x130.jpg" class="attachment-loop size-loop wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2019/12/18/the-game-says-kendrick-lamar-is-the-eminem-of-this-rap-era/" title="The Game Says Kendrick Lamar Is The Eminem Of This Rap Era">The Game Says Kendrick Lamar Is The Eminem Of This Rap Era</a></h3>
<div class="entry-meta">
<span class="entry-date">14 hours ago</span> </div>
</div>
</li>
<li class="post-229624 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news category-trending tag-vybz-kartel">
<div class="post-thumb">
<a href="https://urbanislandz.com/2019/12/18/vybz-kartel-new-prison-photos-brings-back-old-gaza-memories-with-lisa-hyper/" title="Vybz Kartel New Prison Photos Brings Back Old Gaza Memories With Lisa Hyper">
<img width="220" height="130" src="https://urbanislandz.com/wp-content/uploads/2019/12/Vybz-Kartel-Lisa-Hyper-prison-220x130.jpg" class="attachment-loop size-loop wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2019/12/18/vybz-kartel-new-prison-photos-brings-back-old-gaza-memories-with-lisa-hyper/" title="Vybz Kartel New Prison Photos Brings Back Old Gaza Memories With Lisa Hyper">Vybz Kartel New Prison Photos Brings Back Old Gaza Memories With Lisa Hyper</a></h3>
<div class="entry-meta">
<span class="entry-date">15 hours ago</span> </div>
</div>
</li>
<li class="post-229619 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-dababy">
<div class="post-thumb">
<a href="https://urbanislandz.com/2019/12/18/dababy-says-rap-beefs-and-diss-tracks-is-not-his-lane/" title="DaBaby Says Rap Beefs And Diss Tracks Is Not His Lane">
<img width="220" height="130" src="https://urbanislandz.com/wp-content/uploads/2019/12/DaBaby-2-220x130.jpg" class="attachment-loop size-loop wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2019/12/18/dababy-says-rap-beefs-and-diss-tracks-is-not-his-lane/" title="DaBaby Says Rap Beefs And Diss Tracks Is Not His Lane">DaBaby Says Rap Beefs And Diss Tracks Is Not His Lane</a></h3>
<div class="entry-meta">
<span class="entry-date">16 hours ago</span> </div>
</div>
</li>
<li class="post-229615 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-news">
<div class="post-thumb">
<a href="https://urbanislandz.com/2019/12/18/dancehall-community-not-happy-about-jamaicas-entertainment-minister-comment-on-noise-act/" title="Folks Unhappy With Jamaica&#8217;s Entertainment Minister Statement On Noise Act">
<img width="220" height="130" src="https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-220x130.jpg" class="attachment-loop size-loop wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-220x130.jpg 220w, https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-300x178.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-768x455.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-700x414.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-600x355.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West-200x118.jpg 200w, https://urbanislandz.com/wp-content/uploads/2019/10/Babsy-Grange-and-Kanye-West.jpg 1250w" sizes="(max-width: 220px) 100vw, 220px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2019/12/18/dancehall-community-not-happy-about-jamaicas-entertainment-minister-comment-on-noise-act/" title="Folks Unhappy With Jamaica&#8217;s Entertainment Minister Statement On Noise Act">Folks Unhappy With Jamaica&#8217;s Entertainment Minister Statement On Noise Act</a></h3>
<div class="entry-meta">
<span class="entry-date">17 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments">.</p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-43"><h3 class="title">Top Stories</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2019/12/18/vybz-kartel-new-prison-photos-brings-back-old-gaza-memories-with-lisa-hyper/"><img src="https://urbanislandz.com/wp-content/uploads/2019/12/Vybz-Kartel-Lisa-Hyper-prison-120x100.jpg" height="100" width="120" alt="Vybz Kartel New Prison Photos Brings Back Old Gaza Memories With Lisa Hyper" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2019/12/18/vybz-kartel-new-prison-photos-brings-back-old-gaza-memories-with-lisa-hyper/">Vybz Kartel New Prison Photos Brings Back Old Gaza Memories With Lisa Hyper</a></h3><br /><div class="entry-meta">15 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/"><img src="https://urbanislandz.com/wp-content/uploads/2019/08/Foota-Hype-8-120x100.jpg" height="100" width="120" alt="Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2019/12/18/dancehall-veteran-foota-hype-held-by-us-immigration-ice-in-miami-reports/">Dancehall Veteran Foota Hype Held By US Immigration ICE In Miami: Reports</a></h3><br /><div class="entry-meta">17 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2019/12/18/meek-mill-hilarious-drunken-freestyle-diddy-birthday-video/"><img src="https://urbanislandz.com/wp-content/uploads/2019/12/Meek-Mill-25-120x100.jpg" height="100" width="120" alt="Meek Mill Spits Hilarious Drunken Freestyle At Diddy’s Birthday Over Luther Vandross Classic" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2019/12/18/meek-mill-hilarious-drunken-freestyle-diddy-birthday-video/">Meek Mill Spits Hilarious Drunken Freestyle At Diddy’s Birthday Over Luther Vandross Classic</a></h3><br /><div class="entry-meta">20 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2019/12/18/tekashi-6ix9ines-biological-breaks-silence-says-he-is-safer-in-prison/"><img src="https://urbanislandz.com/wp-content/uploads/2019/12/Takashi-father-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine&#8217;s Biological Breaks Silence, Says He Is Safer In Prison" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2019/12/18/tekashi-6ix9ines-biological-breaks-silence-says-he-is-safer-in-prison/">Tekashi 6ix9ine&#8217;s Biological Breaks Silence, Says He Is Safer In Prison</a></h3><br /><div class="entry-meta">20 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2019/12/18/tekashi-6ix9ine-baby-mama-sara-celebrates-as-he-heads-to-prison/"><img src="https://urbanislandz.com/wp-content/uploads/2019/12/Tekashi-baby-mama-Sara-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine Baby Mama Sara Celebrates As He Heads To Prison" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2019/12/18/tekashi-6ix9ine-baby-mama-sara-celebrates-as-he-heads-to-prison/">Tekashi 6ix9ine Baby Mama Sara Celebrates As He Heads To Prison</a></h3><br /><div class="entry-meta">21 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/dancehallhiphop/">
<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/DHHofficial">
<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/dancehallhiphop/">
<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#E1306C" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://dancehallhiphop.com/feed/">
<span class="zoom-social_icons-list-span socicon socicon-rss" data-hover-rule="background-color" data-hover-color="#1e73be" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-123078"><a href="https://urbanislandz.com/category/lyrics/">Lyrics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83085"><a href="https://urbanislandz.com/category/photos/">Photos</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3> <ul>
<li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li>
<li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<span class="copyright">Copyright © 2018 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://urbanislandz.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "003aa35b46", post_id : 229613 } ); } ); /* ]]> */</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><script data-optimized='1' src='https://urbanislandz.com/min/a2efd.js' defer></script></body>
</html>
