<!DOCTYPE html><html lang="en-US"><head><style id="litespeed-optm-css-rules">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</style><link data-asynced="1" as="style" onload="this.onload=null;this.rel='stylesheet'" rel='preload' id='primenews-google-fonts-css' href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2Citalic%2C700%2C700italic%26subset%3Dlatin%2C&#038;ver=5.4.2&#038;display=swap' type='text/css' media='all' /><noscript><link rel='stylesheet' id='primenews-google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2Citalic%2C700%2C700italic%26subset%3Dlatin%2C&#038;ver=5.4.2&#038;display=swap' type='text/css' media='all' /></noscript><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://urbanislandz.com/wp-content/litespeed/cssjs/642f42fc21e3db72e77a7bd68538a7ac.css" /><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/fba99.js"></script><script id="litespeed-css-async-lib" src="https://urbanislandz.com/wp-content/plugins/litespeed-cache/assets/js/css_async.min.js"></script><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://urbanislandz.com/xmlrpc.php"><title>50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday - Urban Islandz</title><meta name="description" content="T.I. issued a challenge to 50 Cent for a Verzuz battle on the day he&#039;s celebrating his birthday and now Fif is responding. Over the last few months, the" /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday - Urban Islandz" /><meta property="og:description" content="T.I. issued a challenge to 50 Cent for a Verzuz battle on the day he&#039;s celebrating his birthday and now Fif is responding. Over the last few months, the" /><meta property="og:url" content="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/" /><meta property="og:site_name" content="Urban Islandz" /><meta property="article:publisher" content="https://www.facebook.com/urbanislandz" /><meta property="article:published_time" content="2020-07-06T23:09:27+00:00" /><meta property="article:modified_time" content="2020-07-06T23:10:22+00:00" /><meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I..jpg" /><meta property="og:image:width" content="1400" /><meta property="og:image:height" content="800" /><meta property="fb:app_id" content="137673839610560" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@urbanislandz" /><meta name="twitter:site" content="@urbanislandz" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://urbanislandz.com/#organization","name":"Urban Islandz","url":"https://urbanislandz.com/","sameAs":["https://www.facebook.com/urbanislandz","https://instagram.com/urbanislandz","https://www.youtube.com/user/CaribbeanUrbanMedia/","https://twitter.com/urbanislandz"],"logo":{"@type":"ImageObject","@id":"https://urbanislandz.com/#logo","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2018/01/Urbanislandz-logo-amp-1.png","width":300,"height":26,"caption":"Urban Islandz"},"image":{"@id":"https://urbanislandz.com/#logo"}},{"@type":"WebSite","@id":"https://urbanislandz.com/#website","url":"https://urbanislandz.com/","name":"Urban Islandz","description":"Dancehall &amp; Hip Hop","publisher":{"@id":"https://urbanislandz.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://urbanislandz.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#primaryimage","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I..jpg","width":1400,"height":800},{"@type":"WebPage","@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#webpage","url":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/","name":"50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday - Urban Islandz","isPartOf":{"@id":"https://urbanislandz.com/#website"},"primaryImageOfPage":{"@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#primaryimage"},"datePublished":"2020-07-06T23:09:27+00:00","dateModified":"2020-07-06T23:10:22+00:00","description":"T.I. issued a challenge to 50 Cent for a Verzuz battle on the day he's celebrating his birthday and now Fif is responding. Over the last few months, the","breadcrumb":{"@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/"]}]},{"@type":"BreadcrumbList","@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/","url":"https://urbanislandz.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/","url":"https://urbanislandz.com/category/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/hip-hop/","url":"https://urbanislandz.com/category/news/hip-hop/","name":"Hip Hop"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/","url":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/","name":"50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday"}}]},{"@type":"NewsArticle","@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#article","isPartOf":{"@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#webpage"},"author":{"@id":"https://urbanislandz.com/#/schema/person/6d2a26a32e3cf857d2ef3685592302b1"},"headline":"50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday","datePublished":"2020-07-06T23:09:27+00:00","dateModified":"2020-07-06T23:10:22+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#webpage"},"publisher":{"@id":"https://urbanislandz.com/#organization"},"image":{"@id":"https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/#primaryimage"},"keywords":"50 Cent,T.I.","articleSection":"Hip Hop,Trending","inLanguage":"en-US","copyrightYear":"2020","copyrightHolder":{"@id":"https://urbanislandz.com/#organization"}},{"@type":["Person"],"@id":"https://urbanislandz.com/#/schema/person/6d2a26a32e3cf857d2ef3685592302b1","name":"Jamie Litton"}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='https://api.w.org/' href='https://urbanislandz.com/wp-json/' /><link rel='amphtml' href='https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/amp/' />
<style type="text/css" id="wpzoom-prime-news-custom-css">.navbar-brand-wpz .tagline{display:none;font-family:"PT Sans"}h1,h2,h3,h4,h5,h6{color:#000}.header_misc a{color:#000}.sb-search .sb-icon-search{color:#000}.entry-title a{color:#000}.cat-links a{color:#eee}.page h1.entry-title,.single h1.entry-title{color:#000}.widget .title{color:#d00}.site-footer{background-color:#000;color:#fff}.site-footer .widget .title{color:#fff}.site-footer a{color:#daefef}.site-footer a:hover{color:#d33}body{font-family:"Helvetica Neue",Helvetica,Arial,sans-serif}.navbar-brand-wpz h1{font-family:"PT Sans";font-weight:400}.top-navbar a{font-family:"PT Sans";font-weight:400}.main-navbar a{font-family:"PT Sans";font-weight:700}.slides li h3{font-family:"PT Sans";font-weight:400}.widget h3.title{font-family:"PT Sans";font-weight:700}.site-footer .widget h3.title{font-family:"PT Sans";font-weight:700}.entry-title{font-family:"PT Sans";font-weight:700}.single h1.entry-title{font-family:"PT Sans";font-size:34px;font-weight:700}.page h1.entry-title{font-family:"PT Sans";font-weight:400}</style><link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" /><meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" /><style type="text/css" id="wp-custom-css">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</style> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script> <script>document.addEventListener("DOMContentLoaded",function(){window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-17144505-1');});</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" /></head><body class="post-template-default single single-post postid-241842 single-format-standard wp-custom-logo"><div class="page-wrap"><header class="site-header"><div class="inner-wrap"><div class="brand-wrap"><div class="navbar-brand-wpz"></div><div class="header_misc"></div></div></div><nav class="main-navbar" role="navigation"><div class="inner-wrap"><div class="side-panel-btn"></div><div class="navbar-header-main"><div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li><li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li><li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li><li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li><li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li></ul></div></div><div id="navbar-main"><div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="header_social1"><div id="zoom-social-icons-widget-10" class="widget zoom-social-icons-widget"><ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels"><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank">
<span class="screen-reader-text">facebook</span>
<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span></a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span></a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span></a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank">
<span class="screen-reader-text">rss</span>
<span class="zoom-social_icons-list-span socicon socicon-rss" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span></a></li></ul></div></div><div id="sb-search" class="sb-search"><form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span></form></div><div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li><li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li><li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li></ul></div></div></div></nav><div class="clear"></div></header><div class="inner-wrap"><div class="musicad11"><div class="musicad112"><style type="text/css">.Header-Ad-Unit{display:inline-block;width:320px;height:100px}@media (max-width:415px){.Header-Ad-Unit{width:320px;height:100px}}@media (min-width:765px){.Header-Ad-Unit{width:728px;height:90px}}@media (min-width:980px){.Header-Ad-Unit{width:728px;height:90px}}</style><ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins> <script>document.addEventListener("DOMContentLoaded",function(){(adsbygoogle=window.adsbygoogle||[]).push({});});</script> </div></div><main id="main" class="site-main" role="main"><div class="content-area"><article id="post-241842" class="post-241842 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-50-cent tag-t-i"><header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8"><span class="cat-links"><a href="https://urbanislandz.com/category/news/hip-hop/" rel="category tag">Hip Hop</a>, <a href="https://urbanislandz.com/category/trending/" rel="category tag">Trending</a></span><h1 class="entry-title fn">50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday</h1><div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/jlitton/" title="Posts by Jamie Litton" rel="author">Jamie Litton</a></span> <span class="entry-date"> <time class="entry-date" datetime="2020-07-06T19:09:27-04:00">July 6, 2020</time> </span></div></header><header class="entry-image"><div class="post-thumb">
<img width="1400" height="800" src="https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I..jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I..jpg 1400w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-300x171.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-700x400.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-600x343.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-200x114.jpg 200w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-400x230.jpg 400w" sizes="(max-width: 1400px) 100vw, 1400px" /></div></header><div class="entry_wrapper"><div class="entry-details"><ul class="entry-meta"><li class="post_author_side"><a href="https://urbanislandz.com/author/jlitton/" title="Posts by Jamie Litton" rel="author">Jamie Litton</a> <span class="entry-author">Author</span></li></ul></div><div class="post_wrapper"><div class="entry-content"><p>T.I. issued a challenge to 50 Cent for a Verzuz battle on the day he&#8217;s celebrating his birthday and now Fif is responding.</p><p>Over the last few months, the Verzuz battle platform created by <a href="https://urbanislandz.com/artist/swizz-beatz/">Swizz Beatz</a> and <a href="https://urbanislandz.com/artist/timbaland/">Timbaland</a> seems to have become a permanent part of the culture. Since we are all forced to stay home more than ever and unable to enjoy many of our usual summertime festivities, listening to our favorite artists go hit-for-hit in a battle over who has the best catalog has become the next best thing for many music fans. Now it seems that in honor of <a href="https://urbanislandz.com/artist/50-cent/">50 Cent&#8217;s</a> birthday, <a href="https://urbanislandz.com/artist/t-i/">T.I.</a> has challenged the New York rapper to come get some smoke. In two separate Instagram posts on Monday, Tip delivered his proposal, saying, &#8220;For your birthday, I offer you a challenge, sir. Pull your a** up man, with twenty of your records man, sit across from me man, and get this work man.&#8221;</p><p>The first video saw T.I. talking into the camera showing the Atlanta native trying to entice Fifty into a battle with a bit of friendly roasting when he says, &#8220;I understand if you don&#8217;t wanna answer to that challenge, &#8217;cause last time you got challenged Kanye West dusted you&#8217;re a** off.&#8221; He then extended the challenge to the Verzuz creators, saying, &#8220;Swizz, Timbaland, hook the muthafu**in speakers up!&#8221;</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/tv/CCTzuofgKaf/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/tv/CCTzuofgKaf/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"></p><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></a></p><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/tv/CCTzuofgKaf/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">We love POWER / For LIFE/ BMF &amp; everything u doin on ?&#8230;. Now pull up and catch this Trap Muzik fade big fella&#8230;. @50cent @verzuztv @therealswizzz @timbaland #24hrsToRespond Repost if you ain&#39;t scared of this nigga @50cent Hook this shit UP?? I AINT SCARED OF THIS NIGGA? Westside Zone1 Atown BANKHEAD SHIT UDIGG ??ITS DA KIIIIIIING BIIITCH?? -drops mic ?</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/troubleman31/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> TIP</a> (@troubleman31) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-07-06T17:45:56+00:00">Jul 6, 2020 at 10:45am PDT</time></p></div></blockquote><p></p><p>The second video, posted only three hours later, features Tip talking on the phone with Kevin Hart, who happens to share a birthday with 50 Cent. &#8220;I know it&#8217;s your birthday man. I celebrate you,&#8221; he began. &#8220;But if you get a chance, ya hear me? You hear me Kevin Hart? If you get a chance, please tell Fifty bring his a** on out here get this smoke.&#8221; Kevin immediately responds, &#8220;Oh, Jesus Christ,&#8221; and you can almost hear him rolling his eyes on the other end of the line.</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/tv/CCUHS5qBMFm/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/tv/CCUHS5qBMFm/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"></p><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></a></p><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/tv/CCUHS5qBMFm/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Happy Gday @kevinhart4real Now tell @50cent cmon and catch this fade&#8230;. matter fact I&#39;m looking for a jet&#8230;. To pull up on HIM at his Lil Birthday Party or whatever&#8230;. I Wanna See What He Talkin Bout!!!! #TheSouthGotSomethingToSay And GodDamnit IM SAYING IT!!!! @verzuztv Repost if you ain&#39;t scared of this Nigga @50cent</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/troubleman31/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> TIP</a> (@troubleman31) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-07-06T20:40:53+00:00">Jul 6, 2020 at 1:40pm PDT</time></p></div></blockquote><p></p><p>&#8220;I speak for all the Southern people,&#8221; T.I. announces, &#8220;New York been saying sh*t under they breath about us and having little bullsh*t slick ass comments.&#8221; &#8220;You sayin&#8217; what needs to be said,&#8221; Kevin agrees.</p><p>Verzuz founders Swizz Beatz and Timbaland have yet to speak out on the challenge, but I think every hip hop fan can agree that this would be a great show. 50 Cent has since reacted to the challenge saying, &#8220;Yo somebody passed TI the weed they gave smokey in Friday. LOL.&#8221;</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CCUQyS8Hbtq/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CCUQyS8Hbtq/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"></p><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></a></p><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CCUQyS8Hbtq/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">yo somebody passed TI the weed they gave smokey in Friday. LOL ?</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/50cent/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> 50 Cent</a> (@50cent) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-07-06T21:59:45+00:00">Jul 6, 2020 at 2:59pm PDT</time></p></div></blockquote><p></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-241842" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-241842" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div><div class="clear"></div></div></div></div><div class="clear"></div><footer class="entry-footer"><div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/50-cent/" rel="tag">50 Cent</a>, <a href="https://urbanislandz.com/artist/t-i/" rel="tag">T.I.</a></div><div class="related"><div class="related-heading">More 50 Cent News</div><ul class="related-list"><div class="related-title"><li>
<a href="https://urbanislandz.com/2020/07/06/reginae-carter-take-shots-at-lil-wayne-50-cent-for-black-women-comments/" rel="bookmark" title="Permanent Link to Reginae Carter Take Shots At Lil Wayne &#038; 50 Cent For &#8220;Black Women&#8221; Comments">Reginae Carter Take Shots At Lil Wayne &#038; 50 Cent For &#8220;Black Women&#8221; Comments</a></li></div><div class="related-title"><li>
<a href="https://urbanislandz.com/2020/07/04/50-cent-rips-meek-mill-in-interview-lil-wayne-meek-respond/" rel="bookmark" title="Permanent Link to 50 Cent Rips Meek Mill In Interview With Lil Wayne, Meek Respond Calling Fif &#8220;Corny&#8221;">50 Cent Rips Meek Mill In Interview With Lil Wayne, Meek Respond Calling Fif &#8220;Corny&#8221;</a></li></div><div class="related-title"><li>
<a href="https://urbanislandz.com/2020/07/03/50-cent-blast-dj-clue-refusing-play-pop-smoke-album-rap-news/" rel="bookmark" title="Permanent Link to 50 Cent Blast DJ Clue For Refusing To Play Pop Smoke&#8217;s Album, Calls Him &#8220;Lower Case L&#8221;">50 Cent Blast DJ Clue For Refusing To Play Pop Smoke&#8217;s Album, Calls Him &#8220;Lower Case L&#8221;</a></li></div></ul></div><div class="postrelated"><div class="home-widgetized-sections"><div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3><div class="featured-grid-single"><div class="left_col_posts"><div id="post-241866" class="post-241866 post type-post status-publish format-standard has-post-thumbnail category-dancehall"><div class="post-thumb">
<a href="https://urbanislandz.com/2020/07/06/dancehall-veteran-dancer-labba-labba-is-dead-reports/" title="Dancehall Veteran Dancer Labba Labba Is Dead: Reports">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2018/09/Labba-Labba-alive-1000x600.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2018/09/Labba-Labba-alive-1000x600.jpg 1000w, https://urbanislandz.com/wp-content/uploads/2018/09/Labba-Labba-alive-200x119.jpg 200w" sizes="(max-width: 800px) 100vw, 800px" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2020/07/06/dancehall-veteran-dancer-labba-labba-is-dead-reports/" title="Dancehall Veteran Dancer Labba Labba Is Dead: Reports">Dancehall Veteran Dancer Labba Labba Is Dead: Reports</a></h3><p>Legendary dancehall dancer Labba Labba has died. In 2018, veteran Jamaican dancer Labba Labba spoke of his desired to pursue<a class="read-more" href="https://urbanislandz.com/2020/07/06/dancehall-veteran-dancer-labba-labba-is-dead-reports/">[Read More&#8230;]</a></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-241866" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/07/06/dancehall-veteran-dancer-labba-labba-is-dead-reports/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-241866" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/07/06/dancehall-veteran-dancer-labba-labba-is-dead-reports/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div><div class="entry-meta"><span class="entry-date">1 hour ago</span></div></div></div></div><ul class="right_col_posts"><li class="post-241861 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-pop-smoke tag-tekashi"><div class="post-thumb">
<a href="https://urbanislandz.com/2020/07/06/tekashi-6ix9ine-reacts-pop-smoke-gangstas-diss-beef/" title="Tekashi 6ix9ine Reacts To Pop Smoke’s &#8220;Gangstas&#8221; Diss, &#8220;Let That Man Rest&#8221;">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/02/Tekashi-6ix9ine-Pop-Smoke-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2020/07/06/tekashi-6ix9ine-reacts-pop-smoke-gangstas-diss-beef/" title="Tekashi 6ix9ine Reacts To Pop Smoke’s &#8220;Gangstas&#8221; Diss, &#8220;Let That Man Rest&#8221;">Tekashi 6ix9ine Reacts To Pop Smoke’s &#8220;Gangstas&#8221; Diss, &#8220;Let That Man Rest&#8221;</a></h3><div class="entry-meta"><span class="entry-date">2 hours ago</span></div></div></li><li class="post-241858 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-trending tag-rygin-king"><div class="post-thumb">
<a href="https://urbanislandz.com/2020/07/06/rygin-king-shooting-suspects-released-from-police-custody/" title="Rygin King Shooting Suspects Released From Police Custody">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/07/Rygin-King-3-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2020/07/06/rygin-king-shooting-suspects-released-from-police-custody/" title="Rygin King Shooting Suspects Released From Police Custody">Rygin King Shooting Suspects Released From Police Custody</a></h3><div class="entry-meta"><span class="entry-date">2 hours ago</span></div></div></li><li class="post-241849 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-music tag-juice-wrld"><div class="post-thumb">
<a href="https://urbanislandz.com/2020/07/06/juice-wrlds-posthumous-album-legends-never-die-release-date-tracklist/" title="Juice WRLD&#8217;s Posthumous Album &#8220;Legends Never Die&#8221; Release Date &#038; Tracklist">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/12/Juice-Wrld-63-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2020/07/06/juice-wrlds-posthumous-album-legends-never-die-release-date-tracklist/" title="Juice WRLD&#8217;s Posthumous Album &#8220;Legends Never Die&#8221; Release Date &#038; Tracklist">Juice WRLD&#8217;s Posthumous Album &#8220;Legends Never Die&#8221; Release Date &#038; Tracklist</a></h3><div class="entry-meta"><span class="entry-date">2 hours ago</span></div></div></li><li class="post-241842 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-50-cent tag-t-i"><div class="post-thumb">
<a href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/" title="50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-400x230.jpg 400w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-700x400.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-768x439.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-600x343.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-200x114.jpg 200w, https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I..jpg 1400w" sizes="(max-width: 400px) 100vw, 400px" /> </a></div><div class="post_content"><h3 class="entry-title"><a href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/" title="50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday">50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday</a></h3><div class="entry-meta"><span class="entry-date">6 hours ago</span></div></div></li></ul></div><div class="clear">&nbsp;</div></div></div></div><div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div><div class="clear"></div></footer><div class="clear"></div></article><div id="comments"><p class="nocomments">.</p></div></div><section id="site-sidebar"><div class="adv_side">
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins> <script>document.addEventListener("DOMContentLoaded",function(){(adsbygoogle=window.adsbygoogle||[]).push({});});</script> </div><div class="widget feature-posts" id="wpzoom-feature-posts-43"><h3 class="title">Whats Trending</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/06/tekashi-6ix9ine-reacts-pop-smoke-gangstas-diss-beef/"><img src="https://urbanislandz.com/wp-content/uploads/2020/02/Tekashi-6ix9ine-Pop-Smoke-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine Reacts To Pop Smoke’s &#8220;Gangstas&#8221; Diss, &#8220;Let That Man Rest&#8221;" /></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2020/07/06/tekashi-6ix9ine-reacts-pop-smoke-gangstas-diss-beef/">Tekashi 6ix9ine Reacts To Pop Smoke’s &#8220;Gangstas&#8221; Diss, &#8220;Let That Man Rest&#8221;</a></h3><br /><div class="entry-meta">2 hours ago<small></small> <br /></div></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/06/rygin-king-shooting-suspects-released-from-police-custody/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Rygin-King-3-120x100.jpg" height="100" width="120" alt="Rygin King Shooting Suspects Released From Police Custody" /></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2020/07/06/rygin-king-shooting-suspects-released-from-police-custody/">Rygin King Shooting Suspects Released From Police Custody</a></h3><br /><div class="entry-meta">2 hours ago<small></small> <br /></div></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/50-Cent-and-T.I.-120x100.jpg" height="100" width="120" alt="50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday" /></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2020/07/06/50-cent-ti-verzuz-birthday/">50 Cent Laughs At T.I. For Challenging Him To A Verzuz Battle On His Birthday</a></h3><br /><div class="entry-meta">6 hours ago<small></small> <br /></div></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/06/reginae-carter-take-shots-at-lil-wayne-50-cent-for-black-women-comments/"><img src="https://urbanislandz.com/wp-content/uploads/2018/11/Reginae-Carter-and-Lil-Wayne-120x100.jpg" height="100" width="120" alt="Reginae Carter Take Shots At Lil Wayne &#038; 50 Cent For &#8220;Black Women&#8221; Comments" /></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2020/07/06/reginae-carter-take-shots-at-lil-wayne-50-cent-for-black-women-comments/">Reginae Carter Take Shots At Lil Wayne &#038; 50 Cent For &#8220;Black Women&#8221; Comments</a></h3><br /><div class="entry-meta">7 hours ago<small></small> <br /></div></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/06/tommy-lee-sparta-named-person-of-interest-by-police-for-shooting-in-montego-bay/"><img src="https://urbanislandz.com/wp-content/uploads/2018/05/Tommy-Lee-Sparta-2-120x100.jpg" height="100" width="120" alt="Tommy Lee Sparta Named Person Of Interest By Police For Shooting In Montego Bay" /></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2020/07/06/tommy-lee-sparta-named-person-of-interest-by-police-for-shooting-in-montego-bay/">Tommy Lee Sparta Named Person Of Interest By Police For Shooting In Montego Bay</a></h3><br /><div class="entry-meta">9 hours ago<small></small> <br /></div></div><div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/06/popcaans-unruly-affiliate-bookha-killed-in-motorcycle-crash/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Bookha-and-Popcaan-120x100.jpg" height="100" width="120" alt="Popcaan&#8217;s Unruly Affiliate Bookha Killed In Motorcycle Crash" /></a></div><div class="post_content"><h3><a href="https://urbanislandz.com/2020/07/06/popcaans-unruly-affiliate-bookha-killed-in-motorcycle-crash/">Popcaan&#8217;s Unruly Affiliate Bookha Killed In Motorcycle Crash</a></h3><br /><div class="entry-meta">10 hours ago<small></small> <br /></div></div><div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div><div class="clear"></div></section><div class="clear"></div></main></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="inner-wrap"><div class="footer-widgets widgets"><div class="widget-areas"><div class="column"><div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3><ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded"><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/dancehallhiphop/">
<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #000000; font-size: 18px; padding:8px"></span><span class="zoom-social_icons-list__label">Facebook</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/DHHofficial">
<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #000000; font-size: 18px; padding:8px"></span><span class="zoom-social_icons-list__label">Twitter</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/dancehallhiphop/">
<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#E1306C" style="background-color : #000000; font-size: 18px; padding:8px"></span><span class="zoom-social_icons-list__label">Instagram</span>
</a></li><li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://dancehallhiphop.com/feed/">
<span class="zoom-social_icons-list-span socicon socicon-rss" data-hover-rule="background-color" data-hover-color="#1e73be" style="background-color : #000000; font-size: 18px; padding:8px"></span><span class="zoom-social_icons-list__label">Feed</span>
</a></li></ul><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li></ul></div><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3><ul><li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li><li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li><li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li><li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li><li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li></ul><div class="clear"></div></div><div class="clear"></div></div><div class="column"><div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3><div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p></div><div class="clear"></div></div><div class="clear"></div></div></div></div><div class="site-info"><div class="site-copyright">
<span class="copyright">Copyright © 2020 Urban Islandz</span></div></div></div></footer></div> <script type="text/javascript">document.addEventListener("DOMContentLoaded",function(){jQuery(document).ready(function(){jQuery.post("https://urbanislandz.com/wp-admin/admin-ajax.php",{action:"entry_views",_ajax_nonce:"5d049ed266",post_id:241842});});});</script> <script type='text/javascript'>var zoomOptions={"slideshow_auto":"1","slideshow_speed":"4000"};</script> <script type='text/javascript'>var sharing_js_options={"lang":"en","counts":"","is_stats_active":""};</script> <script type='text/javascript'>var windowOpen;jQuery(document.body).on('click','a.share-facebook',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomfacebook','menubar=1,resizable=1,width=600,height=400');return false;});var windowOpen;jQuery(document.body).on('click','a.share-twitter',function(){if('undefined'!==typeof windowOpen){windowOpen.close();}
windowOpen=window.open(jQuery(this).attr('href'),'wpcomtwitter','menubar=1,resizable=1,width=600,height=350');return false;});</script> <script async src="//www.instagram.com/embed.js"></script><script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/5664f.js"></script></body></html>

