<!DOCTYPE html>
<html lang="en-US">
<head><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">

<title>Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash - Urban Islandz</title>
<meta name="description" content="Even while he throws down with his celebrity friends at his party amidst his newfound fame in a sense, Bounty Killer does not hesitate to share the" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash - Urban Islandz" />
<meta property="og:description" content="Even while he throws down with his celebrity friends at his party amidst his newfound fame in a sense, Bounty Killer does not hesitate to share the" />
<meta property="og:url" content="https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2020-06-17T20:06:46+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="829" />
<meta property="fb:app_id" content="137673839610560" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://urbanislandz.com/#organization","name":"Urban Islandz","url":"https://urbanislandz.com/","sameAs":["https://www.facebook.com/urbanislandz","https://instagram.com/urbanislandz","https://www.youtube.com/user/CaribbeanUrbanMedia/","https://twitter.com/urbanislandz"],"logo":{"@type":"ImageObject","@id":"https://urbanislandz.com/#logo","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2018/01/Urbanislandz-logo-amp-1.png","width":300,"height":26,"caption":"Urban Islandz"},"image":{"@id":"https://urbanislandz.com/#logo"}},{"@type":"WebSite","@id":"https://urbanislandz.com/#website","url":"https://urbanislandz.com/","name":"Urban Islandz","description":"Dancehall &amp; Hip Hop","publisher":{"@id":"https://urbanislandz.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://urbanislandz.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#primaryimage","inLanguage":"en-US","url":"https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids.jpg","width":1400,"height":829},{"@type":"WebPage","@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#webpage","url":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/","name":"Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash - Urban Islandz","isPartOf":{"@id":"https://urbanislandz.com/#website"},"primaryImageOfPage":{"@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#primaryimage"},"datePublished":"2020-06-17T20:06:46+00:00","dateModified":"2020-06-17T20:06:46+00:00","description":"Even while he throws down with his celebrity friends at his party amidst his newfound fame in a sense, Bounty Killer does not hesitate to share the","breadcrumb":{"@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/"]}]},{"@type":"BreadcrumbList","@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/","url":"https://urbanislandz.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/","url":"https://urbanislandz.com/category/news/","name":"News"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/category/news/dancehall/","url":"https://urbanislandz.com/category/news/dancehall/","name":"Dancehall"}},{"@type":"ListItem","position":4,"item":{"@type":"WebPage","@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/","url":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/","name":"Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash"}}]},{"@type":"NewsArticle","@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#article","isPartOf":{"@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#webpage"},"author":{"@id":"https://urbanislandz.com/#/schema/person/cf3a3c67f8ef6b9510239d925050c43e"},"headline":"Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash","datePublished":"2020-06-17T20:06:46+00:00","dateModified":"2020-06-17T20:06:46+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#webpage"},"publisher":{"@id":"https://urbanislandz.com/#organization"},"image":{"@id":"https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/#primaryimage"},"keywords":"Bounty Killer","articleSection":"Dancehall","inLanguage":"en-US","copyrightYear":"2020","copyrightHolder":{"@id":"https://urbanislandz.com/#organization"}},{"@type":["Person"],"@id":"https://urbanislandz.com/#/schema/person/cf3a3c67f8ef6b9510239d925050c43e","name":"K.D. Anglin"}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='stylesheet' id='primenews-google-fonts-css' href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2Citalic%2C700%2C700italic%26subset%3Dlatin%2C&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='primenews-style-css' href='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css' href='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/css/media-queries.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-custom-css' href='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/custom.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://urbanislandz.com/wp-json/' />
<link rel='amphtml' href='https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/amp/' /><script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script>

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"PT Sans";
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#000000;
}
.sb-search .sb-icon-search{
	color:#000000;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"PT Sans";
	font-weight:normal;
}
.top-navbar a{
	font-family:"PT Sans";
	font-weight:normal;
}
.main-navbar a{
	font-family:"PT Sans";
	font-weight:700;
}
.slides li h3{
	font-family:"PT Sans";
	font-weight:normal;
}
.widget h3.title{
	font-family:"PT Sans";
	font-weight:700;
}
.site-footer .widget h3.title{
	font-family:"PT Sans";
	font-weight:700;
}
.entry-title{
	font-family:"PT Sans";
	font-weight:700;
}
.single h1.entry-title{
	font-family:"PT Sans";
	font-size:34px;
	font-weight:700;
}
.page h1.entry-title{
	font-family:"PT Sans";
	font-weight:normal;
}

</style>

<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-240466 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
</div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="inner-wrap">
<div class="musicad11">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-240466" class="post-240466 post type-post status-publish format-standard has-post-thumbnail category-dancehall tag-bounty-killer">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/news/dancehall/" rel="category tag">Dancehall</a></span>
<h1 class="entry-title fn">Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash</h1> <div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/ksmith/" title="Posts by K.D. Anglin" rel="author">K.D. Anglin</a></span> <span class="entry-date"> <time class="entry-date" datetime="2020-06-17T16:06:46-04:00">June 17, 2020</time> </span> </div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1400" height="829" src="https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-300x178.jpg 300w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-700x415.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-768x455.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-600x355.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-200x118.jpg 200w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-220x130.jpg 220w" sizes="(max-width: 1400px) 100vw, 1400px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/ksmith/" title="Posts by K.D. Anglin" rel="author">K.D. Anglin</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Even while he throws down with his celebrity friends at his party amidst his newfound fame in a sense, Bounty Killer does not hesitate to share the spotlight with his children.</p>
<p><a href="https://urbanislandz.com/artist/bounty-killer/">Bounty Killer</a> was already a famous high-profile dancehall celebrity, but he has been thrust into the spotlight in recent times following his impressive <a href="https://urbanislandz.com/2020/05/24/beenie-man-verzuz-bounty-killer-clash-jamaicas-dancehall-culture-the-real-winner/">Verzuz battle with Beenie Man</a>. The dancehall Godfather threw a huge birthday bash over the weekend in celebration of his 48th trip around the sun, and the unity and respect it brought into one room was refreshing. They say timing is everything, and it could not ring more true than this. The dancehall star was barely 20 years old when we first met him and now he is two years shy of hitting a half-century with a slew of hits and more than just his own nation&#8217;s respect under his belt. </p>
<p>Also in attendance at his 48th birthday bash were four of the deejay&#8217;s children. Another fact that heaps respect on Bounty Killer&#8217;s name is how he plays the role of father. Over the years, we have been privy to Bounty Killer celebrating his kids wherever he gets the chance in his interactions with the media. </p>
<p><img src="https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids.jpg" alt="" width="800" height="1187" class="aligncenter size-full wp-image-240467" srcset="https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids.jpg 800w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids-202x300.jpg 202w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids-674x1000.jpg 674w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids-768x1140.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids-600x890.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-and-his-kids-200x297.jpg 200w" sizes="(max-width: 800px) 100vw, 800px" /></p>
<p>He and his son <a href="https://urbanislandz.com/2016/08/01/bounty-killer-son-major-myjah-chris-brown-album/">Major Myjah</a> who is a hip-hop artist, had an interview with Winford Williams &#8220;Onstage,&#8221; introducing Myjah to the Jamaican people as he is based abroad. Bounty also takes great pride in his daughter&#8217;s sporting and academic achievements, often posting certificates and videos of her dominating the track. Considering his history of being a proud father, it didn&#8217;t surprise us to see his kids all in great spirits celebrating their father&#8217;s big day over the weekend.</p>
<p>Bounty took to Instagram to share a picture of himself and his kids and hearts melted at the sight of &#8220;The Killer&#8221; with his beautiful family. It seemed all the comments really echoed the same sentiment, &#8220;Congrats Mr. Price you have done well.&#8221; Not only were his biological children in attendance, but his musical bloodline also showed up, which by themselves made it a star-studded event. </p>
<p><img src="https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer.jpg" alt="" width="1080" height="1350" class="aligncenter size-full wp-image-240470" srcset="https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer.jpg 1080w, https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer-240x300.jpg 240w, https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer-700x875.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer-768x960.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer-600x750.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/06/Major-Myjah-Bounty-Killer-200x250.jpg 200w" sizes="(max-width: 1080px) 100vw, 1080px" /></p>
<p>The likes of Wayne Marshall and Bling Dawg were in attendance whom many consider his musical children. OVO signee dancehall artiste <a href="https://urbanislandz.com/2020/06/14/popcaan-koffee-beenie-man-show-out-for-bounty-killers-48-birthday-bash/">Popcaan was also among the celebrity guests</a>, and we all know his connection to Vybz Kartel, the former protege of &#8216;The Warlord&#8217; himself. It seems as if Bounty Killer&#8217;s fatherly instincts don&#8217;t stop at home, and it is evident in the help he has issued to other artistes, which in turn sees him get the endless respect he deserves. </p>
<p><img src="https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid.jpg" alt="" width="1080" height="1350" class="aligncenter size-full wp-image-240471" srcset="https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid.jpg 1080w, https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid-240x300.jpg 240w, https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid-700x875.jpg 700w, https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid-768x960.jpg 768w, https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid-600x750.jpg 600w, https://urbanislandz.com/wp-content/uploads/2020/06/Popcaan-Koffee-Unruly-Squid-200x250.jpg 200w" sizes="(max-width: 1080px) 100vw, 1080px" /></p>
<p>So respected is the man, rumors have it that his &#8220;supa surprise&#8221; phone call at the party that was captured in a photo he posted with Popcaan was none other than Bajan superstar <a href="https://urbanislandz.com/artist/rihanna/">Rihanna</a>. We can tell that the party was a splendid event, but it was also what the dancehall icon deserved after hoisting the Jamaican flag so high on many an occasion for decades. A party fit for a King or rather the Dancehall Gad.</p>
<div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/bounty-killer/" rel="tag">Bounty Killer</a></div>
<div class="related">
<div class="related-heading">More Bounty Killer News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/06/16/bounty-killer-respond-to-trolls-who-compare-his-girlfriend-to-dangel/" rel="bookmark" title="Permanent Link to Bounty Killer Respond To Trolls Who Compare His Girlfriend To D&#8217;Angel">Bounty Killer Respond To Trolls Who Compare His Girlfriend To D&#8217;Angel</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/06/15/foota-hype-bounty-killer-squash-beef-dancehall/" rel="bookmark" title="Permanent Link to Bounty Killer &#038; Foota Hype Squash Their Beef Despite Controversial Witchcraft Statement">Bounty Killer &#038; Foota Hype Squash Their Beef Despite Controversial Witchcraft Statement</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/06/14/popcaan-koffee-beenie-man-show-out-for-bounty-killers-48-birthday-bash/" rel="bookmark" title="Permanent Link to Popcaan, Koffee, Beenie Man Show Out For Bounty Killer&#8217;s 48 Birthday Bash">Popcaan, Koffee, Beenie Man Show Out For Bounty Killer&#8217;s 48 Birthday Bash</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-240483" class="post-240483 post type-post status-publish format-standard has-post-thumbnail category-non category-hip-hop tag-megan-thee-stallion">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/06/17/megan-thee-stallion-label-under-fire-sign-copycat-erica-banks/" title="Megan Thee Stallion&#8217;s Label Under Fire For Signing A &#8216;Copycat&#8217; Meet Erica Banks">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/06/Megan-Thee-Stallion-and-Erica-Banks-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2020/06/Megan-Thee-Stallion-and-Erica-Banks-800x480.jpg 800w, https://urbanislandz.com/wp-content/uploads/2020/06/Megan-Thee-Stallion-and-Erica-Banks-200x119.jpg 200w" sizes="(max-width: 800px) 100vw, 800px" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/06/17/megan-thee-stallion-label-under-fire-sign-copycat-erica-banks/" title="Megan Thee Stallion&#8217;s Label Under Fire For Signing A &#8216;Copycat&#8217; Meet Erica Banks">Megan Thee Stallion&#8217;s Label Under Fire For Signing A &#8216;Copycat&#8217; Meet Erica Banks</a></h3>
<p>Megan Thee Stallion&#8217;s old label, 1501 Certified Entertainment, is under fire for seemingly signing a copycat of her name Erica<a class="read-more" href="https://urbanislandz.com/2020/06/17/megan-thee-stallion-label-under-fire-sign-copycat-erica-banks/">[Read More&#8230;]</a></p>
<div class="entry-meta">
<span class="entry-date">10 mins ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-240475 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-chance-the-rapper tag-j-cole">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/06/17/chance-the-rapper-gave-j-cole-a-big-l-for-dissing-noname-on-new-song/" title="Chance The Rapper Gave J. Cole A Big L For Dissing Noname On New Song">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/07/Chance-the-rapper-album-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/06/17/chance-the-rapper-gave-j-cole-a-big-l-for-dissing-noname-on-new-song/" title="Chance The Rapper Gave J. Cole A Big L For Dissing Noname On New Song">Chance The Rapper Gave J. Cole A Big L For Dissing Noname On New Song</a></h3>
<div class="entry-meta">
<span class="entry-date">2 hours ago</span> </div>
</div>
</li>
<li class="post-240473 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-nicki-minaj tag-tekashi">
 <div class="post-thumb">
<a href="https://urbanislandz.com/2020/06/17/tekashi-6ix9ine-nicki-minaj-failed-to-break-youtube-record-heres-why/" title="Tekashi 6ix9ine &#038; Nicki Minaj Failed To Break YouTube Record, Here&#8217;s Why">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/06/Tekashi-and-Nicki-Minaj-trollz-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/06/17/tekashi-6ix9ine-nicki-minaj-failed-to-break-youtube-record-heres-why/" title="Tekashi 6ix9ine &#038; Nicki Minaj Failed To Break YouTube Record, Here&#8217;s Why">Tekashi 6ix9ine &#038; Nicki Minaj Failed To Break YouTube Record, Here&#8217;s Why</a></h3>
<div class="entry-meta">
<span class="entry-date">2 hours ago</span> </div>
</div>
</li>
<li class="post-240466 post type-post status-publish format-standard has-post-thumbnail category-dancehall tag-bounty-killer">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/" title="Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/06/Bounty-Killer-kids-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/06/17/bounty-killer-shares-spotlight-with-his-kids-at-star-studded-birthday-bash/" title="Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash">Bounty Killer Shares Spotlight With His Kids At Star-Studded Birthday Bash</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
<li class="post-240460 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-the-game tag-young-buck">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/06/17/the-game-donates-money-to-young-buck-amidst-bankruptcy-and-falling-out-with-g-unit/" title="The Game Donates Money To Young Buck Amidst Bankruptcy And Falling Out With G-Unit">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/06/The-Game-Young-Buck-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/06/17/the-game-donates-money-to-young-buck-amidst-bankruptcy-and-falling-out-with-g-unit/" title="The Game Donates Money To Young Buck Amidst Bankruptcy And Falling Out With G-Unit">The Game Donates Money To Young Buck Amidst Bankruptcy And Falling Out With G-Unit</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments">.</p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-43"><h3 class="title">Whats Trending</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/06/17/chance-the-rapper-gave-j-cole-a-big-l-for-dissing-noname-on-new-song/"><img src="https://urbanislandz.com/wp-content/uploads/2019/07/Chance-the-rapper-album-120x100.jpg" height="100" width="120" alt="Chance The Rapper Gave J. Cole A Big L For Dissing Noname On New Song" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/06/17/chance-the-rapper-gave-j-cole-a-big-l-for-dissing-noname-on-new-song/">Chance The Rapper Gave J. Cole A Big L For Dissing Noname On New Song</a></h3><br /><div class="entry-meta">2 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/06/17/the-game-donates-money-to-young-buck-amidst-bankruptcy-and-falling-out-with-g-unit/"><img src="https://urbanislandz.com/wp-content/uploads/2020/06/The-Game-Young-Buck-120x100.jpg" height="100" width="120" alt="The Game Donates Money To Young Buck Amidst Bankruptcy And Falling Out With G-Unit" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/06/17/the-game-donates-money-to-young-buck-amidst-bankruptcy-and-falling-out-with-g-unit/">The Game Donates Money To Young Buck Amidst Bankruptcy And Falling Out With G-Unit</a></h3><br /><div class="entry-meta">3 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/06/17/tekashi-6ix9ine-roast-meek-mill-drake-song-hit/"><img src="https://urbanislandz.com/wp-content/uploads/2019/06/Tekashi69-and-Meek-Mill-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine Roast Meek Mill To A Crisp, Says Meek Need Drake To Make A Hit" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/06/17/tekashi-6ix9ine-roast-meek-mill-drake-song-hit/">Tekashi 6ix9ine Roast Meek Mill To A Crisp, Says Meek Need Drake To Make A Hit</a></h3><br /><div class="entry-meta">5 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/06/17/nicki-minaj-respond-lil-nas-x-gay-barb-collaboration-rap/"><img src="https://urbanislandz.com/wp-content/uploads/2020/06/Nicki-Minaj-and-Lil-Nas-X-120x100.jpg" height="100" width="120" alt="Nicki Minaj Responds To Lil Nas X Saying Being Gay Was Why He Denied Being A Barb" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/06/17/nicki-minaj-respond-lil-nas-x-gay-barb-collaboration-rap/">Nicki Minaj Responds To Lil Nas X Saying Being Gay Was Why He Denied Being A Barb</a></h3><br /><div class="entry-meta">6 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/06/17/jay-z-beyonce-sued-by-iconic-jamaican-dancer-dr-lantoinette-stines-for-black-effect/"><img src="https://urbanislandz.com/wp-content/uploads/2018/06/JAY-Z-Beyonce-Apesht-120x100.jpg" height="100" width="120" alt="Jay-Z &#038; Beyonce Sued By Iconic Jamaican Dancer Dr. L&#8217;Antoinette Stines For &#8220;Black Effect&#8221;" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/06/17/jay-z-beyonce-sued-by-iconic-jamaican-dancer-dr-lantoinette-stines-for-black-effect/">Jay-Z &#038; Beyonce Sued By Iconic Jamaican Dancer Dr. L&#8217;Antoinette Stines For &#8220;Black Effect&#8221;</a></h3><br /><div class="entry-meta">6 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/06/17/j-cole-drops-a-powerful-new-song-snow-on-tha-bluff-listen-it/"><img src="https://urbanislandz.com/wp-content/uploads/2019/03/j-cole-120x100.jpg" height="100" width="120" alt="J. Cole Drops New Song “Snow On Tha Bluff” Seemingly Responds To Noname" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/06/17/j-cole-drops-a-powerful-new-song-snow-on-tha-bluff-listen-it/">J. Cole Drops New Song “Snow On Tha Bluff” Seemingly Responds To Noname</a></h3><br /><div class="entry-meta">17 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3> <ul>
<li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li>
<li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<span class="copyright">Copyright © 2020 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/init.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/jquery.slicknav.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/flickity.pkgd.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/jquery.carouFredSel-6.2.1-packed.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/jquery.fitvids.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/superfish.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/headroom.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/retina.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/jquery-ui.min.js'></script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/search_button.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://urbanislandz.com/wp-content/themes/wpzoom-prime-news/js/functions.js'></script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://urbanislandz.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "bc4353a9a5", post_id : 240466 } ); } ); /* ]]> */</script>
</body>
</html>