<!DOCTYPE html>
<html lang="en-US">
<head><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/css/d3fc5dc7aa42df7c5c801f73902af18a.css?ver=20864" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Saweetie Says &#039;Pretty B.I.T.C.H Music&#039; Is More Than An Album &quot;It&#039;s A Movement&quot; - Urban Islandz</title>
<meta name="description" content="Saweetie explains why her album is taking so long while letting fans know that she is starting a movement. The &quot;Icy Girl&quot; rapper announced that her debut" />
<link rel="canonical" href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Saweetie Says &#039;Pretty B.I.T.C.H Music&#039; Is More Than An Album &quot;It&#039;s A Movement&quot;" />
<meta property="og:description" content="Saweetie explains why her album is taking so long while letting fans know that she is starting a movement. The &quot;Icy Girl&quot; rapper announced that her debut" />
<meta property="og:url" content="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2022-07-01T16:40:08+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4.jpeg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="842" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Soje Leslie" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />

<link rel="amphtml" href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/amp/" /><style id='wp-block-library-theme-inline-css' type='text/css'>
/**
 * Colors
 */
/**
 * Breakpoints & Media Queries
 */
/**
 * SCSS Variables.
 *
 * Please use variables from this sheet to ensure consistency across the UI.
 * Don't add to this sheet unless you're pretty sure the value will be reused in many places.
 * For example, don't add rules to this sheet that affect block visuals. It's purely for UI.
 */
/**
 * Colors
 */
/**
 * Fonts & basic variables.
 */
/**
 * Grid System.
 * https://make.wordpress.org/design/2019/10/31/proposal-a-consistent-spacing-system-for-wordpress/
 */
/**
 * Dimensions.
 */
/**
 * Shadows.
 */
/**
 * Editor widths.
 */
/**
 * Block & Editor UI.
 */
/**
 * Block paddings.
 */
/**
 * React Native specific.
 * These variables do not appear to be used anywhere else.
 */
/**
*  Converts a hex value into the rgb equivalent.
*
* @param {string} hex - the hexadecimal value to convert
* @return {string} comma separated rgb values
*/
/**
 * Breakpoint mixins
 */
/**
 * Long content fade mixin
 *
 * Creates a fading overlay to signify that the content is longer
 * than the space allows.
 */
/**
 * Focus styles.
 */
/**
 * Applies editor left position to the selector passed as argument
 */
/**
 * Styles that are reused verbatim in a few places
 */
/**
 * Allows users to opt-out of animations via OS-level preferences.
 */
/**
 * Reset default styles for JavaScript UI based pages.
 * This is a WP-admin agnostic reset
 */
/**
 * Reset the WP Admin page styles for Gutenberg-like pages.
 */
.wp-block-audio figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-audio figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-code {
  border: 1px solid #ccc;
  border-radius: 4px;
  font-family: Menlo, Consolas, monaco, monospace;
  padding: 0.8em 1em;
}

.wp-block-embed figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-embed figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.blocks-gallery-caption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .blocks-gallery-caption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-image figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-image figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-pullquote {
  border-top: 4px solid currentColor;
  border-bottom: 4px solid currentColor;
  margin-bottom: 1.75em;
  color: currentColor;
}
.wp-block-pullquote cite,
.wp-block-pullquote footer, .wp-block-pullquote__citation {
  color: currentColor;
  text-transform: uppercase;
  font-size: 0.8125em;
  font-style: normal;
}

.wp-block-quote {
  border-left: 0.25em solid currentColor;
  margin: 0 0 1.75em 0;
  padding-left: 1em;
}
.wp-block-quote cite,
.wp-block-quote footer {
  color: currentColor;
  font-size: 0.8125em;
  position: relative;
  font-style: normal;
}
.wp-block-quote.has-text-align-right {
  border-left: none;
  border-right: 0.25em solid currentColor;
  padding-left: 0;
  padding-right: 1em;
}
.wp-block-quote.has-text-align-center {
  border: none;
  padding-left: 0;
}
.wp-block-quote.is-style-plain, .wp-block-quote.is-style-large, .wp-block-quote.is-large {
  border: none;
}

.wp-block-search .wp-block-search__label {
  font-weight: bold;
}

:where(.wp-block-group.has-background) {
  padding: 1.25em 2.375em;
}

.wp-block-separator.has-css-opacity {
  opacity: 0.4;
}

.wp-block-separator {
  border: none;
  border-bottom: 2px solid currentColor;
  margin-left: auto;
  margin-right: auto;
}
.wp-block-separator.has-alpha-channel-opacity {
  opacity: initial;
}
.wp-block-separator:not(.is-style-wide):not(.is-style-dots) {
  width: 100px;
}
.wp-block-separator.has-background:not(.is-style-dots) {
  border-bottom: none;
  height: 1px;
}
.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots) {
  height: 2px;
}

.wp-block-table thead {
  border-bottom: 3px solid;
}
.wp-block-table tfoot {
  border-top: 3px solid;
}
.wp-block-table td,
.wp-block-table th {
  padding: 0.5em;
  border: 1px solid;
  word-break: normal;
}
.wp-block-table figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-table figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-video figcaption {
  color: #555;
  font-size: 13px;
  text-align: center;
}
.is-dark-theme .wp-block-video figcaption {
  color: rgba(255, 255, 255, 0.65);
}

.wp-block-template-part.has-background {
  padding: 1.25em 2.375em;
  margin-top: 0;
  margin-bottom: 0;
}
</style>
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-ttf-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font' id='wpzoom-social-icons-font-genericons-woff-css' href='https://urbanislandz.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel="https://api.w.org/" href="https://urbanislandz.com/wp-json/" /><link rel="alternate" type="application/json" href="https://urbanislandz.com/wp-json/wp/v2/posts/283680" /><link rel="preload" as="image" href="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4.jpeg" />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#ffdcdc;
}
.header_misc a:hover{
	color:#ffdcdc;
}
.header_misc .navbar-wpz > .current-menu-item > a, .header_misc .navbar-wpz > .current_page_item > a{
	color:#ffdcdc;
}
.sb-search .sb-icon-search{
	color:#ffdcdc;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.top-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.main-navbar a{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.slides li h3{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:bold;
}
.site-footer .widget h3.title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-weight:normal;
}
.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.single h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
	font-size:40px;
}
.page h1.entry-title{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}

</style>


<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-PGHYXV6763"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-PGHYXV6763');
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6028873096749132" crossorigin="anonymous"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-283680 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258074" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258074"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258073" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258073"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-300x26.png" class="custom-logo" alt="Urban Islandz" srcset="https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default.png 300w, https://urbanislandz.com/wp-content/uploads/2019/02/UI-logo-default-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-11" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" title="Facebook">
<span class="screen-reader-text">facebook-alt</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" title="Twitter">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" title="Instagram">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank" title="Default Label">
<span class="screen-reader-text">feed</span>
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="color" data-hover-color="#dd3333" style="color : #ffdcdc; font-size: 16px; padding:6px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-258068" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258068"><a href="https://urbanislandz.com/category/trending/">TRENDING</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a>
<ul class="sub-menu">
<li id="menu-item-279816" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-279816"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
<li id="menu-item-279817" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279817"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
</ul>
</li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-265319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265319"><a href="https://urbanislandz.com/category/feature/">FEATURES</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="musicad11 ad-label">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<div class="inner-wrap">
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-283680" class="post-283680 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-music category-news tag-saweetie">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/hip-hop/" rel="category tag">Hip Hop</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/music/" rel="category tag">Music</a><span class="cat-links-small"> / </span><a href="https://urbanislandz.com/category/news/" rel="category tag">News</a></span>
<h1 class="entry-title fn">Saweetie Says &#8216;Pretty B.I.T.C.H Music&#8217; Is More Than An Album &#8220;It&#8217;s A Movement&#8221;</h1> <div class="entry-meta">
<span class="entry-author">By <a href="https://urbanislandz.com/author/njcuser/" title="Posts by Soje Leslie" rel="author">Soje Leslie</a></span> <span class="entry-date">On: <time class="entry-date" datetime="2022-07-01T12:40:08-04:00">July 1, 2022 12:40 PM</time> </span>
</div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAwIiBoZWlnaHQ9Ijg0MiIgdmlld0JveD0iMCAwIDEyMDAgODQyIj48cmVjdCB3aWR0aD0iMTAwJSIgaGVpZ2h0PSIxMDAlIiBmaWxsPSIjZmVmZmZmIi8+PC9zdmc+" width="1200" height="842" data-src="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4.jpeg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Saweetie" data-srcset="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4.jpeg 1200w, https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-300x211.jpeg 300w, https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-700x491.jpeg 700w, https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-768x539.jpeg 768w" data-sizes="(max-width: 1200px) 100vw, 1200px" /><noscript><img width="1200" height="842" src="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4.jpeg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="Saweetie" srcset="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4.jpeg 1200w, https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-300x211.jpeg 300w, https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-700x491.jpeg 700w, https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-768x539.jpeg 768w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/njcuser/" title="Posts by Soje Leslie" rel="author">Soje Leslie</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>Saweetie explains why her album is taking so long while letting fans know that she is starting a movement.</p>
<p>The &#8220;Icy Girl&#8221; rapper announced that her debut album <em>Pretty B.I.T.C.H Music</em>, originally set for release in the summer, is being delayed. In a lengthy post on Instagram on Thursday, <a href="https://urbanislandz.com/artist/saweetie/">Saweetie</a> shared to her Icy Family that the project won&#8217;t be available soon and noted that she is working on a masterpiece that will take some time.</p>
<p>&#8220;These past couple of years have been a growing experience for me as an artist, human, but most importantly a WOMAN,&#8221; Saweetie began the post shared on her Instagram Story.</p>
<p>&#8220;I have realized my purpose with the platform God has given me which is why I have taken my time with releasing music this time around. Through hours of self-reflection I have realized that Pretty B.I.T.C.H Music is not an album—it&#8217;s a movement. It&#8217;s a culture. It&#8217;s a language. It&#8217;s a lifestyle. We not rushing art, we taking our time! This ain&#8217;t no microwave sh*t! It&#8217;s baking &amp; it will definitely be worth the taste,&#8221; she ended.</p>
<p>Saweetie had first announced the album in June 2021, but the album has been delayed several times. Last year, she noted that she is a perfectionist and wanted the project to have as much impact as possible.</p>
<figure id="attachment_283681" aria-describedby="caption-attachment-283681" style="width: 1200px" class="wp-caption aligncenter"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMjAwIiBoZWlnaHQ9IjE3NzMiIHZpZXdCb3g9IjAgMCAxMjAwIDE3NzMiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNmZWZmZmYiLz48L3N2Zz4=" data-src="https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement.jpg" alt="" width="1200" height="1773" class="size-full wp-image-283681" data-srcset="https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement.jpg 1200w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-203x300.jpg 203w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-677x1000.jpg 677w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-768x1135.jpg 768w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-1040x1536.jpg 1040w" data-sizes="(max-width: 1200px) 100vw, 1200px" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement.jpg" alt="" width="1200" height="1773" class="size-full wp-image-283681" srcset="https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement.jpg 1200w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-203x300.jpg 203w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-677x1000.jpg 677w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-768x1135.jpg 768w, https://urbanislandz.com/wp-content/uploads/2022/07/Saweetie-statement-1040x1536.jpg 1040w" sizes="(max-width: 1200px) 100vw, 1200px" /></noscript><figcaption id="caption-attachment-283681" class="wp-caption-text">Screenshot / Saweetie IG</figcaption></figure>
<p>Earlier in February, she had shared several updates with fans, including a studio promotion with signs of the names of the artists who were going to appear on her album.</p>
<p>Among them are Dreezy, Swae Lee, and Rico Nasty.</p>
<p>Dreezy, who celebrated her birthday at the same time, had also shared how much she liked the artist.</p>
<p>&#8220;Now I&#8217;m riding for Saweetie, anybody got something to say about Saweetie y&#8217;all got a problem with me,&#8221; she said in the video.</p>
<p>Saweetie&#8217;s long-awaited album is being produced by Artistry and Warner Records. The album was originally set to be released on June 25, 2021, with tracks &#8220;Tap In,&#8221; &#8220;Back to the Streets,&#8221; featuring Jhené Aiko, &#8220;Best Friend&#8221; featuring Doja Cat, &#8220;Fast (Motion),&#8221; and &#8220;Closer&#8221; featuring H.E.R.</p>
<p>The song &#8220;Tap In&#8221; was released on June 17, 2020, as the album&#8217;s lead single and reached No.20 on the Billboard Hot 100 giving Saweetie her first top 20 single.</p>
<p>&#8220;Back to the Streets,&#8221; featuring Jhené Aiko, was released on October 23, 2020, debuted at No.73 on the Billboard Hot 100, and peaked at No. 58. It is now Gold certified by the Recording Industry Association of America.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-283680" class="share-twitter sd-button share-icon no-text" href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-283680" class="share-facebook sd-button share-icon no-text" href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/saweetie/" rel="tag">Saweetie</a></div>
<div class="related">
<div class="related-heading">More Saweetie News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/03/23/saweetie-hit-the-studio-with-swae-lee-dreezy-rico-nasty/" rel="bookmark" title="Permanent Link to Saweetie Hit The Studio With Swae Lee, Dreezy &#038; Rico Nasty">Saweetie Hit The Studio With Swae Lee, Dreezy &#038; Rico Nasty</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/02/28/nle-choppa-hung-up-on-quavos-ex-girlfriend-saweetie/" rel="bookmark" title="Permanent Link to NLE Choppa Hung Up On Quavo&#8217;s Ex-Girlfriend Saweetie">NLE Choppa Hung Up On Quavo&#8217;s Ex-Girlfriend Saweetie</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2022/02/06/taiaysha-saweetie-samples-shabba-ranks-classic-ting-a-ling-on-one-night-ting/" rel="bookmark" title="Permanent Link to Tai’Aysha, Saweetie Samples Shabba Ranks Classic &#8216;Ting-A-ling&#8217; On &#8216;One Night Ting&#8217;">Tai’Aysha, Saweetie Samples Shabba Ranks Classic &#8216;Ting-A-ling&#8217; On &#8216;One Night Ting&#8217;</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-283687" class="post-283687 post type-post status-publish format-standard has-post-thumbnail category-dancehall category-feature category-hip-hop category-news tag-popcaan tag-safaree-samuels">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/07/01/popcaan-reacts-to-safaree-wearing-tight-brief-in-new-video-hey-bwoy-yyyy/" title="Popcaan Reacts To Safaree Wearing Tight Brief In New Video: &#8220;Hey Bwoy Yyyy&#8221;">
 <img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI4MDAiIGhlaWdodD0iNDgwIiB2aWV3Qm94PSIwIDAgODAwIDQ4MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="800" height="480" data-src="https://urbanislandz.com/wp-content/uploads/2022/07/Safaree-Popcaan-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="Safaree Popcaan" loading="lazy" /><noscript><img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2022/07/Safaree-Popcaan-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="Safaree Popcaan" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/07/01/popcaan-reacts-to-safaree-wearing-tight-brief-in-new-video-hey-bwoy-yyyy/" title="Popcaan Reacts To Safaree Wearing Tight Brief In New Video: &#8220;Hey Bwoy Yyyy&#8221;">Popcaan Reacts To Safaree Wearing Tight Brief In New Video: &#8220;Hey Bwoy Yyyy&#8221;</a></h3>
<div class="entry-meta">
<span class="entry-date">22 mins ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-283595 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-kendrick-lamar">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/07/01/kendrick-lamars-diamond-encrusted-thorn-crown-cost-3-million/" title="Kendrick Lamar&#8217;s Diamond-Encrusted Thorn Crown Cost $3 Million">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/06/Kendrick-diamond-crown-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/06/Kendrick-diamond-crown-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/07/01/kendrick-lamars-diamond-encrusted-thorn-crown-cost-3-million/" title="Kendrick Lamar&#8217;s Diamond-Encrusted Thorn Crown Cost $3 Million">Kendrick Lamar&#8217;s Diamond-Encrusted Thorn Crown Cost $3 Million</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>

<li class="post-283680 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-music category-news tag-saweetie">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/" title="Saweetie Says &#8216;Pretty B.I.T.C.H Music&#8217; Is More Than An Album &#8220;It&#8217;s A Movement&#8221;">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Saweetie" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2021/06/Saweetie-4-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Saweetie" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/07/01/saweetie-says-pretty-b-i-t-c-h-music-is-more-than-an-album-its-a-movement/" title="Saweetie Says &#8216;Pretty B.I.T.C.H Music&#8217; Is More Than An Album &#8220;It&#8217;s A Movement&#8221;">Saweetie Says &#8216;Pretty B.I.T.C.H Music&#8217; Is More Than An Album &#8220;It&#8217;s A Movement&#8221;</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
<li class="post-283674 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-nicki-minaj">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/06/30/nicki-minaj-partnered-with-rap-snacks-for-barbie-que-chips-biggest-collab-since-2016/" title="Nicki Minaj Partnered With Rap Snacks For &#8216;Barbie-Que&#8217; Chips, Biggest Collab Since 2016">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/06/Nicki-Rap-Snack-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Nicki Minaj Rap Snack" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/06/Nicki-Rap-Snack-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="Nicki Minaj Rap Snack" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/06/30/nicki-minaj-partnered-with-rap-snacks-for-barbie-que-chips-biggest-collab-since-2016/" title="Nicki Minaj Partnered With Rap Snacks For &#8216;Barbie-Que&#8217; Chips, Biggest Collab Since 2016">Nicki Minaj Partnered With Rap Snacks For &#8216;Barbie-Que&#8217; Chips, Biggest Collab Since 2016</a></h3>
<div class="entry-meta">
<span class="entry-date">22 hours ago</span> </div>
</div>
</li>
<li class="post-283671 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-news tag-ddg">
<div class="post-thumb">
<a href="https://urbanislandz.com/2022/06/30/rapper-ddg-reveals-he-was-cleared-of-gun-charge-shares-arrest-footage/" title="Rapper DDG Reveals He Was Cleared Of Gun Charge, Shares Arrest Footage">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjMwIiB2aWV3Qm94PSIwIDAgNDAwIDIzMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" width="400" height="230" data-src="https://urbanislandz.com/wp-content/uploads/2022/06/DDG-rapper-1-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /><noscript><img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2022/06/DDG-rapper-1-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" loading="lazy" /></noscript> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2022/06/30/rapper-ddg-reveals-he-was-cleared-of-gun-charge-shares-arrest-footage/" title="Rapper DDG Reveals He Was Cleared Of Gun Charge, Shares Arrest Footage">Rapper DDG Reveals He Was Cleared Of Gun Charge, Shares Arrest Footage</a></h3>
<div class="entry-meta">
<span class="entry-date">23 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>
<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments"></p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">
<div class="musicad2 ad-label">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-49"><h3 class="title">Features</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/07/01/popcaan-reacts-to-safaree-wearing-tight-brief-in-new-video-hey-bwoy-yyyy/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/07/Safaree-Popcaan-140x100.jpg" height="100" width="140" alt="Popcaan Reacts To Safaree Wearing Tight Brief In New Video: &#8220;Hey Bwoy Yyyy&#8221;" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/07/Safaree-Popcaan-140x100.jpg" height="100" width="140" alt="Popcaan Reacts To Safaree Wearing Tight Brief In New Video: &#8220;Hey Bwoy Yyyy&#8221;" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/07/01/popcaan-reacts-to-safaree-wearing-tight-brief-in-new-video-hey-bwoy-yyyy/">Popcaan Reacts To Safaree Wearing Tight Brief In New Video: &#8220;Hey Bwoy Yyyy&#8221;</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/06/29/tidal-taps-sean-paul-shaggy-zj-sparks-for-reggae-day-curated-playlists/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2021/03/Shaggy-and-Sean-Paul-140x100.jpg" height="100" width="140" alt="TIDAL Taps Sean Paul, Shaggy, ZJ Sparks For Reggae Day Curated Playlists" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2021/03/Shaggy-and-Sean-Paul-140x100.jpg" height="100" width="140" alt="TIDAL Taps Sean Paul, Shaggy, ZJ Sparks For Reggae Day Curated Playlists" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/06/29/tidal-taps-sean-paul-shaggy-zj-sparks-for-reggae-day-curated-playlists/">TIDAL Taps Sean Paul, Shaggy, ZJ Sparks For Reggae Day Curated Playlists</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/06/29/r-kelly-sentenced-to-30-years-in-prison-for-sex-crimes-lawyer-to-appeal/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2019/09/R-Kelly-mug-140x100.jpg" height="100" width="140" alt="R. Kelly Sentenced To 30 Years In Prison For Sex Crimes, Lawyer To Appeal" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2019/09/R-Kelly-mug-140x100.jpg" height="100" width="140" alt="R. Kelly Sentenced To 30 Years In Prison For Sex Crimes, Lawyer To Appeal" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/06/29/r-kelly-sentenced-to-30-years-in-prison-for-sex-crimes-lawyer-to-appeal/">R. Kelly Sentenced To 30 Years In Prison For Sex Crimes, Lawyer To Appeal</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/06/29/irv-gotti-admits-tearing-up-signing-300m-deal-including-selling-masters/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2020/10/Irv-Gotti-140x100.jpg" height="100" width="140" alt="Irv Gotti Tears Up Signing $300m Deal That Includes Selling His Masters" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2020/10/Irv-Gotti-140x100.jpg" height="100" width="140" alt="Irv Gotti Tears Up Signing $300m Deal That Includes Selling His Masters" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/06/29/irv-gotti-admits-tearing-up-signing-300m-deal-including-selling-masters/">Irv Gotti Tears Up Signing $300m Deal That Includes Selling His Masters</a></h3><br />
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2022/06/29/everton-blender-feels-good-about-french-montanas-ghetto-people-song-sample/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDAiIGhlaWdodD0iMTAwIiB2aWV3Qm94PSIwIDAgMTQwIDEwMCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZlZmZmZiIvPjwvc3ZnPg==" data-src="https://urbanislandz.com/wp-content/uploads/2022/06/Blender-French-140x100.jpg" height="100" width="140" alt="Everton Blender Feels Good About French Montana&#8217;s &#8220;Ghetto People Song&#8221; Sample" /><noscript><img src="https://urbanislandz.com/wp-content/uploads/2022/06/Blender-French-140x100.jpg" height="100" width="140" alt="Everton Blender Feels Good About French Montana&#8217;s &#8220;Ghetto People Song&#8221; Sample" /></noscript></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2022/06/29/everton-blender-feels-good-about-french-montanas-ghetto-people-song-sample/">Everton Blender Feels Good About French Montana&#8217;s &#8220;Ghetto People Song&#8221; Sample</a></h3><br />
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" title="Facebook">
<span class="zoom-social_icons-list-span social-icon genericon genericon-facebook-alt" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" title="Twitter">
<span class="zoom-social_icons-list-span social-icon genericon genericon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" title="Instagram">
<span class="zoom-social_icons-list-span social-icon genericon genericon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank" title="Feed">
<span class="zoom-social_icons-list-span social-icon genericon genericon-feed" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-cat-footer-main-site-container"><ul id="menu-cat-footer-main-site" class="menu"><li id="menu-item-258080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258080"><a href="https://urbanislandz.com/category/trending/">Trending</a></li>
<li id="menu-item-258079" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258079"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-258081" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258081"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-258083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258083"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-258084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-258084"><a href="https://urbanislandz.com/category/dancehall/">Dancehall</a></li>
<li id="menu-item-258082" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-258082"><a href="https://urbanislandz.com/category/hip-hop/">Hip Hop</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-3"><h3 class="title">About</h3><div class="menu-footer-2-container"><ul id="menu-footer-2" class="menu"><li id="menu-item-258078" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258078"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li id="menu-item-258076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258076"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li id="menu-item-258077" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258077"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<div class="wpz-menu-footer"><ul id="menu-footer-legal" class="menu"><li id="menu-item-258085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258085"><a href="https://urbanislandz.com/legal-2/">Terms of Use</a></li>
<li id="menu-item-258086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-258086"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>
<span class="copyright">Copyright © 2021 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type='text/javascript' id='primenews-script-js-extra'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<script data-no-optimize="1" defer>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</script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/js/97ad905b31531d646c3e4f8e09f3008a.js?ver=20864"></script></body>
</html>
