<!DOCTYPE html>
<html lang="en-US">
<head><link rel='stylesheet' id='primenews-google-fonts-css' href='//fonts.googleapis.com/css?family=PT+Sans%3Aregular%2Citalic%2C700%2C700italic%26subset%3Dlatin%2C&#038;ver=5.4.2' type='text/css' media='all' /><link data-optimized="2" rel="stylesheet" href="https://urbanislandz.com/wp-content/litespeed/cssjs/b994d.css" /><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/86e65.js"></script><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://urbanislandz.com/xmlrpc.php">

<title>R. Kelly&#039;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops - Urban Islandz</title>
<meta name="description" content="R. Kelly&#039;s ex-girlfriend, Joycelyn Savage, is no longer facing charges of domestic battery after Azriel Clary refused to cooperate with cops. The" />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="R. Kelly&#039;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops - Urban Islandz" />
<meta property="og:description" content="R. Kelly&#039;s ex-girlfriend, Joycelyn Savage, is no longer facing charges of domestic battery after Azriel Clary refused to cooperate with cops. The" />
<meta property="og:url" content="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/" />
<meta property="og:site_name" content="Urban Islandz" />
<meta property="article:publisher" content="https://www.facebook.com/urbanislandz" />
<meta property="article:published_time" content="2020-08-01T18:13:31+00:00" />
<meta property="og:image" content="https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="789" />
<meta property="fb:app_id" content="137673839610560" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@urbanislandz" />
<meta name="twitter:site" content="@urbanislandz" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel="amphtml" href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/amp/" /><meta name="generator" content="AMP for WP 1.0.58.5" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='https://api.w.org/' href='https://urbanislandz.com/wp-json/' />

<style type="text/css" id="wpzoom-prime-news-custom-css">
.navbar-brand-wpz .tagline{
	display:none;
	font-family:"PT Sans";
}
h1, h2, h3, h4, h5, h6{
	color:#000000;
}
.header_misc a{
	color:#000000;
}
.sb-search .sb-icon-search{
	color:#000000;
}
.entry-title a{
	color:#000000;
}
.cat-links a{
	color:#eeeeee;
}
.page h1.entry-title, .single h1.entry-title{
	color:#000000;
}
.widget .title{
	color:#dd0000;
}
.site-footer{
	background-color:#000000;
	color:#ffffff;
}
.site-footer .widget .title{
	color:#ffffff;
}
.site-footer a{
	color:#daefef;
}
.site-footer a:hover{
	color:#dd3333;
}
body{
	font-family:"Helvetica Neue", Helvetica,Arial, sans-serif;
}
.navbar-brand-wpz h1{
	font-family:"PT Sans";
	font-weight:normal;
}
.top-navbar a{
	font-family:"PT Sans";
	font-weight:normal;
}
.main-navbar a{
	font-family:"PT Sans";
	font-weight:700;
}
.slides li h3{
	font-family:"PT Sans";
	font-weight:normal;
}
.widget h3.title{
	font-family:"PT Sans";
	font-weight:700;
}
.site-footer .widget h3.title{
	font-family:"PT Sans";
	font-weight:700;
}
.entry-title{
	font-family:"PT Sans";
	font-weight:700;
}
.single h1.entry-title{
	font-family:"PT Sans";
	font-size:34px;
	font-weight:700;
}
.page h1.entry-title{
	font-family:"PT Sans";
	font-weight:normal;
}

</style>

<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://urbanislandz.com/wp-content/uploads/2018/01/cropped-Urbanislandz-icon-1-270x270.png" />
<style type="text/css" id="wp-custom-css">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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-17144505-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-17144505-1');
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<meta name="msvalidate.01" content="A35A329E503632DFEFC4C86A2FD298D9" />
</head>
<body class="post-template-default single single-post postid-243727 single-format-standard wp-custom-logo">
<div class="page-wrap">
<header class="site-header">
<div class="inner-wrap">
<div class="brand-wrap">
<div class="navbar-brand-wpz">
</div>
<div class="header_misc">
</div>
</div>
</div>
<nav class="main-navbar" role="navigation">
<div class="inner-wrap">
<div class="side-panel-btn">
</div>
<div class="navbar-header-main">
<div id="menu-main-slide" class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-83084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li id="menu-item-83083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li id="menu-item-83086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li id="menu-item-237540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li id="menu-item-237541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div>
</div>
<div id="navbar-main">
<div class="logoicon">
<a href="https://urbanislandz.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="300" height="26" src="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-300x26.png" class="custom-logo" alt="Urban Islandz" itemprop="logo" srcset="https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp.png 300w, https://urbanislandz.com/wp-content/uploads/2018/02/UI-Logo-main-amp-200x17.png 200w" sizes="(max-width: 300px) 100vw, 300px" /></a> </div>
<div class="header_social1">
<div id="zoom-social-icons-widget-10" class="widget zoom-social-icons-widget">
<ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--round zoom-social-icons-list--no-labels">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">facebook</span>
<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">twitter</span>
<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">instagram</span>
<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
 <li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" target="_blank" rel="nofollow noopener">
<span class="screen-reader-text">rss</span>
<span class="zoom-social_icons-list-span socicon socicon-rss" data-hover-rule="color" data-hover-color="#dd0000" style="color : #000000; font-size: 17px; padding:8px"></span>
</a>
</li>
</ul>
</div> </div>
<div id="sb-search" class="sb-search">
<form method="get" id="searchform" action="https://urbanislandz.com/">
<input type="search" class="sb-search-input" placeholder="Enter your keywords..." name="s" id="s" />
<input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" />
<span class="sb-icon-search"></span>
</form> </div>
<div class="menu-categories-container"><ul id="menu-categories" class="navbar-wpz dropdown sf-menu"><li id="menu-item-185" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-185"><a href="https://urbanislandz.com/category/news/">NEWS</a></li>
<li id="menu-item-2347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2347"><a href="https://urbanislandz.com/category/music/">MUSIC</a></li>
<li id="menu-item-10707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10707"><a href="https://urbanislandz.com/category/videos/">VIDEOS</a></li>
</ul></div>
</div>
</div>
</nav>
<div class="clear"></div>
</header>
<div class="inner-wrap">
<div class="musicad11">
<div class="musicad112">
<style type="text/css">
.Header-Ad-Unit { display:inline-block; width: 320px; height: 100px; }
@media (max-width: 415px) { .Header-Ad-Unit { width: 320px; height: 100px; } }
@media (min-width: 765px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
@media (min-width: 980px) { .Header-Ad-Unit { width: 728px; height: 90px; } }
</style>
<ins class="adsbygoogle Header-Ad-Unit" data-ad-client="ca-pub-6028873096749132" data-ad-slot="6287109558"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
</div>
<main id="main" class="site-main" role="main">
<div class="content-area">
<article id="post-243727" class="post-243727 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-azriel-clary tag-joycelyn-savage tag-r-kelly">
<header class="entry-header"><meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<span class="cat-links"><a href="https://urbanislandz.com/category/news/hip-hop/" rel="category tag">Hip Hop</a>, <a href="https://urbanislandz.com/category/trending/" rel="category tag">Trending</a></span>
<h1 class="entry-title fn">R. Kelly&#8217;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops</h1> <div class="entry-meta">
<span class="entry-author">by <a href="https://urbanislandz.com/author/sstar/" title="Posts by Sasha Star" rel="author">Sasha Star</a></span> <span class="entry-date"> <time class="entry-date" datetime="2020-08-01T14:13:31-04:00">August 1, 2020</time> </span> </div>
</header>
<header class="entry-image">
<div class="post-thumb">
<img width="1400" height="789" src="https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage.jpg" class="attachment-loop-large-cropped size-loop-large-cropped wp-post-image" alt="" srcset="https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage.jpg 1400w, https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-300x169.jpg 300w, https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-700x395.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-768x433.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-600x338.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-200x113.jpg 200w" sizes="(max-width: 1400px) 100vw, 1400px" /> </div>
</header>
<div class="entry_wrapper">
<div class="entry-details">
<ul class="entry-meta">
<li class="post_author_side">
<a href="https://urbanislandz.com/author/sstar/" title="Posts by Sasha Star" rel="author">Sasha Star</a> <span class="entry-author">Author</span>
</li>
</ul>
</div>
<div class="post_wrapper">
<div class="entry-content">
<p>R. Kelly&#8217;s ex-girlfriend, Joycelyn Savage, is no longer facing charges of domestic battery after Azriel Clary refused to cooperate with cops.</p>
<p>The 25-year-old was placed in cuffs back in January following an altercation at the apartment she shared with <a href="https://urbanislandz.com/artist/r-kelly/">R. Kelly</a> and his other girlfriend, <a href="https://urbanislandz.com/2020/07/24/r-kellys-ex-gf-azriel-clary-pens-touching-tribute-to-joycelyn-savage-share-private-pics/">Azriel Clary</a>. The three had lived together in a luxury apartment in Trump Towers, but the two ladies began to live together on their own after the “I Believe I Can Fly” singer went to jail. When Kelly and Clary split up in December last year, she moved out, but an argument ensued with Savage when she went to fetch her things. Savage was reportedly unhappy that Clary had brought a man with her, feeling it was disrespectful to have a male in Kelly’s apartment while he was not around. Viral videos showed the women having a verbal spat that quickly devolved into a physical altercation.</p>
<p><img src="https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage.jpg" alt="" width="1080" height="1350" class="aligncenter size-full wp-image-227252" srcset="https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage.jpg 1080w, https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage-240x300.jpg 240w, https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage-768x960.jpg 768w, https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage-700x875.jpg 700w, https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage-600x750.jpg 600w, https://urbanislandz.com/wp-content/uploads/2019/11/Joycelyn-Savage-200x250.jpg 200w" sizes="(max-width: 1080px) 100vw, 1080px" /></p>
<p>At the time, Clary was pleased that her sister wife had been arrested, tweeting, “Today’s a good day to go to jail.” But it seems that she has cooled down over the past few months and has decided to drop the charges against Savage. According to the <a href="https://chicago.suntimes.com/crime/2020/7/30/21348546/r-kelly-joycelyn-savage-azriel-clary-instagram-trump-hotel-domestic-battery-chicago">Chicago Sun-Times</a>, Clary refused to co-operate with the authorities as she did not wish to pursue the case, leaving prosecutors without enough evidence to proceed.</p>
<p>The women reportedly no longer communicate due to Clary’s disownment of Kelly while Savage remains devoted to the controversial singer, but Clary did reminisce about their relationship on Savage’s birthday last week, saying that she will always love her and that the latter deserves to live her life without being in Kelly’s shadow.</p>
<p><iframe title="R. Kelly’s Girlfriends Azriel Clary and Joycelyn Savage Get Into Fist Fight" width="750" height="422" src="https://www.youtube.com/embed/yjT9lTv_4ac?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-243727" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-243727" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="clear"></div>
<footer class="entry-footer">
<div class="tag_list"><h4>Tags:</h4> <a href="https://urbanislandz.com/artist/azriel-clary/" rel="tag">Azriel Clary</a>, <a href="https://urbanislandz.com/artist/joycelyn-savage/" rel="tag">Joycelyn Savage</a>, <a href="https://urbanislandz.com/artist/r-kelly/" rel="tag">R. Kelly</a></div>
<div class="related">
<div class="related-heading">More Azriel Clary News</div>
<ul class="related-list">
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/03/24/r-kellys-ex-azriel-clary-responds-to-troll-who-called-her-a-joke/" rel="bookmark" title="Permanent Link to R. Kelly’s Ex Azriel Clary Responds To Troll Who Called Her &#8216;A Joke&#8217;">R. Kelly’s Ex Azriel Clary Responds To Troll Who Called Her &#8216;A Joke&#8217;</a></li>
</div>
<div class="related-title"><li>
<a href="https://urbanislandz.com/2020/01/09/r-kellys-girlfriend-joycelyn-savage-arrested-after-ig-live-fight-with-azriel-clary/" rel="bookmark" title="Permanent Link to R. Kelly&#8217;s Girlfriend Joycelyn Savage Arrested After IG Live Fight With Azriel Clary">R. Kelly&#8217;s Girlfriend Joycelyn Savage Arrested After IG Live Fight With Azriel Clary</a></li>
</div>
</ul>
</div>
<div class="postrelated">
<div class="home-widgetized-sections">
<div class="widget wpzoom-featured-cat" id="wpzoom-featured-cat-25"><h3 class="title"><a href="https://urbanislandz.com/category/news/">Trending</a></h3>
<div class="featured-grid-single">
<div class="left_col_posts">
<div id="post-243730" class="post-243730 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-tekashi">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/" title="Tekashi 6ix9ine Back On Instagram As House Arrest Ends Today">
<img width="800" height="480" src="https://urbanislandz.com/wp-content/uploads/2020/05/Tekashi-6ix9ine-cars-800x480.jpg" class="attachment-loop-large size-loop-large wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/" title="Tekashi 6ix9ine Back On Instagram As House Arrest Ends Today">Tekashi 6ix9ine Back On Instagram As House Arrest Ends Today</a></h3>
<p>Tekashi 6ix9ine is getting ready to start trolling Meek Mill on Instagram as his house arrest official comes to an<a class="read-more" href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/">[Read More&#8230;]</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-243730" class="share-facebook sd-button share-icon" href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-243730" class="share-twitter sd-button share-icon" href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-end"></li></ul></div></div></div>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</div>
</div>
<ul class="right_col_posts">
<li class="post-243727 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-azriel-clary tag-joycelyn-savage tag-r-kelly">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/" title="R. Kelly&#8217;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/" title="R. Kelly&#8217;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops">R. Kelly&#8217;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops</a></h3>
<div class="entry-meta">
<span class="entry-date">3 hours ago</span> </div>
</div>
</li>
<li class="post-243723 post type-post status-publish format-video has-post-thumbnail category-dancehall category-videos tag-jesse-royal tag-kabaka-pyramid tag-munga-honorable tag-royal-blu tag-runkus post_format-post-format-video">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/08/01/runkus-jesse-royal-royal-blu-kabaka-pyramid-munga-honorable-team-up-on-5gs-listen-it/" title="Runkus, Jesse Royal, Royal Blu, Kabaka Pyramid &#038; Munga Honorable Team Up On &#8220;5Gs&#8221;: Listen It">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/08/Munga-Runkus-Royal-Blu-Jesse-Kaka-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/08/01/runkus-jesse-royal-royal-blu-kabaka-pyramid-munga-honorable-team-up-on-5gs-listen-it/" title="Runkus, Jesse Royal, Royal Blu, Kabaka Pyramid &#038; Munga Honorable Team Up On &#8220;5Gs&#8221;: Listen It">Runkus, Jesse Royal, Royal Blu, Kabaka Pyramid &#038; Munga Honorable Team Up On &#8220;5Gs&#8221;: Listen It</a></h3>
<div class="entry-meta">
<span class="entry-date">5 hours ago</span> </div>
</div>
</li>
<li class="post-243720 post type-post status-publish format-standard has-post-thumbnail category-hip-hop tag-tahiry-jose tag-vado">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/08/01/vado-tells-his-side-of-the-story-says-tahiry-is-also-abusive-towards-him/" title="Vado Tells His Side Of The Story Says Tahiry Is Also Abusive Towards Him">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/07/Vado-and-Tahiry-400x230.jpg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/08/01/vado-tells-his-side-of-the-story-says-tahiry-is-also-abusive-towards-him/" title="Vado Tells His Side Of The Story Says Tahiry Is Also Abusive Towards Him">Vado Tells His Side Of The Story Says Tahiry Is Also Abusive Towards Him</a></h3>
<div class="entry-meta">
<span class="entry-date">5 hours ago</span> </div>
</div>
</li>
<li class="post-243717 post type-post status-publish format-standard has-post-thumbnail category-hip-hop category-trending tag-koffee">
<div class="post-thumb">
<a href="https://urbanislandz.com/2020/07/31/koffee-eyes-second-reggae-grammy-as-she-readies-new-album/" title="Koffee Eyes Second Reggae Grammy As She Readies New Album">
<img width="400" height="230" src="https://urbanislandz.com/wp-content/uploads/2020/02/Koffee-52-400x230.jpeg" class="attachment-loop-cols size-loop-cols wp-post-image" alt="" /> </a>
</div>
<div class="post_content">
<h3 class="entry-title"><a href="https://urbanislandz.com/2020/07/31/koffee-eyes-second-reggae-grammy-as-she-readies-new-album/" title="Koffee Eyes Second Reggae Grammy As She Readies New Album">Koffee Eyes Second Reggae Grammy As She Readies New Album</a></h3>
<div class="entry-meta">
<span class="entry-date">19 hours ago</span> </div>
</div>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div></div> </div>
</div>

<div class="OUTBRAIN" data-widget-id="TF_1" data-src=" " data-ob-template="UrbanIslandzMedia"></div>
<div class="clear"></div>
</footer>
<div class="clear"></div>
</article>
<div id="comments">
<p class="nocomments">.</p>
</div>
</div>
<section id="site-sidebar">
<div class="adv_side">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6028873096749132" data-ad-slot="8708975959"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="widget feature-posts" id="wpzoom-feature-posts-43"><h3 class="title">Whats Trending</h3><ul class="feature-posts-list"><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/"><img src="https://urbanislandz.com/wp-content/uploads/2020/05/Tekashi-6ix9ine-cars-120x100.jpg" height="100" width="120" alt="Tekashi 6ix9ine Back On Instagram As House Arrest Ends Today" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/08/01/tekashi-6ix9ine-back-on-instagram-as-house-arrest-ends-today/">Tekashi 6ix9ine Back On Instagram As House Arrest Ends Today</a></h3><br /><div class="entry-meta">3 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/"><img src="https://urbanislandz.com/wp-content/uploads/2019/11/R-Kelly-and-Joycelyn-Savage-120x100.jpg" height="100" width="120" alt="R. Kelly&#8217;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/08/01/r-kellys-ex-gf-joycelyn-savage-charges-dismissed-azriel-clary-refused-to-cooperate-with-cops/">R. Kelly&#8217;s Ex-GF Joycelyn Savage Charges Dismissed, Azriel Clary Refused To Cooperate With Cops</a></h3><br /><div class="entry-meta">3 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/31/koffee-eyes-second-reggae-grammy-as-she-readies-new-album/"><img src="https://urbanislandz.com/wp-content/uploads/2020/02/Koffee-52-120x100.jpeg" height="100" width="120" alt="Koffee Eyes Second Reggae Grammy As She Readies New Album" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/07/31/koffee-eyes-second-reggae-grammy-as-she-readies-new-album/">Koffee Eyes Second Reggae Grammy As She Readies New Album</a></h3><br /><div class="entry-meta">19 hours ago<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/31/rihanna-assured-navy-new-music-is-still-coming-despite-r9-lengthy-delay/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Rihanna-1-120x100.jpg" height="100" width="120" alt="Rihanna Assured Navy New Music Is Still Coming Despite R9 Lengthy Delay" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/07/31/rihanna-assured-navy-new-music-is-still-coming-despite-r9-lengthy-delay/">Rihanna Assured Navy New Music Is Still Coming Despite R9 Lengthy Delay</a></h3><br /><div class="entry-meta">July 31, 2020<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/31/why-drake-and-mavado-beefing-everything-you-should-know/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Drake-and-Mavado-120x100.jpg" height="100" width="120" alt="Why Drake And Mavado Beefing? Everything You Should Know" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/07/31/why-drake-and-mavado-beefing-everything-you-should-know/">Why Drake And Mavado Beefing? Everything You Should Know</a></h3><br /><div class="entry-meta">July 31, 2020<small></small> <br /></div>
</div>
<div class="clear"></div></li><li><div class="post-thumb"><a href="https://urbanislandz.com/2020/07/30/hip-hop-producer-jw-lucas-dragged-on-twitter-over-breonna-taylor-tweets/"><img src="https://urbanislandz.com/wp-content/uploads/2020/07/Lucas-Breonna-Taylor-120x100.jpg" height="100" width="120" alt="Hip Hop Producer JW Lucas Dragged On Twitter Over Breonna Taylor Tweets" /></a></div>
<div class="post_content">
<h3><a href="https://urbanislandz.com/2020/07/30/hip-hop-producer-jw-lucas-dragged-on-twitter-over-breonna-taylor-tweets/">Hip Hop Producer JW Lucas Dragged On Twitter Over Breonna Taylor Tweets</a></h3><br /><div class="entry-meta">July 30, 2020<small></small> <br /></div>
</div>
<div class="clear"></div></li></ul><div class="clear"></div><div class="clear"></div></div>
<div class="clear"></div>
</section>
<div class="clear"></div>
</main>
</div>
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="inner-wrap">
<div class="footer-widgets widgets">
<div class="widget-areas">
<div class="column">
<div class="widget zoom-social-icons-widget" id="zoom-social-icons-widget-7"><h3 class="title">Follow us</h3>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/urbanislandz" rel="nofollow noopener">
<span class="zoom-social_icons-list-span socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://urbanislandz.com/feed/" rel="nofollow noopener">
<span class="zoom-social_icons-list-span socicon socicon-feedburner" data-hover-rule="background-color" data-hover-color="#dd3333" style="background-color : #000000; font-size: 18px; padding:8px"></span>
<span class="zoom-social_icons-list__label">Feed</span>
</a>
</li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_nav_menu" id="nav_menu-2"><h3 class="title">Category</h3><div class="menu-categories-footer-container"><ul id="menu-categories-footer-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-83084"><a href="https://urbanislandz.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83083"><a href="https://urbanislandz.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83086"><a href="https://urbanislandz.com/category/videos/">Videos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237540"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237541"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
</ul></div><div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_pages" id="pages-3"><h3 class="title">About Us</h3> <ul>
<li class="page_item page-item-331"><a href="https://urbanislandz.com/about-us/">About Us</a></li>
<li class="page_item page-item-2036"><a href="https://urbanislandz.com/advertise/">Advertise</a></li>
<li class="page_item page-item-2352"><a href="https://urbanislandz.com/contact/">Contact Us</a></li>
<li class="page_item page-item-2032"><a href="https://urbanislandz.com/legal-2/">Legal</a></li>
<li class="page_item page-item-2034"><a href="https://urbanislandz.com/privacy-policy/">Privacy Policy</a></li>
</ul>
<div class="clear"></div></div> <div class="clear"></div>
</div>
<div class="column">
<div class="widget widget_text" id="text-96"><h3 class="title">Urbanislandz.com</h3> <div class="textwidget"><p>Urban Islandz is a leader for dancehall and hip hop content. Find the latest news, new music, and videos right here daily.</p>
</div>
<div class="clear"></div></div> <div class="clear"></div>
</div>
</div>
</div>
<div class="site-info">
<div class="site-copyright">
<span class="copyright">Copyright © 2020 Urban Islandz</span>
</div>
</div>
</div>
</footer>
</div>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://urbanislandz.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "742f25d059", post_id : 243727 } ); } ); /* ]]> */</script>
<script type='text/javascript'>
/* <![CDATA[ */
var zoomOptions = {"slideshow_auto":"1","slideshow_speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script><script data-optimized="1" src="https://urbanislandz.com/wp-content/litespeed/cssjs/5ed9b.js"></script></body>
</html>
